"There's an issue with the installer service" error while downloading Komplete bundle

ProfessorChaos
ProfessorChaos Member Posts: 129 Advisor
edited February 2023 in Native Access

Almost every time I open Native Access, on top of the annoyance that is to type in my system password (only virtual instrument manager that requires that), most times I get error messages like "There's an issue with the installer service. To resolve this issue, try restarting Native Access. If this doesn't work, restart your computer and try again."

I got this months ago when I was trying to install my Komplete 9 package, which stopped several times, then almost every time I had to install some 3rd party instrument that uses Kontakt. But OK, not the end of the world.

Last night I bought Komplete 14 CE, which is a massive download of over 1 TB, so I clicked on the Install All button and went to bed. I was really excited that today I was going to get to try at least a few of the instruments, especially the film scoring ones.

This morning I turn on the monitor and see that it had only downloaded about 4 items, and the rest were stalled, showing this lovely message on the top right:

This is pathetic, Native Instruments. Native Access was a disaster at the beginning, then slowly got a bit better, but now it's back to being a disaster.

And I know the first thing many people are going to say is "It's your internet connection", because it's always the customer's problem, never the company. I can't say I have a deluxe connection like 1 Tb Fiber from AT&T or similar, but I have a decent cable connection, at least when it comes to the download speed, because the upload is a pathetic 10 Mbps, artificially capped by Spectrum.

But at over 350 Mbps downstream, things download pretty fast, and I hardly ever have interruptions or time outs. But to be sure, I tested the speed from my location in the east coast of the US to where NI is located in the US, Los Angeles, and to their HQ in Berlin:

So the upload speed for servers far away may be pathetic, much worse than the 10 Mbps I get for local ones, but you can see the download speeds for both are very decent, and every other product manager or installer never gave me a download issue. That includes the Eastwest installer, which I used to download the full Hollywood Orchestra Diamond Plus edition, which is close to 1 TB and I left downloading overnight to find it all installed the next morning.

And I had a problem downloading Hans Zimmer strings from Spitfire, but their installer has a setting to enable or disable Cloudfront, and once I disabled that, all 248 GB downloaded pretty fast.

So Native Instruments, please fix this. So far I was only able to install 8 products from the whole suite, and I'm really excited to start learning them and making music with them, but it stalled again even while typing this post:

So how long is it going to take me to download the whole bundle? Days? Weeks? Don't you think it shouldn't be this hard?

Best Answer

«13

Answers

  • ProfessorChaos
    ProfessorChaos Member Posts: 129 Advisor

    These are all the screenshots I took since this morning when I woke up to find just 8 products installed. Right now I still have 193 left to install and I have to leave for the whole afternoon, so I'm guessing when I get back I will find it installed maybe 8 more at best. The first available in the list is Choir-Omnia, so we're at the "C" and I have to go all the way down to "Y".

    At least when this came in optical discs, it took a few hours, but it was reliable. Now it's a joke. It's either Native Access that is garbage, or they don't pay for good enough servers, because everybody is having this problem, which is easy to check online doing a simple search.

    So how long is it going to be until I have the whole suite? A week, maybe, of me having to keep an eye on it all the time to see when it stalls? Regardless of the cheap servers NI has, Native Access is terrible. It could at least retry every minute and when the servers are up again, it resumes.

    It's completely unacceptable that someone who paid over a thousand dollars for a downloadable product has to babysit the downloader app from that company to make sure it's downloading it.

    Screenshot 2023-02-16 at 9.53.47 AM

    Screenshot 2023-02-16 at 10.27.53 AM

    Screenshot 2023-02-16 at 11.30.14 AM

    Screenshot 2023-02-16 at 12.45.14 PM

    So that's 4 times in a few hours. And every time, I have to close it, open it again typing the system password, click on the "available" tab, and then click on install all, and about an hour later, do it all over again.

    Why can't software companies have better QC for their programs? And how is it that this has been going on for at least a year and they haven't fixed it?

  • Vocalpoint
    Vocalpoint Member Posts: 691 Pro
    edited February 2023

    Professor,

    "At least when this came in optical discs, it took a few hours, but it was reliable. Now it's a joke. It's either Native Access that is garbage, or they don't pay for good enough servers, because everybody is having this problem, which is easy to check online doing a simple search."

    I think you are generalizing a lot with these statements. I read your first post about an hour ago and then I thought I would try to install a half dozen products from my own Komplete 14 ULT package - some large, some smaller - all worked fine in a timely manner.

    And you should give some thought to understanding exactly where you are and where these files are in the real world. Assuming that you are downloading from LA or Germany is most likely not the case. They could be in cloud location 5 miles from you or 5000 miles from you.

    And remember too - just because SpeedTest says you are rocking a 350MBPS connection that does not mean you are GETTING 350MBPS to the actual file locations. I can tell by the ping rate and other details in your screen caps that there could be all sorts of hoops to jump through on your specific route to the NI servers.

    ANYTHING could be holding up the parade if you need to make 15 hops from your place to the actual location of the files. Jeez - Spectrum could be doing some work to their network that you might have no clue is happening. Or you and 18 of your neighbours are overloading the local POP connection down the street - you just do not know for sure.

    I know you do not want to accept the fact that your connection is not at fault - but I can tell you with 100% certainty that Native Access is running fast and furious here - and it is definitely not the NA 2 software at fault. I am also on Windows and have had no issues at all with NA2 since it was released.

    VP

  • DunedinDragon
    DunedinDragon Member Posts: 280 Pro

    I can't say I've had any real serious problems with Native Access, but I'm fairly new to the Kontakt eco-system. I tend to do individual download/installs. Some larger instruments may take a while but they always complete eventually. The only problem I've ever had was last week when I tried to do the updated release on Kontakt 7 on the day it was released. That took a while and the screen didn't properly update the status, but then I was probably competing with a ton of other people doing the upgrade. I eventually killed the app and restarted it and that's when I discovered it had completed the installation..it just hadn't updated the processes on the screen.

    I use lots of different installers from many different vendors such as Pulse, Spitfire, 8Dio Toontrack, etd. and Native Access seems to be one of the more efficient and reliable ones I've encountered.

  • Ed M
    Ed M Member Posts: 139 Advisor

    Experience has learned me to avoid the "install all" option. I agree something seems not to be optimized with the install through NA. It takes longer, but installing a few smaller Instruments at the same time and the bigger ones one at a time never gave me problems.

  • ProfessorChaos
    ProfessorChaos Member Posts: 129 Advisor

    No, dude. You are defending the indefensible. My connection is perfectly fine. I don't care to defend my connection. I'm not the internet provider. That's Spectrum, a company I despise just like I despised it when it was Time Warner Cable because they are a monopoly in many parts of the country like where I live, and they keep raising the price every 6 to 12 months, and they cap their upstream to 10 Mbps, so when I started paying Apple for 2 TB of cloud space, and I uploaded my DSLR collection, it took about a week. So I don't defend my connection because it's a great company. It's not, it's despicable, and it's just like that South Park episode from many years ago, and that SNL sketch.

    But as far as the connection itself, maybe it goes out twice a year for an hour at worst. And the 350 Mbps are real, if I download from good servers. If I'm getting Apple updates, or anything that is stored in AWS servers, or things like that, the download is really fast. And I have downloaded things from all over the world. If the server is fast and reliable, the download is fast, period. And it doesn't stall.

    This is nothing more than a typical company trying to maximize profits by saving money in costs somewhere, and Native Instruments does that by either contracting with companies that have ****** servers, or they run them themselves. However, the servers themselves are not the biggest problem here. They could keep the same exact server setup they have now and still not get customer irate, if they had written a well designed and coded program instead of that joke that is Native Access.

    Because if you tell me that the servers are mediocre and they stall every hour or so, but the program keeps trying and a minute or two later resumes the download, I wouldn't be complaining. But when their software is so poorly designed (and this is a very common problem with software in general) that when the server has a hiccup, instead of retrying every minute or so until it's up again, it shows you the Cylon bar going left and right, and it never does anything else, leaving the user with no choice but to close the program, then reopen it, which at least in macOS requires the user to enter the system password EVERY-FRACKING-TIME, then going to the "available" tab and click again on "install all", and you have to do this dozens of times, because so far I think I have like 20 to 25% of the whole thing, and it's been about five times that I got that same message, then that's really pathetic software. It's like it's been designed and coded by people took a coding course online and started a month ago. Because there's no defense for writing something so pathetic that takes like a minute to load (and it used to take like 3) on a Mac Studio Ultra, forces you to enter the system password every time, and also can't handle a simple server glitch.

    Maybe I was wrong when I said that my connection didn't have any issues, what I mean is that I haven't noticed any issues like this with any other installer software of this kind. But maybe their server or my connection has a moment when it disconnects for a second or two, but the software is designed well enough that it won't stall forever if the server or the user connection has a glitch and stops transferring the file for a second.

    Before I left this afternoon about 5 hours ago, I remember that I was on the letter "C". Choir Omnia was downloading, and had failed at least once. So right before I left, I did the same process all over again, and Choir Omnia started downloading.

    When I came back about an hour, this is what I see:

    And this time actually I took a screen recording of just that part, because by now this is so pathetic and funny that I will make the white line red and I will add the Cylon woosh. So as of now, I still have 179 items to install. In a package that my connection is perfectly capable of downloading in full in one night, and I know this because like I mentioned in my post, a few months ago I downloaded the Eastwest Hollywood Orchestra Opus or Diamond something edition, very close to 1 TB, without any issues. Next morning it was installed.

    Now, all of this wouldn't mean squat if it happened to me and only me, and I found no other people with the same problem. So here, for your reading enjoyment:

    In another thread, check out this post:

    JohnnyC Member Posts: 1 Noise

    January 1 edited January 1

    I am getting the same issue here, been nearly 24 hrs trying to install Komplete 14 and it is not even halfway through, as everyone else, it will install a few then just hang and this message appears.

    (There’s an issue with the installer service, try restarting Native Access. If this doesn’t work , restart your computer and try again) 

    all permissions granted, tried many many restarts, still the same

    the error appears just after it starts the install at the point where it puts the installer on the desktop, the error appears if the installer is not successfully mounted on the desktop, then I have to restart native access again :(

    2018 Mac mini i7 6 core, 64gb memory. Monterey 12.6.2. Native Access 3.1.0

    ---------------------------------------------------------------------------------------------------------------------------------

    Sounds familiar? Read the full thread if you want: https://community.native-instruments.com/discussion/6349/native-access-2-continues-to-give-installation-error

    https://community.native-instruments.com/discussion/9481/help-native-access-is-broken-wont-finish-install-of-products#latest

    And I'm sure there's many many more. The reality is that Native Access is just garbage code, and until NI does something about it, us users are going to have to waste hours and days because of that.

  • ProfessorChaos
    ProfessorChaos Member Posts: 129 Advisor

    Oh, surprise, surprise. Maybe by the end of 2023 I will have finished installing Komplete 14 Collector's Edition.


  • ProfessorChaos
    ProfessorChaos Member Posts: 129 Advisor

    Seriously, Native Instruments. This is absolute garbage. I'm not saying this for being mean, I really wish you had written a downloader and installer that works at least as well as the other companies that sell this kind of product. But you just didn't think it through, and I hope the coders that did this are not the same that did the actual products that get installed. Because this is just another level of crappiness.

    I thought, since I was only installing a handful of instruments at a time, why not try to uninstall it, download it again, and then install a fresh version, even if I had the latest one.

    Well, as far as uninstalling, you don't provide an uninstaller, so I had to launch Find Any File and delete every single result after searching for "Native Access". After that, I restarted my Mac, went to your website, download Native Access again, installed it, and this time, just fed up with going down the list alphabetically, I wanted to install some of the libraries that I'm really excited about, the Stradivari Violin, for which you have a really well done walkthrough on YouTube. Then the Cello and all the other Symphony series libraries.

    So that's just about 6 or 7 products? Maybe not even a minute after I set them to download, then poor coding rears its ugly head again:

    So once again, this must be the 12th time since I bought K14 last night, I close and launch Native Access AGAIN!!

    This time I only select the Stradivari Violin and hope for the best, while my experience tells me to expect the worst. And lo and behold:

    Then just a couple of minutes later, when it only had a few minutes left:

    It's hard to think of piece of software that is more pathetic than this. And again, not saying this to be mean, it's just reality. I don't when the hell am I going to have the product I paid a lot of money for, because the company that makes it didn't pay any attention to the delivery. It's like buying a very expensive piano, and the company delivers it in a Yugo with flat tires. Native Access is the software version of a Yugo.

  • ProfessorChaos
    ProfessorChaos Member Posts: 129 Advisor

    And again!!


  • ProfessorChaos
    ProfessorChaos Member Posts: 129 Advisor

    But of course...


  • ProfessorChaos
    ProfessorChaos Member Posts: 129 Advisor

    Well, that would be terrible in itself, but let's say the solution is to add 5 at a time to the queue. Well, for the past four hours I only added the Stradivari Violin and it stalled about 6 times, and still does.

    So that's not a solution I'm afraid. The solution is for NI to fire whoever wrote this piece of garbage, and hire a software engineer that can build a whole new downloader and installer app that works.

  • ProfessorChaos
    ProfessorChaos Member Posts: 129 Advisor

    To make things ever weirder, I had an idea; to delete Native Access again (I can't call it uninstalling exactly because there's no uninstaller, I had to manually delete like 30+ files all over the drive), but this time install Native Access 1 instead.

    AND IT WORKED!!

    As awful as Native Access 1 is, since it also asks you for the system password not just once, but twice or thrice, and it has other annoyances, it doesn't stall!! It downloads everything without complaining, stalling or anything.

    The interface is more basic, it only shows the download there in the tile that has the instrument, but I went to sleep after queueing a lot of the big size libraries that are over 20 GB, and when I woke up, they were downloaded and installed.

    I didn't do an Install All because it told me that I didn't have enough disk space, since I had some Time Machine temp files that were taking up like 700 GB, and even after deleting those, it still needed another 200 GB and I honestly didn't know what else to clean, because I had been cleaning up space to get to over the 1.2 TB it says on the website.

    But it's fine, I downloaded the things I wanted the most, and I'll keep downloading the rest over the weekend.

    So let me ask you, Native Instruments, how is it that I have a Mac Studio, a machine that is exclusively M1, because it never had an Intel chip. And you make a version of Native Access for Apple Silicon, and you screw it up so badly that it doesn't work, yet, the one you had made for the Intel Macs, does work, even if it's still a royal PITA to use.

    Do you know what QC is? It stands for Quality Control. It's that thing when you test the hell out of something before releasing it. You might want to implement that.

    And you might also want to change the way you think and put yourselves in the perspective of the customer, and ask yourselves, do customers enjoy having to type their system password every time they launch NA, especially for now that they have to use the first version that pesters you to enter it several times?

  • ProfessorChaos
    ProfessorChaos Member Posts: 129 Advisor

    So finally, using the downloader installer that was made for older Macs with Intel CPUs, I was able to download the full suite since last night, a few at a time when it came to the large ones, and eventually I had like 100 left that were small, and I say screw it, I left them all downloading, and I started watching a movie.

    The next time I checked, all of them had finished.

    So I have a Mac that has an M1 chip, and NI makes an app specifically for that chip and it doesn't work at all, because at best you can download the small size products a few at a time, and forget about anything that is over 1 GB.

    But the app that they had made for Intel Macs, that one works perfectly. So what the hell is going on?

  • ebber
    ebber Member Posts: 11 Member

    Same problem here with brand new Mac Book Pro...

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin

    Hi @ProfessorChaos really sorry for the inconveniences here. I can confirm that there was an issue related to the download queue that triggered the "Installer service..." error message. The underlying cause of that issue was fixed with Native Access 3.2.0 update, released earlier this week.

    Can you please update NA? This should resolve the issue.

Back To Top