Welcome to the new and improved Native Instruments online community. Join our active forum of 40,000+ members for discussions and much more.

Native Access 2 continues to give installation error

nbtwmusic
nbtwmusic Member Posts: 1 Noise
edited January 16 in Native Access

Hi!

I keep receiving this error message when try to install multiple plug-ins at a time. “There’s an issue with the installer service to resolve this issue try restarting native access.” Or I keep having plug ins completely fail to install. I use a Mac 2017 with the most recent update. I’ve granted full disk access, I’ve restarted the app, I’ve deleted the installers of the failed plug ins and re-downloaded. But nothing is working, any other troubleshooting advice? I’m desperate for a quick fix.

Tagged:

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 4,459 mod
    edited January 16 Answer ✓

    @JohnnyC @mrkeeny @oliverwalsh @TonyByte Keep in mind that it's a user forum, not a substitute for support. Please get in touch with our installation specialists here: http://bit.ly/NIsupport_install

    I will also close this thread as the title is too general and might be confusing for users affected with similar issues but not with the exact error message as the OP.

«1

Answers

  • victorp.sg
    victorp.sg Member Posts: 32 Tri

    Have you also tried restarting your Mac computer?

  • PhatMonkey
    PhatMonkey Member Posts: 8 Sine

    I am having the same problem on Windows 11, takes over 1 min to load the app then gives the installer service error msg.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 4,459 mod

    @nbtwmusic @PhatMonkey Could you post screenshots of the error message ?

  • PhatMonkey
    PhatMonkey Member Posts: 8 Sine

    Hi NA updated today, not seen the same error, the only problem that remains now is that NA takes ages to load or do anything :)

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 4,459 mod

    The new version of Native Access 2.6.2 took care of this issue. The team is still working on these loading times.

  • stans
    stans Member Posts: 12 Sine

    Same issue on MacOS Catalina here. Repeating failures on new installs and occasionally, the "installer service" failing message pops up. I've also granted full disk access to NTKdaemon and Native Access (2.6.1).

    I've restarted more than once and continue to get this error.


  • Drewcipher
    Drewcipher Member Posts: 1 Noise
    edited December 2022

    I'm having this same issue with Native Access v3.1. Just started happening today. Anyone have any ideas?

    Running MacOS Monterey with an M1 Pro chip.

  • 6xes
    6xes Member Posts: 173 Saw

    have you given full disk access to Native acces and the Ntk daemon inside of security&privacy??

    finder>system preferences>security&privacy

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 4,459 mod

    @Drewcipher This thread is from a few months, what is the errror message? Can you post a screenshot of that error message? As @6xes mentioned, have you given Full Disk Access to Native Access and the NTKDaemon? If these items don't appear in the list, click the plus (+) symbol and add them from:

    Macintosh HD > Applications > Native Access

    Macintosh HD > Library > Application Support > Native Instruments > NTK > NTKDaemon

  • djv5010
    djv5010 Member Posts: 5 Sine
    edited December 2022

    I'm also having this issue. I've given full disk access to both Native Access and NTKDaemon and things download just fine for about 10 minutes, then I get the error described in the OP here (and screenshot by stans above) and I have to restart Native Access.

    Mac Studio, M1 - Monterey

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 4,459 mod

    @djv5010 What version of Native Access are you using? Make sure to use the latest one (3.1.0) https://www.native-instruments.com/en/specials/native-access-2/

    Some users fixed the issue by restarting Native Access, restarting their computer. Please also check these points as it has helped other users with the same issue: Native Access Error: "Waiting for connection"

  • djv5010
    djv5010 Member Posts: 5 Sine

    I'm using Native Access 3.1.0 and I have restarted Native Access and my computer about 15 times. I've run through all of those check points from this link and it's still occurring.

    The only odd thing is that there is a red outline around my Application Location in file management.




    But libraries are downloading just fine - it's just that after 5 or 6 of them download, i get the error message saying I need to restart. I restart and then it works fine again for a few library installs, then same message.


  • zenkick
    zenkick Member Posts: 1 Noise
    edited December 2022

    Same exact issue as @djv5010. Native Access and NTK Daemon both have full disk access.

    A few expansions/libs will queue+download+install without issue, then I receive the error.

    Rinse. Repeat.

    Reboot has no impact on the behavior.

    Ventura 13.1. NA 3.1.0. 1GB Fiber demarcation. Ethernet on new MBP 4TB/64GB.

  • djv5010
    djv5010 Member Posts: 5 Sine

    Does Native Access 2 require Rosetta? Because it shouldn’t but perhaps that’s the issue?

  • elxsound
    elxsound Member Posts: 3 Sine

    Same problem. This is a dumb issue. Native Access 3.1.0

    It'll download multiple libraries. It'll then install multiple libraries before showing the same message as @djv5010


    Additionally, upon restarting Native Access I'll get another dependency warning. I then re-install the NTKDaemon and success. NA 3.1.0 then opens correctly, and again, it begins installing a few libraries before showing another error message.


    I know coding is not magic, nor is it easy but it's been the same problem(s) for a very long time and I'm surprised to see so many issues at this stage.


    Is it safe to say the focus is delayed due to Izoptope integration? Please delay that and focus on users not needing to troubleshoot so many dependency issues that require multiple restarts.

This discussion has been closed.
Back To Top