For users facing issues with installing Native Access 3.3.0 on M1 Macs

Hayo_NI Product Team Posts: 262 mod
edited August 2023 in Native Access

Thank you to all the people who highlighted this emerging issue where it seems as though Native Access 3.3.0 cannot install the NTK Daemon on Mac devices. We're going to be rolling out a hotfix for 3.3.1 early next week to address the issue.

For some insight, the company worked to have all products run natively, with Native Access and the NTK Daemon waiting until the last product runs natively for us to completely deprecate the need to install Rosetta 2. Once this was the case, we deprecated Rosetta 2.

However, one massive oversight was that the installers require Rosetta 2 to run. Native Access' installer bundle is not part of the same tech that handles all other installers, which is why you're able to install Native Access, but the NTK Daemon (and all products that run on these installers) will fail to install if Rosetta 2 is not already on your device. We assumed since all the installers were universal binaries (therefore could run on any OS) that this would naturally work, and our initial tests showed no issues. For new M1/M2 macs that didn't install an older version of Native Access before, this is going to be a problem for you.

We're discussing next week how much effort it would be to fix all of our installers (which we're trying to get rid of altogether, but that's a whole other can of worms), but in the meantime, 3.3.1 will be released to roll back the complete deprecation of Rosetta 2, requiring you to install it again, and reconvene on a new plan, which I'll add down below.

In the meantime, contact customer care if you're facing this issue, and ask them for an installer for Native Access 3.2.2. This is the last version that had Rosetta 2 running. When you download that Native Access version, you'll need to install Rosetta, and then (if you're not on Mac OS X 10.14) you'd be prompted to update to 3.3.0, which should solve the issue. We've also updated the website to be downloading version 3.2.2 for ARM download links.

We sincerely apologise for this inconvenience.



  • Kimmo Peltola
    Kimmo Peltola Member Posts: 11 Member

    That auto update in the NA software, I would skip. By removing that feature, you minimize the problem among users. Some people would never find out until it has been fixed.

  • ageeee
    ageeee Member Posts: 8 Member

    Yeah well going back to having to use Rosetta is, well, a backwards step. Not exactly a "hot fix". This forum seems to be full of a lot of unnecessary philosophical navel gazing. All I want to be able to is use my NI instruments on my M1 which has been around for a few years now. Which I can't anymore. And use without Rosetta. Rosetta was always just an interim measure to allow Intel programmes to run. It's fine if you have no interest in moving to Silicon based Macs but lots of us do. To be fair it has been a wait for Plugin Alliance/Brainworx, Arturia etc to get their instruments and software in to Silicon but most are there now although there is still a wait for Ventura compatibility. But that is another story. There are known issues with PA plugins for example in Logic when trying to run on Ventura. For me, I went back to Monterey for this very reason. Re-installed everything in a non-Rosetta environment. And I have to disagree with someone above, you and your computer will know if something is running in Rosetta in the background. For Logic users it requires a very plain to see auhosting process to run as a translation layer for plugins which is known to cause problems. So for me, and many of us I suspect, we want to run a non Rosetta, clean environment. Which leads back to NI. Your software appears to run like this but we can't install it. This is ridiculous in this day and age frankly. There may be a million different reasons for the convoluted Native Access installation and maintenance thing but frankly if you can only use NI software when connected to the internet so NA can run (I'm not certain on this) , that's a bit of a show stopper. I live rurally and occasionally the internet goes out. I have ilok USB which stores my authorisations for my other stuff so that means I can carry on without internet. The other obvious thing is people travelling with laptops and no immediate internet access - are you saying to them they can't use their NI instruments?

    But anyway, your products work but I can't install them. That is pretty bad for an outfit that has been around as long as NI. XLN Audio, Arturia, Softube a bunch of others etc etc have installers and authorisation systems that are fully Silicon/ARM and that of course don't require Rosetta. There are heaps of DAWs and other software manufacturers that have got this right - it's about making music not spending all day check for software updates or authorisations. Native Access should not be something that is part of the music ecosystem like that. It is not musical.

    You can't expect us to compromise our systems just to be able to run NI.

  • LostInFoundation
    LostInFoundation Member Posts: 3,985 Expert
    edited April 2023

    About NA “installation file copy of the older version available for download in the site somewhere”:

    I must correct myself: the older versions are available on the site. I don’t know if this page is new or what. Not seeing it linked in @Hayo_NI post (Btw:I would add this link to the post) made me make a mistake.

    In any case, my bad.

    Here is the link:

    For the other points (installation files available for ALL products) I’m still of the same opinion

  • Hayo_NI
    Hayo_NI Product Team Posts: 262 mod

    Unfortunately the full fix would be to revisit all installers for all versions of all of our products which is a fix we're investigating, but would take longer to address. In the meantime, we've rolled out 3.3.1 where we will send back the ability for users to install Native Access again. It's live now. Apologies for the frustrations here.

    When we've addressed all installers, we'll deprecate Rosetta with confidence.

    For users experiencing issues with Guitar Rig 5 that are visiting this post, see LostInFoundation's post above. Native Access 3.2.3 will be softly released there so you can continue to activate that old product. It will not be a supported version, but a version released to block the auto update server from auto updating you to the latest version of Native Access. This does mean at some point as we continue to improve our product installation pipeline, at some point 3.2.3 might experience some issues. When that happens, we will not patch it.

  • Kimmo Peltola
    Kimmo Peltola Member Posts: 11 Member
    edited April 2023

    Well, don't know what NI have been doing but that 3.3.1 doesn't fix anything on my system. I can still only run Guitar Rig 5 i demo mode - it won't accept my serial. Back to 3.2.2 then.

  • Hayo_NI
    Hayo_NI Product Team Posts: 262 mod

    As I mentioned, the link to old installers that LostInFoundation posted contains one that will provide you with an Native Access that resolves your problem. Please bear with us a little longer while we work to get it out.

    at 10.14, 3.2.3 should show up tomorrow there, which is one that will help Guitar Rig 5 activate.

  • jacqui brookes
    jacqui brookes Member Posts: 36 Member
    edited April 2023

    Download for recently purchased Kontakt 7 factory library 2 failed. Macmini M1 failed 50% through....maybe a server issue? Yes I did update the native access update.

  • 50-pence
    50-pence Member Posts: 2 Newcomer

    Erm, I don't get it.

    Neither 3.3.0 or 3.3.1 let's me proceed with installation for the same reason as before- I get the same NTK Daemon installer popup that asks me to install Rosetta.

    MBP 14" 2021 running Monterey 12.5

  • PauloA
    PauloA Member Posts: 2 Newcomer


    3.2.3 is still not there. Any news regarding that version. I use Guitar Rig 5 almost every day.

    Sorry to propose this, but if the problem is actually of NI, and the temporary solution will cause problems in the future (NA 3.2.3 as mentioned in your post), wouldn't it be easier to upgrade all Guitar Rig 5 users to Guitar Rig 6? Or at least, giving us, I don't know, 80% discount or something on it? We are stuck and cannot play/record for almost a week already.


  • rshklarek
    rshklarek Member Posts: 4 Newcomer

    I'm also incredibly confused by this entire process. I have exactly the same issue.

    Same hardware as 50-pence but running Monterey 12.6.5.

  • Hayo_NI
    Hayo_NI Product Team Posts: 262 mod

    Hi all,

    Apologies for the delay. Here's the support article about this issue.

    Follow the steps to uninstall the existing Native Access and install version 3.2.3, which will block the update process. Should this not resolve the issue, please reach out to our support team so we can keep this article up to date.

  • wrojzer
    wrojzer Member Posts: 4 Newcomer

    Hi Hayo,

    will this also work for updating Reaktor?

    MBP M1 2021

    MacOS 12.6.3

    thanks and best,


  • rshklarek
    rshklarek Member Posts: 4 Newcomer

    But with Native Access version 3.3.0, the NTKDaemon service is NOT running natively on Apple Silicon / M-Systems. It still requires Rosetta 2. This doesn't solve the issue some of us are having in the first place.

  • wrojzer
    wrojzer Member Posts: 4 Newcomer

    it doesn't work for me.

    Same problem as before, - gets stuck on: "Dependency installation process is taking longer than normal..."

    MBP M1 2021 w/ MacOS 12.6.3

Back To Top