For users facing issues with installing Native Access 3.3.0 on M1 Macs

24

Comments

  • ageeee
    ageeee Member Posts: 8 Member

    Yep same old problem for what should be a very simple implementation. No Rosetta please on M1/2s is all we ask. Or else we vote with our feet. I've resorted to networking up an old Intel MacBook pro and running NI stuff from there. But that will be the end of the road for me with NI. All this extra stuff running in the background to update or whatever marketing spin they want to put on it. It's like it's Microsoft or something. Suspect has a lot to do with Soundwide.

  • Hayo_NI
    Hayo_NI Product Team Posts: 262 mod

    @ageeee we understand. We admit that the jump off of Rosetta was too premature. I want us to move away, but there's a few things preventing us from doing so that we're going to be addressing moving forward, which we're working on. Apologies for that

  • KikkoAndMoonman
    KikkoAndMoonman Member Posts: 2 Newcomer

    Guys, this is getting ridiculous now. I'm on an M1 Ultra Mac and I cannot get a single version, be it latest, legacy, Rosetta or Apple Silicon to work. I cannot install a new product I have bought. What do you suggest I do?


    When I try to log in, it tells me "Unable to log in. Please restart your computer and try again". It does nothing.


    I would please be keen for a solution because this isn't really acceptable. Thank you.

  • Rich_NI
    Rich_NI Customer Care Posts: 173 mod

    Hi @KikkoAndMoonman

    This issue is usually caused by one of the following products interfering with Native Access' connection to our servers: 

    VPN / Proxy

    Network Security software / harsh settings

    Please restart your computer and temporarily disable any such software. You should then be able to login without issue. 

    If the issue persists, please submit a ticket via the following form: http://bit.ly/NIsupport_install

  • rshklarek
    rshklarek Member Posts: 4 Newcomer

    You're saying the jump off of Rosetta was too premature, after almost 3 years? 95% of other plug-in developers (outside of Soundwide) have managed to put out universals that recognize which chip systems run on, or let you choose the appropriate installer.

    Ironically I've paid the most money for NI and Plugin Alliance software, which has become unusable to me since making the transition to Apple Silicon. Good to know that I'm not alone in this at least, and that these marketing driven plug-in developers feel the dismay of their customers.

  • Altatnesiti
    Altatnesiti Member Posts: 3 Member
    edited May 2023

    Why is Native Access 3 constantly “update dependencies” on startup and ask for password to “modify system files”?! - very alarming! Also the download on NI WEB mention version 3.3 but installer is version 3.1 - ****** … and yes, I’ve given NI full disk access permissions…

  • Hayo_NI
    Hayo_NI Product Team Posts: 262 mod

    @Altatnesiti Thanks for the comment! Regarding the installer version, could you refresh the cache on native-instruments.com? Could be that an older version of the page is cached. When I try downloading I get the 3.3.1 installers.

    Regarding why we install dependencies, we're aware that this is an issue, and going to address it soon. Currently, if the NTK Daemon isn't running on startup, we reinstall it. This is as a result of an old compromise where we had shadow NTK Daemons running that couldn't be stopped. We've since fixed the bug, but not returned this UX. Apologies for the inconvenience!

  • donmaddonald
    donmaddonald Member Posts: 38 Member
    edited May 2023

    guys, I have an issue with 3.4 on an M2 MacBook Pro.. I don't know what to do, @Hayo_NI, any suggestions?


  • wrojzer
    wrojzer Member Posts: 4 Newcomer

    still doesn't work for me. - 3.4.0

    Same problem as before, - gets stuck on: "Dependency installation process is taking longer than normal..."

    MBP M1 2021 w/ MacOS 12.6.3

  • 50-pence
    50-pence Member Posts: 2 Newcomer

    Just seen this on the other thread for announcing current NA version:

    "Our next two releases will contain a large under-the-hood overhaul to our download manager and uninstalling content products. There could possibly be one more release in the middle so that we can debug more issues on Daemon stability, so three releases planned for the next few months."

    Those of us on Apple Silicon, and unwilling to install Rosetta... still can't even open Native Access. Copy the app over, open it. The install rosetta window pops up when it tries to install NTK Daemon.

    It's not a case of stability... We can't run the application full-stop!

  • Hayo_NI
    Hayo_NI Product Team Posts: 262 mod

    @donmaddonald Reach out to our support team here. Let them know your issue. Give them your daemon.log file as well so that they can help debug faster. Looks like you either didn't give permissions at some point in the start up flow, or you might need to give full disk access on your mac, but they'll likely be able to help you better.

    @50-pence We are aware. However, what we tried to do with 3.3.0 was to remove that barrier for you. Instead, we created a ton more barriers for a ton more users to have to overcome. We haven't given up on this, we're going to retry it at a later time. However, we're committing our resources now to the next 3 releases first, as they're quite large undertakings, and have put this on the back burner for now. We'll pick it back up when one of the releases are ready.

  • rshklarek
    rshklarek Member Posts: 4 Newcomer

    I downloaded the new Native Access 3.4.0 and installing it suddenly worked on my Macbook Pro M1 Pro without having Rosetta installed or being prompted to install it.

    Now it seems that NA has installed Rosetta without my explicit permission, through an install helper without explicitly mentioning Rosetta. I was purposefully trying not to install Rosetta and keeping my system native and now you've managed to install it.

    After years of looking forward to install my NI software again, I am frankly disgusted. Just keep going with your logos, your branding and your sales. Never mind the people who've already paid for your products and been using them for more than a decade. Shame.

  • nardiz
    nardiz Member Posts: 6 Member
    I can't believe it. 
    Native Access version 3.4.0 still requires Rosetta on Apple Silicon/M-Systems. 
    What is this nonsense 
    


  • nardiz
    nardiz Member Posts: 6 Member
    NtkDaemon requires Rosetta
    


  • markj
    markj Member Posts: 3 Member

    Also pretty disgusted here to find out that by upgrading my computer hardware to Apple Silicon, I lose access to all of my NI libraries, the Kontakt sampler, etc. because I don't want to run Rosetta cripple ware and NI does not provide native applications for installing and managing their software. Apple Silicon has been around since 2020!

Back To Top