Please Grant Permission to Native Access to Install Dependencies.



  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,823 mod
    edited April 14

    @LukeKeywalker Can you try the following?

    Delete this folder: Macintosh HD/Users/Shared/Native Instruments

    Relaunch Native Access.

    @FloraSynth Can you try it as well? If it does not work, since you have not contacted our support yet, I would also recommend you do so.

  • LukeKeywalker
    LukeKeywalker Member Posts: 40 Member

    Hi @Jeremy_NI ,

    this has no effect. The problem continues... Can't use NA2 at all anymore.

  • LukeKeywalker
    LukeKeywalker Member Posts: 40 Member

    @Jeremy_NI Ok now its not funny anymore:

    I downgraded AS RECOMMENDED BY NI to NA1 and it killed all my activations, so now I cannot open my NI products anymore - because they are all "un-activated" and NA1 cannot activate them and NA2 doesn't work. So I cannot use any of my NI products anymore... *****!!!!!

    Which hotline can I call for instant help? I need to work...jesus.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,823 mod

    Hey @LukeKeywalker You can get in touch here:

  • LukeKeywalker
    LukeKeywalker Member Posts: 40 Member
    Answer ✓

    It seems like I found a solution (at least for my system and for now).

    I kicked NTKDaemon out of the list for apps that got automatically started with a restart. Then reinstalled NTKDaemon:

    Native Access App - Contents - Resources - daemon - mac - NTK Daemon Installer Mac.pkg

    it will now automatically be added to the list again but this time it works.

    Now it seems to be stable. Looks like the startup process did not work until you remove it there and then add again.

    Good luck to everyone

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,823 mod

    @LukeKeywalker Thanks a lot for this piece of information, it's really appreciated and could really be helpful to others.

  • ozan
    ozan Member Posts: 14 Member
  • Pete Kowalsky
    Pete Kowalsky Member Posts: 3 Newcomer
    edited June 14

    Also seems to have worked for me after rm -rf './Native\ Instruments/' in /Users/Shared.

    Holy CRAPPERS - now let's see if it works more than exactly ONCE. 🤦

    YES! I've updated to 3.4.0 and it works after closing the app. Now I'll reboot and test it again. Fingers crossed...

    Aaaaan YES it works after a reboot as well.

    Many thanks to users LukeKeywalker and ozan for testing and posting back here.

    <RANT> I have frankly been disgusted with NI support for lack of fixes for this issue for the last 7-8 months. Quite disappointing. I bet if the payment page stopped working for more than 7-8 minutes they'd have that fixed in no time. For as much as this software is, we expect it to work and expect resolutions to these issues. </RANT>

  • TommyV
    TommyV Member Posts: 5 Newcomer

    Looks to me like this is fixed. I ran into

    "Please grant permission to Native Access to install dependencies. Please restart Native Access and try again.

    Release: 3.4.0"

    upon launching. I followed the advice, closed NA and restarted it, and it came up fine.

  • MrGrey23
    MrGrey23 Member Posts: 1 Newcomer

    I just got Kompltete 14 Standard. I too cannot install NI Access 2. I get a grant permission error.

    I don't understand why this is an issue. So many people having THE SAME DAMN PROBLEM!

    I expect to get what i paid for. This needs to be corrected Now!

  • dafingaz
    dafingaz Member Posts: 6 Newcomer

    I just had the same problem the last few days.

    Went through the forum here and was hesitant to try any solutions in fear of losing access (pun intended) to the files that were working in Logic.

    I found an article on the Native Instruments site today and going through the steps solved it for me (I didn't find this article in my extensive searches the last few days, so maybe it's a new solution?).

    It's not letting me post the link here, but the title of the article is "Native Access Error: "Please grant permission to NTK Daemon to install dependencies."

    And copying the title reformatted the text here. LOL.

    Hope that solution works for someone!

  • ShadyAdy
    ShadyAdy Member Posts: 1 Newcomer

    Having tried the prescribed 6-point steps, I got this message in the Terminal:

    "sudo: /Library/Application Support/Native Instruments/NTK/NTKDaemon.: command not found"

    I'm assuming then, that I need this Rosetta? But what on earth is Rosetta? And where do I find/download it?

    Any suitable suggestions will be most gratefully received, as I have been tearing my hair out for the past couple of weeks, trying unsuccessfully to resolve this 'grant Native Access dependencies' issue - am getting utterly cheesed off with it, if I'm quite honest. It's thoroughly annoying, as Native Access had been working perfectly fine until this unwelcome issue reared its ugly head out of nowhere.

    Still, happy days, eh? Cheers.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,823 mod

    @ShadyAdy Here's how to install Rosetta:

    If you still have iisues, please get in touch with our dedicated support here:

  • glpguitarplayer1954
    glpguitarplayer1954 Member Posts: 1 Newcomer

    I just spent $99 for a serious pc install fail?????

    Ni has the worst support ever, I want a refund

  • MadCapsule
    MadCapsule Member Posts: 2 Newcomer

    I just installed the 3.5.2 update and am getting the dependencies issue again. I ran the script in terminal and I keep getting the same error.

Back To Top