Please Grant Permission to Native Access to Install Dependencies.



  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,823 mod
    edited October 2022

    @safeite Can you try these steps for Native Access 2 :

    1. Go to Macintosh HD > Applications > Utilities and open the Terminal app.
    2. Copy this command line:
    3. sudo /Library/Application\ Support/Native\ Instruments/NTK/
    4. Paste the command text into Terminal and press enter.
    5. Enter your macOS password when prompted.
    6. Start Native Access.

    Also make sure that Rosetta is installed on your computer (it is needed for 1 little part of the Native Access installation.)

  • safeite
    safeite Member Posts: 16 Newcomer
    edited October 2022

    Did not work, had tried this previosly.

    However, what DOES work on an M1 Mac is to right-click on the NA app in the Application folder and then show package contents. Navigate to Mac and the installer for the mac Daemon, launch, install, reboot. All is well now.

    Possible issue: the downloadable daemon installer version installed does not contain all the data - the installer ALWAYS appears BLANK. The enclosed .app DAEMON install DOES have a selectable installable data-set in it’s window.

    It appears there may TWO installers out there. one works, the other does not.

    Please see other post with picts of the two divergent installers. One works, the other not at all.


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,823 mod

    @safeite Thanks for the update. Happy that it finally works for you!

  • sieren
    sieren Member Posts: 1 Newcomer

    Chiming in to say I was experiencing the same issue.

    What finally solved it (after countless hours of debugging) was running this in terminal:

    sudo launchctl enable system/com.native-instruments.NativeAccess.Helper2

    I hope this helps some here who have seen this issue as well.

    Looks like the Helper was permanently disabled within the launchctl database.

  • JayO
    JayO Member Posts: 3 Newcomer
    edited October 2022

    Thank you for posting this !

    I can verify that this works on an Intel Mac too.

    I tried everything else posted here, and nothing else worked, this took care of the issue.

    I will try to post a picture of the full path to the Daemon installer pkg.

    Once I double clicked that, it did it's thing, and the issue is gone.

    Thanks again !!

    EDIT: Ugh image didn't post for some reason.

    Full path to Daemon installer once you right-click, and show contents of Native Access app package is :

    Contents/Resources/daemon/mac/NTKDaemon Installer Mac.pkg

    • Jay

  • pranaearth
    pranaearth Member Posts: 50 Helper

    None of the suggestions here worked, nor did any of the suggestions support gave me. I had to go back to NA1. Everything is working as expected.

  • kipe
    kipe Member Posts: 5 Newcomer
    edited October 2022

    I was able to install Native Access 2.7 on my Macbook Pro with an M1 Pro just now, but only after a couple of attempts. This process worked:

    Run Cleanup script and then reboot.

    Run NTKDaemon installer (copied from new 2.7 folder)

    Restart and then reinstall Native Access 2.7

    I hope this still works whenever the next update is out with auto-update :-|

  • rockstarjazzcat
    rockstarjazzcat Member Posts: 1 Newcomer
    edited October 2022

    Erm, it's almost November, and on a Mac Studio Ultra running 12.6.1...

    And downgrading, running the earlier installer has led to kernel panics during products install. :(

  • kipe
    kipe Member Posts: 5 Newcomer

    3.0.1 broke things again.. Getting "Please Grant Permission to Native Access to Install Dependencies" again now! smh

  • pranaearth
    pranaearth Member Posts: 50 Helper

    3.0.1 is the only available DL version on the NI website. I cannot install it because of the same permissions issue. Is there a direct 3.3.0 link available?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,823 mod

    Hey everyone,

    It seems that some users managed to fix this by entering this commanfd in Terminal:

    sudo chmod -R 777 /Users/Shared/Native Instruments

    If it works for you, can you let us know what is your OS ?

  • pranaearth
    pranaearth Member Posts: 50 Helper

    Holy Carp. I don't know how I missed this message. After installing the NTKDaemon, NA works. No more permissions error. Thanks a bunch for figuring this out

  • Drain
    Drain Member Posts: 1 Newcomer

    gonziakSep 28, 2022

    I found the solution you need to go to Application folder - Native access and click to show the package content /Applications/Native and click NTKDaemon .... and instal it it helped me

    this method worked for me


Back To Top