Several Software Problems with Komplete Kontrol MK3

Amestie Member Posts: 9 Newcomer

Hi there,

First of all: Please excuse my writing. I'm not very good in writing English.

I experienced some issues after setting up my brand new Komplete Kontrol S61 MK3. Maybe one of you could help me on this before I refund the keyboard. Be assured that I went to all processes that could solve these problems provided by Native Instruments (re-organizing data base, allowing HDD accesses, etc.):

  • RX10 Elements cannot be installed (disc access issues eventhough NTKDaemon and Native Access are set)
  • Komplete Kontrol doesn't start correctly ("One of the plug-in needed cannot be found...", ScanApp crashes with error report).
  • menu issues directly on the keyboard. Sometimes only "DAW" lamp lights up and I cannot press any other bottom unless I turn the keyboard off and on again.

Btw, the application location in Native Access causes an error sign (red circle) at "File Management" (Preferences) eventhough it seems to be correctly.

Any help would be highly appreciated :)

Best regards




  • Chris_NI
    Chris_NI Product Team Posts: 47 mod

    Hi Michael / @Amestie

    Sorry you are running into issues installing and using the SW products.

    Which operating system are you on? Windows / Mac? OS version.

    I will run this by our software QA engineers to see if there are some ideas. I will post back here after.

  • Amestie
    Amestie Member Posts: 9 Newcomer

    I'm running a Mac OS Sonoma 14.0 (MacBook M2 Pro, 32 GB, SDD.

  • Martin_NI
    Martin_NI Product Team Posts: 22 mod

    Hey @Amestie

    Could you please share the crash report you got from Komplete Kontrol please? We recommend always running Komplete Kontrol 3 once standalone outside of a DAW before using it in your DAW of choice.

    Could you please ensure you have the "Hardware Connection Service" installed in Native Access. This software ensures that the keyboard can connect to Komplete Kontrol and Kontakt.

    Would you mind sharing what DAW you are using? Hopefully, that will enable us to help you further.

  • Amestie
    Amestie Member Posts: 9 Newcomer


    Hardware Connection Service is installed (and has been reinstalled already). I'm using Logic Pro (latest Version) as DAW.

    Crashes at start occur either way - no matter if Logic Pro is running or not.

    Crashreport is attached (PDF)

  • Mike Mass
    Mike Mass Member Posts: 9 Newcomer

    Same here...

    Mac m1..

  • nightjar
    nightjar Member Posts: 1,078 Guru

    Your problem might be Kontakt 7.6.1.

    Rich_NI Customer Care Posts: 170 mod

    October 19

    In some cases, the latest Kontakt update (7.6.1) is causing CPU spikes and DAW crashes. These issues are currently being investigated with a high priority by our developers.

    In the meantime, we would request that any users experiencing such issues to downgrade to the previous version of Kontakt 7 (7.6.0) via the following link: 




    We will provide updates about the fix as and when we have them. Sorry if you have been inconvenienced by any issues with the recent update!

    Tagged: Kontakt 7

  • Mike Mass
    Mike Mass Member Posts: 9 Newcomer

    Also, I don't see the graphics on led screen, just the knob features... It's not the same without the graphic of the instrument!

  • Amestie
    Amestie Member Posts: 9 Newcomer
    edited October 25

    The downgrade didn't solve the problem, unfortunately.

    At least these two issues still occur:

    • RX10 Elements cannot be installed (disc access issues eventhough NTKDaemon and Native Access are set*)
    • Komplete Kontrol doesn't start correctly ("One of the plug-in needed cannot be found...", ScanApp crashes with error report)

    *EDIT: I also set full disk access to NIHardwareAgent.

  • PoorFellow
    PoorFellow Member Posts: 1,102 Guru

    Hi , N.I. MAC expert Jeremy:NI is not here until November 6th , and I do not have a MAC myself.

    I share my compilation OS MAC advice below here but I have no idea if it will be of any help to you ! (Sorry !)

    Compatibility of Native Instruments Products on macOS :

    1) Check all folders in Download, Application and Content locations by doing Get Info in Finder for full Read and Write access permission. Click lock at bottom right to make changes.


    2). Be sure Full Disk Access is granted for NI applications under System Settings> Privacy and Security> Then under "Privacy Section" scroll down to "Full Disc Access" right arrow. Will open up the NI apps, and you slide them all to "on".


    If it fails immediately on download, it is probably disc write privileges, if it fails at last point in installation, probably Full Disc Access. When all is working you will see the temporary install folder for the app you are installing show up on your desktop. If you get that far, it should complete.

    Final Solution: For new MacBook Pro users or anyone using the M1 & M2 chips, Native Access will work as long as you have the permissions turned on under the privacy and security. So if you see Native Access and the other NTKDaemon on your list, make sure they are turned on and you see blue after you check them. If you don't see blue and if they don't appear in your drop down list under FULL DRIVE ACCESS then you will continue to have installation issues.

    Did everything explain above. Stil problem. Then formatting external disk to APFS. Everything works fine

    This works - change your designated File Management folders in Native Access Preferences to a drive that is Mac OS Extended (Journaled) format. If you, like me, are trying to install using ExFat Samsung T7 SSD it will not work.

    I had the same issue here, and there was one additional step that solved this: I had to change the permissions for the desktop. For some reason, "everyone" did not have read and write permissions for the desktop, and that somehow prevented the dmg to do its thing.


    (a) I gave full disk access for NI Access and NTK

    (b) changed the permissions to read/write for the destination folder

    (c) changed the permissions to read/write for the desktop

    and then it worked. Good luck guys!

    I've given full disk access to Native Access and the NTKDaemon, changed permissions on folders, and checked the APFS disk format, and the issues still happening. So I am not able to use or reinstall certain Kontakt libraries.

    Native Access's NTK Daemon: sometimes fails to install even with full disk access, also mutex issue

    Tips: Full Disk Access on Mac and why it matters

    Ref. : Native Access - Dependency Installation on Mac

    If the issue persists even after the steps you mentioned, please contact our support:

  • Amestie
    Amestie Member Posts: 9 Newcomer

    Thanks mate, I appriciate your effords! Anyways, I actually don't want to become a software engineer. My Mac is up to date and I already tried a lot of things in order to solve the current problems. Nothing helped so far.

    I just want to play keyboard so I'm going to refund. As soon as NI fixed those technical issues I'll consider giving that keyboard another chance.

    Cheers, Michael

  • Mike Mass
    Mike Mass Member Posts: 9 Newcomer

    I figured out why the error "missing needed file" or something like that, is happening!! Need to run in Rosetta!!

    After giving full access to Komplete Kontrol, I just went into Privacy &Security/Komplete Kontrol/ made sure all drop downs were blue, and right clicked Komplete Kontrol... Then clicked to run in Rosetta...

    However, I just received two scan app quit unexpectedly errors, but clicked ok and it kept running.. Muuuchh later it did give me that "missing file that's needed" but plugs I wasn't able to run last night is working now!!

    However, I still have no (GUI) graphics on key board just the filter knobs

  • Mike Mass
    Mike Mass Member Posts: 9 Newcomer

    Privacy & Security

    Select files and folders

    Right click Komplete Kontrol

    Get info- Open using Rosetta

    Do the same for file NIHardwareAgent And NTKDaemon

    It will load all the plugins....

    Still dealing with keyboard not showing PLUGS- GUI

  • Brad Yost
    Brad Yost Member Posts: 333 Pro

    Do you have it set up as Komplete Kontrol MIDI (which transmits the note/CC data)


    As a Komplete Kontrol DAW Control Surface?

  • Amestie
    Amestie Member Posts: 9 Newcomer

    Thanks Mike, that helped a ton! At least it's loading the plugins needed so far. I'm still receiving this error message as you mentioned though - but I can live with that as everything seems to work in order.

    Have you been able to install "RX10 Elements"? I'm not. However, I don't know if that is a loss or not ,-)

    Sorry to hear that you're still having issues with your GUI. Mine is working fine right from the start.

    Thanks again!

  • Mike Mass
    Mike Mass Member Posts: 9 Newcomer

    Yes, I just loaded the Izotope portal as I already had it for other plugs, then upgraded to the latest version.

    Then clicked on RX Elements 10 and 11 and it fixed that error..🤙🏾😎

Back To Top