Native Access's NTK Daemon: sometimes fails to install even with full disk access, also mutex issue

zachnfine
zachnfine Member Posts: 3 Member
edited January 2023 in Native Access

I'm posting to document two problems with Native Access (v3.1.0 for Apple Silicon) and NTKDaemon that I encountered on macOS Ventura 13.0.1. Also to document the workarounds I used in order to get through the installation of Komplete Standard 14.


First problem

• Sometimes the installation of an item would fail even though both NTKDaemon and Native Access have been granted Full Disk Access in System Settings - Privacy & Security - Full Disk Access. Strangely, some installs would succeed, some would fail. Nothing was written to the console that I could see so I'm not sure why it was having problems with installing 'Abbey Road 60s Drummer' that it didn't have with 'Battery 4'.

Eventually I used the tip at the bottom of this post to run NTKDaemon as sudo root. This is not a great thing to have to do from a security perspective, but it appeared that NTKDaemon was likely having permissions issues. And it worked, finally I could click the install buttons next to items in Native Access and they would actually reliably install. In addition I could watch informative messages scroll by in the Terminal.


Second problem

• With newfound confidence that installs would succeed I clicked the 'Install All' button. Several items downloaded and installed, and then after a couple of more quickly-downloaded items tried to install I saw NTKDaemon crash with a "mutex lock failed" error:

So I quit Native Access, again ran the NTKDaemon as root via the terminal command "sudo /Library/Application\ Support/Native\ Instruments/NTK/NTKDaemon.app/Contents/MacOS/NTKDaemon", started up Native Access, and hit "Install All" again. It installed a couple of items and then ran into that same NTKDaemon "mutex lock failed" error again.

I quit Native Access again, started up NTKDaemon as root again, and this time I just hit the Install button next to one item. It installed. Another item, it installed. Another item, it installed. I clicked the install button next to 3 smaller items so they'd probably download very quickly and do their installs simultaneously and I was treated to the same NTKDaemon crash.

Eventually after manually relaunching NTKDaemon and Native Access and clicking install buttons one at a time and making sure items didn't install at the same time, I got everything installed. So there's nothing that needs to be done to help me in this case - but the problems I ran into point to a couple of possible bugs in Native Access.

  1. Native Access, at least in this particular version, is queuing downloads, but is not queuing installations - and simultaneous installs are clobbering each other at some step in their process - maybe when registering installs to a common file or db. This should be easy to fix, just queue the installation processes too.
  2. Something isn't right with NTKDaemon and permissions and 'Full Disk Access'. For what it's worth, I had both download location and content location set to a thunderbolt RAID connected to my computer on which I have read/write permissions. Though now that I'm checking those settings I have a 3rd bug to report. Eek.
  3. Native Access's preferences can lose track of user-specified settings and change them on its own. It set "Download Location" to /var/root/Downloads, is that the Default? That is not the location to which I'd set it to download items (and at one point it was downloading to my specified location). I promise I never clicked the 'Restore Defaults' button, and am concerned that maybe one of the NTKDaemon crashes caused the preferences to reset? It appears this happened at some point and now I've got a bunch of content in the non-desired Content Location of /Users/Shared, which I'll have to go move. And all of 'em are owned by root. Argh.

OK I recursively changed ownership of all those content folders and files to my user and group and I moved them to my desired content location, then started up NTKDaemon and Native Access and used the bulk relocate tool to change the location of all the missing content and now finally I have everything installed and in the correct place. Hooray.

But this was a painful process and most users are not going to manage all this command-line tomfoolery. I'm sure this process must work well for most people and likely also for the cases used for testing back at Native Instruments, but my setup is not terribly interesting or bizarre and this was not a good experience. I'm happy to supply more information if needed for attempts to reproduce these issues.

Comments

  • iNate
    iNate Member Posts: 136 Advisor

    Honestly, I don't think there is even a single C-tier developer left at Native Instruments. They probably don't have a QA department at all.

    These issues are so easy to spot and confirm - with the most basic testing - that they are either clueless or simply don't care at all what they are pushing out to users. 100% reproduceable through [literally] normal use.

    No one at Native Instruments seems to have bothered to load up NA2 in a VM (or on any machine) and click "Install All" to witness it fail time and time again. That's how hard a user has to push it to trigger these anomalies.

    Was Komplete Now really that important?

Back To Top