Native Access - Dependency Installation on Mac

JTmapa Member Posts: 4 Newcomer

Hi. I've been having problems getting passed the "Installing dependencies" ("Dependency installation process is taking longer than normal").

I made sure the Native Access and NTKDaemon boxes are ticked to allow Full Disk Access. But that doesn't work. I entered the command text: sudo /Library/Application\ Support/Native\ Instruments/NTK/ to Terminal. That worked but have to reenter this to Terminal over and over again each computer start/restart.

I've exhausted all the info available but nothing works. Please advice.



Mac 7,1 - Monterey 12.6.2, Native Access release: 3.2.1

Best Answer


  • foleyman
    foleyman Member Posts: 2 Newcomer

    I'm having the same problem but getting "Installation Failed: You may need to grant full disk access to Native Access and the Daemon." But full disk access has been given and computer restarted multiple times.

    Was thinking this might be unique to Ventura (I'm on 13.01) but sounds like it's now. Frustrating.

  • JTmapa
    JTmapa Member Posts: 4 Newcomer

    Yeah, no real solution out there! Only thing that works is their Terminal script but only till computer shut down/restart!

  • JTmapa
    JTmapa Member Posts: 4 Newcomer

    Just installed the new update, 3.2.2. The problem persists!!

    Come on, Native Access!!!!

  • sillybark
    sillybark Member Posts: 2 Newcomer

    Native Access should be called Native NO-Access.

    I cannot update any products, the products listed are incomplete, and NA just keeps saying "loading products".

    Glad I have hardware too. This is joke and waste of my time.

  • sillybark
    sillybark Member Posts: 2 Newcomer

    Finally worked. Not sure why. Force quit a few times, left it, then restarted it.

    Not the normal computing experience. Wondering what it was doing.

  • Cicero
    Cicero Member Posts: 1 Newcomer

    Hi I also contacted NI but had no reply.

    I reverted to an older update of Native Access by following steps of removing the new update and its working again OK. I will not be adding the latest update until they fix this.

    Should really have been tested on Ventura before launching it.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,810 mod
    Answer ✓

    @JTmapa If the issue persists even after the steps you mentioned, please contact our support:

Back To Top