First time run error : Invalid download location

Lost_ Member Posts: 4 Noise

hello all

Hopefully someone here might know what is the trouble for my install. I just purchased the Maschine Mk3 and installed the Native Access app. On first run I get the following issue:

I have not been able to register my the Maschine, not even get past this page above. No option to install to a diff drive, no option to do really anything.

here is a video showing exactly what I see:

Maybe something can make heads or tails of this?>

I have no proxy, no vpn, nothing really. Native Access is allowed through the firewall, and I have cleaned out DNS, temp files and check the Hosts file as well. Everything should be clean.

what might I be missing ?

thank you to anyone that can assist. I truly appreciate it and want to use the Maschine, not return it due to this bug.


  • Simchris
    Simchris Temecula, CAMember Posts: 95 Tri

    Did you try changing your dns to google or cloudflare instead of isp?

  • Lost_
    Lost_ Member Posts: 4 Noise

    I am currently using Google .

    I can change though, just to be safe

  • Lost_
    Lost_ Member Posts: 4 Noise

    I tried changing to Cloudflare and still it's the same issue. "Failed to download the latest update" , "

    invalid download location"


  • Lost_
    Lost_ Member Posts: 4 Noise

    Update. Just got info from Native Instruments.

    1.13.5. (which I downloaded from NI site) does not work with my version of Windows 10.

    They gave me the following info:


      Could you please check if that issue persists with the current version of Native Access: 1.14.1

      You can download it here:


      Best regards,

      Isti @ NI



    This fixed the issue.

    Thank you to everyone that tried. Hopefully this info will help others.

Back To Top