Maschine software hangs while previewing kits - Bug (KBDSW-6977)

12357

Answers

  • NewAux
    NewAux Member Posts: 6 Member

    I'm a new user and I don't have an extensive catalog of projects - just stuff that I've saved as I've been learning. But now that you mention it, some of those I haven't been able to open.

  • Necutan
    Necutan Member Posts: 7 Member

    Yeah, i figured out, that when you switched to 2.14 you can't open projects made on 2.15. Good that i asked for any inconveniences or things to keep in mind in my previous post :-)

    So we have to wait...

  • paulyminogue
    paulyminogue Member Posts: 71 Member

    So I bought the Mother Board and the Young Phantom Expansion today. I had to downgrade to 2.14.7 because of the NKS Preview Bug on the M1.

    Mother Maschine Kits are Loading correct.


    Young Phantom Expansion is not loading any kind of the Kits. Is it because I don't have the latest Maschine update? ^^

  • NEKAYBAAW
    NEKAYBAAW Member Posts: 2 Member

    So, this still hasn't been rectified?????? WTH is the Project Manager doing to fix this issue?

  • paulyminogue
    paulyminogue Member Posts: 71 Member

    Hey do you have new Informations for users who have Problems with M1?

    Could you figured something out?

    Thank you

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,892 mod

    @paulyminogue This specific issue will be addressed in the next Maschine / Komplete Kontrol update. We can't share any date at the moment. For now the best workaround is to downgrade. If you bought some products that do not work when downgrading, you should be able to return them and get a refund. Let me know if you need anything else.

  • Horace
    Horace Member Posts: 1 Newcomer
    edited August 2022

    Hello Everyone, I am experiencing the exact same issue you have described. The Maschine software freezes while browsing/previewing sounds. I then have to force quit the application because the spinning ball just hangs there until I do. My software was migrated via Time Machine. However, upon experiencing these issues, I did reinstall the software via Native Access without successfully resolving the problem. Additionally, I am using the UAD Apollo Twin as my sound card. However, I experience the same exact issue when using the built-in system audio sound card. I am running Maschine 2.15.2 on a MacBook Pro (M1 Pro Chipset) macOS Monterey 12.5.

    I am about to rollback to Maschine version 2.14.7 as @Jeremy_NI suggested to others. I'll let you know if this fixes my issue. Hopefully, NI will let us know once they have resolved the issue and provide an updated version of the software.

    -H


    ***Just a quick update to my earlier post... Rolling back my software to the previous version (2.14.7) worked for me. As others mention, I am not able to open projects created with version 2.15, but that should be resolved when NI release the next version correcting the problems with version 2.15.***

  • awayguy
    awayguy Member Posts: 1 Newcomer

    Have just installed latest update - 2.15.2.

    Original bug - previewing any sound hangs the software.

    Loading first kit workaround seems to fix the bug, but under 2.15.1 I still ran into the same bug after a short time of use, so cannot use Maschine for normal production.

    I have a completely clean and full install of the Maschine and Komplete libraries on a new Mac Studio.

    I am aware that most of the software is not M1 compatible, although Machine is supposed to be.

    Shame on Native Instruments for not doing this by now (and not fixing this recent Maschine bug) - and even more shame for not giving us resizable interfaces. I will not upgrade my Komplete Libraries until they do.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,892 mod

    As mentioned earlier in this post (check for "answers") the workaround for this issue is to install a previous version, here is the link again: Maschine 2.14.7

    Yes, it's not ideal, we know. Next update of Maschine should get rid of this issue as well as bring M1 native compatibility and VST3 support for all third party plug-ins.

    Most of our software is compatible with M1 in Rosetta mode.

  • Necutan
    Necutan Member Posts: 7 Member

    He said "M1 native compatibility" will come... yep, he said it. :-)

    i freak out. Thank you guys.

  • driks
    driks Member Posts: 1 Newcomer

    Reducing the audio buffer size to 256 worked for me 🙏

  • benny benny
    benny benny Member Posts: 1 Newcomer

    M1 Pro 16, Mac os monterey 12.5.1

    Same problem. Resolved by switching buffer size to 256 🐒

  • Anomus1
    Anomus1 Member Posts: 5 Member

    MacBook Pro, 16”, M1 Max, 64gb ram. Latest Maschine Software

    While using Maschine+ in controller mode, I experienced the same problems.

    Switching buffer to 256 has fixed it so far.

    Really appreciate whomever discovered this temporary fix. I was completely frustrated and could only use my Maschine+ in stand-alone mode.

  • channelo
    channelo Member Posts: 7 Member

    Thank you Anomus1, I've switched to 128 buffer size and haven't had the hanging issue since then. I think 128 will work for most projects on M1, and going up to 256 will give more than enough headroom when using various processing plugins within Maschine. For more heavy duty stuff, might as well export to a DAW for further processing. This will tie us over until 2.16 comes out!

  • aspectsofwar
    aspectsofwar Member Posts: 1 Newcomer

    Hiya, also experiencing this issue.

    Using a 32gb ram 16" Macbook Pro, M1 Max.

    It was crashing when first installed, worked fine for a few days, then today started crashing anytime I was browsing sounds so I came to this thread.

    I would recommend when sharing the previous installer link to say that anything made on 2.15 would not work with the previous version of maschine, I have a project I was working on for days that I can't open after installing the previous version of Maschine 2 - incredibly inconvenient but grateful there is some form of temporary solution.

Back To Top