Maschine software hangs while previewing kits - Bug (KBDSW-6977)

135

Answers

  • paulyminogue
    paulyminogue GermanyMember Posts: 25 Sine
  • seadragon
    seadragon Member Posts: 8 Sine

    I have the M1 Max MBP and use it with a Focusrite Scarlett 18i8 audio interface.

  • Thatkidprolific
    Thatkidprolific Member Posts: 1 Noise

    Same issue for me, M1 Pro processor on a MacBook Pro 14".

  • Doobox
    Doobox Member Posts: 2 Noise
    Answer ✓

    Same issue.

    M1 Max. library resides on thunderbolt Glyph SSD. No audio interface other than MK3.

    I do switch audio out regularly between, MacBookPro speakers, Built In (Apple headphones), and Airplay (Apple home pods). Maybe that's part of the secret sauce to instantiate the bug.

    I have completely removed everything NI following the NI article, and reinstalled without success.

    Currently working around the issue with either or of the methods below, both work:

    1) reduce audio buffer size to less than 256, prevents crashing previewing patches in any way.

    2) on startup or when loading a new project - hit browser - load whichever patch is currently selected. Once any patch has been loaded I can now scroll and preview any patches.

  • Doobox
    Doobox Member Posts: 2 Noise

    Just a thought. Does anyone / everyone affected run an Apple Studio display? I do.

    I believe that the display has some internals (possibly related to sound) that may just be the recipe.

  • paulyminogue
    paulyminogue GermanyMember Posts: 25 Sine

    I don't use that, still have Problems startet with Maschine Version 2.15.0. No Problems before on Apple M1.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 998 mod

    Hey all, thanks for all the info, I forwarded to our development. There are already known issues on M1 Max and M1 Pro, as we stated on the Apple Silicon article here: Apple Silicon (M1) Compatibility News

    If anyone has more information or comment on this exact same issue, keep them coming. They're investigating these and all these infos help.

  • Golden Brown
    Golden Brown The NetherlandsMember Posts: 10 Sine

    @Jeremy_NI - Sorry, I fell out of this thread. I have 48kHz selected. It happens with just about any kind of present - kit (group) or sound, Factory library or Expansion pack, it doesn't matter. Everything including the native library is on my internal SSD (2TB).

    Maybe some more interesting information for the support team -

    I now know this is definitely due to the Maschine Software (and not because of the hardware), because I just started up Maschine software without hooking up the MK3 (so my headphones are directly plugged into the laptop unlike the last time when I posted the original question). I started clicking around the kits randomly one after the other without letting them finish the playback of the preview completely. Surprisingly, I was able to click through more kits than I usually could. And then it suddenly broke. The color wheel is still spinning as I finish writing this comment.

  • pranaearth
    pranaearth NYCMember Posts: 41 Tri

    I have the same exact issue. Are your sound library/expansions on an external hard drive? I keep all of my sound libraries, including Preview on an external hard drive. I do not have the Factory Library installed. It happens when I try to browse Groups/Sounds/Instruments/Loops. I have a ticket open on the Beta Forums. NI said they can reproduce the issue. I reported it 3 months ago and have heard nothing back. BUG-00807. I am on an M1 Max laptop w32GB of memory. Apps are on the internal drive and all sample libraries are on external drives. All Maschine expansions and Previews are on the same external HD

  • Nutellaface
    Nutellaface Member Posts: 2 Noise

    I just got an M1 mac and have the exact thing happening. Fresh install on NI products as well. Moving from windows. Every other product seems to work. This is disappointing,

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 998 mod
    edited May 30 Answer ✓

    Hey @Nutellaface here is an installer for the previous version of the Maschine software, can you install it and see if the issue still occurs? For some users, the problem only occurs with 2.15: Maschine 2.14.7

  • paulyminogue
    paulyminogue GermanyMember Posts: 25 Sine
    edited May 30

    Hey, I downloaded this Version too and Downgraded my Maschine Software 2.15.2 to 2.14.7 Everything is working fine with this Version. I can skip thru all Expansions, third Party NKS etc. No Preview freezing at all. I also can switch the 44 / 48 khz. No freezing.

    I will keep this Version for me now. Thank you very much for this!


    ++ MacBook Pro M1 / I migrated from Timemaschine to this Mac / Problems started with Maschine Version 2.15. - 2.15.2. / I had Problems with any kind of NKS ++

    Edit:

    Also when I using my UAD Apollo Soundcard, there are no crashes.

  • NXBYL.PMG
    NXBYL.PMG Member Posts: 4 Sine

    I'm was having the same issue with my MBP M1 Pro, but now I can't even get past the scan without it stalling. Hopefully NI will get the compatibility challenges with M1 Pro/Max corrected sooner than later.

  • pranaearth
    pranaearth NYCMember Posts: 41 Tri

    I just downloaded 2.14.7 and just by playing around in the software there are no freezing issues. Next step is to is my controller out of the closet, plug it in and do some testing. As a reminder I'm on a M1Max processor.

Back To Top