Native Access 2 (Intel Mac) Application Location setting Error Flag in Preferences SingaporeMember Posts: 30 Tri
edited July 9 in Native Access

I have just upgraded to Native Access (NA) 2 from v1 on my Mac (running Big Sur 11.6.7) manually.

Now there is an error flag in NA 2 next to Application Location setting in the Preferences which is "/Applications/Native Instruments"--this is the same setting as NA 1 which I had no issue before. Hovering to the error flag, it says either the folder location is missing (which is not so) or a permission setting issue.

I have a separate user account on my Mac with administrator privilege. However, I run NA 1 (now overwritten by NA 2) and NA2 on my working user account which only has standard privilege, so it will prompt me for administrator credential if the installer requires it.

Currently, my "/Applications/Native Instruments" folder is with ownership "iamadmin,admin" and mode "0775" while the content folders and files are mostly with ownership "root,wheel" and mode "0775", except "Native" (NA 2) is with "iamadmin,admin" and mode "0755" for folders and executables, and mode "0644" for standard files.

Is there is bug in Native Access 2.0.7, or do I need to make a trip to my Mac's Privacy settings?


  • SingaporeMember Posts: 30 Tri

    The Application Location in Native Access 2.2.0 still requires that folder location to be world-writable--is this going to be the norm for Native Access 2? Native Access 1 does not require world-writable for this folder location.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,586 admin

    Hi sorry I missed your post. I see that you've contacted our support team already. I've escalated your request. We'll get back to you soon.

  • ardez
    ardez Member Posts: 6 Sine
    edited October 4

    Same issue here, 2019 i9 MacBook Pro 16. Native Access 2 vers. 2.6.2 

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod

    @ardez Can you develop, OP's issue was on Windwows, feel free to post screenshots of the error message or issue.

  • ardez
    ardez Member Posts: 6 Sine

    There you go Jeremy, this is what I see:

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod


    This is unfortunately a bug in Native Access.If the Native Instruments folder got created by running an installer directly or via Native Access 1 it gets created with permissions that are falsely recognised by Native Access 2 as problematic.The installations should still work.Alternatively you could also carry out the following steps:

    1. Please go to Macintosh HD > Applications
    2. rename the "Native Instruments" folder to "_Native Instruments"
    3. create a new folder and name it "Native Instruments"
    4. now please move all the folders you have in "_Native Instruments" into the newly created "Native Instruments" folder
    5. after everything got moved and the "_Native Instruments" folder is empty, it can be deleted

    If you open Native Access now it should not have an issue with that location anymore.

  • Pete from Bristol
    Pete from Bristol Member Posts: 7 Sine

    Thank-you, Jeremy. That solved my problem. My first morning as an Ni user and I'd already messed things up! Looking forward to using your products.

Back To Top