Native Access 2 - Known Issues 🚨



  • R3kl355
    R3kl355 Member Posts: 9 Newcomer

    NA2 Always trying to install dependencies on every launch. The script fix doesn't work as permission is denied. Recently purchased Komplete Ultimate 14 and installing everything is a pita, larger installs get stuck and I have to restart NA and try again.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod

    @R3kl355 As suggested here, you could downgrade to Native Access 1 for the time being, until this issue is finally fixed.

  • Kitaro Oasis
    Kitaro Oasis Member Posts: 1 Newcomer

    i have problems with NA2 too. It always will update to Ver. 3 but dont get located the NTKDaemon.

    Why do we have always Probs wit NA? Just wanted to purchuase Komplet 14 but now i tink twice

  • akirabass
    akirabass Member Posts: 7 Newcomer
    edited November 2022

    I tried the NTK Daemon installer via the link in the first page of this thread. No avail. The installer also require Rosetta.

    I would have liked to be able to install each software that is fully compatible with M1 now without depending on Native Access whose installation is not fully compatible with M1...

  • davemacp
    davemacp Member Posts: 22 Member

    ***** is going on with native access? I just restarted my machine due to it bugging out (as usual) and on a fresh restart it took over 8 minutes to fully open. HOW is it getting worse with every update?!

  • freejay
    freejay Member Posts: 1 Newcomer
    edited November 2022

    I build my new PC and wanted to install my Komplete 14 package but that almost seems impossible: NA 3.0 takes minutes to start, minutes to show my products, minutes to start a download, doesn't update the buttons properly (e.g. from "Install" to "Installed") and most times after I installed 1 or 2 products it shows a minuscle list of installable products afterwards. Only restarting NA helps. But this takes time (see above)...

    Any help on the way?

  • Paul B
    Paul B Member Posts: 41 Helper
    edited November 2022

    Add me to the list of people having ridiculously slow startup times for Native Access (current version 3.0.1). 'Activating products' for around 2:20, 'Loading Products' for around 4:05. Every time, except the second time, when 'Loading Products' was unexpectedly done in a couple of seconds, but it's back to super slow now.

    There's nothing to activate (everything is already activated) and loading products should take a second or two at most.

    The resulting product list is also wrong. I have a few products not installed, a couple of Kontakt Libraries, Kontakt 7 Player (didn't ask for it, don't want it, would like to be able to hide it,) and some controller thing. First time around, none of these showed until I selected 'show discontinued products' in preferences (Kontakt 7 Player is a discontinued product? Ha!) May have been some missing from my installed list as well, I didn't count. I recall NA1 showing me 37 installed products. Not a lot. Not even close to 4 minutes worth. Like I said, a couple of seconds seems generous. NA1 could do it. Same machine. But it gets worse. The last time I loaded NA3, it shows 1 out of 4 available products. And only 15 installed. Can you guess what's coming next? Some of them come back if I enable 'show discontinued products'. Kontakt 7 is among them. What's not among them? FM8, Massive, Reaktor, Kontakt 6 (for which I own the full version), Form, and more.

    No doubt as soon as I reload it (after the several minute startup time) I'll get a different list. Edit: yes, I restarted and all 37 installed and 4 not installed show. Who knows what I'll get next time.

    Downgrading to NA1 is not an option. I tried, followed the given instructions, and it gets stuck on trying to download an update (It's the latest version, so there's no update required or available) and then complains about 'no compatible update found'.

    Please, NI, fix this. It's unusable as is, and I can't downgrade.

    (yes, I am submitting a support request with all of this info)

  • Peter Delve
    Peter Delve Member Posts: 1 Member

    I have exactly the same issues as you Paul B I can't downgrade same error and the new version 3.0.1 is completely useless..Its not picking up all my products and I can add any serial numbers. What a mess sort it out NI!!!!!

  • psoper
    psoper Member Posts: 1 Newcomer

    I've been trying to reinstall Ozone 10 all day, the vst was not showing up in ableton and After uninstalling Native access gets stuck on Starting and does not install Ozone. On top of this Native access sometimes randomly gets stuck opening, and other times simply does not load my serial numbers

  • mattrixx
    mattrixx Member Posts: 8 Newcomer

    This whole Native Access thing is a debacle. Not working!!! Aaaarfrhh/

    The one time NA 3.0.1 opened, it only found 3 products.

  • mattrixx
    mattrixx Member Posts: 8 Newcomer

    The only way I can see all of my products (now that I can finally open the app) is to download and use the Intel version of NA2..... The M1 native version is only showing a few of my products and none of the apps (with the exception of Kontakt Player 7. Also, none of the sound packs.

    So at least if I use the Intel version, I can stumble through. (I'm on a Mac Studio Ultra)

  • shimintula
    shimintula Member Posts: 3 Member

    Had exactly the same problem here (MacOS / Intel) last night. Took forever on 'activating' then 'loading products'. Only about a third of my library was showing up when it finally did start. It was only showing third party content too until I switched on 'show discontinued products' but there was still a lot of stuff missing.

    Opened it this morning and everything was fine. Activated and loaded in about 30 seconds and all products were displaying properly.

    So I'm guessing just give it some time. It's likely a server-side issue that'll get resolved pretty soon (if not already).

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod
    edited November 2022

    @mattrixx @shimintula and all the other affected users,

    Yesterday, and through the night, we experienced a server issue which resulted in a wide range of errors in Native Access.The problem on our side has now been resolved for the most part. Please restart / refresh Native Access and try again. A little fraction of users might still be affected, we'll keep you updated and let you know when it's 100% fixed.

    If you contacted our support for other installation issues, you can expect a little delay in the answer, as you can imagine, a lot of users got in touch. We sincerely apologise for the inconvenience caused and would like to thank you for your patience and understanding.

  • Paul B
    Paul B Member Posts: 41 Helper

    Thanks for letting everyone know. It was frustrating not knowing what was happening, and if the app had notified me there were server problems it would have helped (not just me, but I would not have contacted support and taken up their time).

    I've received a response from support, to which I have replied. The gist of my reply is that I do not believe the app should be so server dependent, e.g., what if all I wanted to do was move the location of an installed library? I believe that activation status/listing of already installed products should not require remote server access. I know that's how many (maybe most/all?) install managers work, but that doesn't, in my opinion, make it a good user experience.

    I'm probably going to try downgrading to NA1 again. If that works, I'll stick with it for now. The only problem it had yesterday prior to my upgrade was an empty list of not yet installed products and updates. The list of already installed products was fine. It could also have used an error message to explain why the other lists were empty, but I understand it's no longer in development, so have no expectation of that.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod

    @Paul B You're right, I wish we could have been able to inform you all sooner. We'll try to find a better way to deal with such issues. This time, NA1 would not have fixed it as the issue was more on our cloud infrastructure, as I understand it. We'll share the official statement soon.

Back To Top