Native Access 2 "issue with the installer service" error

Nicolas Laget
Nicolas Laget Member Posts: 6 Member
edited May 2023 in Native Access

Why is Native Access the only downloader I own that requires me to enter a password to install "dependencies" every time it launches?

Why is this app so very flawed? Why do I have to force quit and reinstall and try multiple times just to get it to - maybe - do what it is designed to do?

Why is this app, so central to everything Native Instrument users do, such a complete failure?

Just let users download individual libraries and install them. That is much slower and manually intensive but at least it works.

Tagged:

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 3,971 Expert

    Because NI

  • Marijn
    Marijn Member Posts: 4 Member

    This looks much more like a security or profile problem than anything related to Native Access 2.

    I've been running NA2 on MacOS 10 - 12.6.5 without problems, but have experienced problems like you explain with different software on a previous system, which had a partly damaged profile.

    Reinstalling MacOS helped.

  • Uwe303
    Uwe303 Moderator Posts: 2,898 mod

    Hello,

    have you tried all this Issues: Native Access 2: Dependency installation process is taking longer than normal (WINDOWS) — Community (native-instruments.com)? On my windows computer i added the NTKDeamon under ransomware protection to the exclusion list and it worked for me.

  • Nicolas Laget
    Nicolas Laget Member Posts: 6 Member

    I recently reinstalled my OS. I am running the latest Mac OS.

    This does not explain why Native Access is the only downloader app that causes any issue. It's really pathetic performance from a major software developer. Output, Arturia, Spitfire, 8Dio, etc... are able to create downloader apps that just work. There is no excuse for thousands of users complaining about Native Access.

    I have gone through the numerous workaround and security settings suggested by NI support knowledge database.

    Now the error message is about a failure of the install script. Libraries download and have a 50% chance of failing to install.

  • Nicolas Laget
    Nicolas Laget Member Posts: 6 Member

    That's what I get. I have 5 more libraries to install. It's not working.


  • Uwe303
    Uwe303 Moderator Posts: 2,898 mod

    Have you tried to contact support? Meanwhile you could also use NA1 there is a download here: https://support.native-instruments.com/hc/de/articles/4748946468497-Downgrade-von-Native-Access-2-auf-Native-Access-1

  • Uwe303
    Uwe303 Moderator Posts: 2,898 mod

    And have you tried this with na2 https://support.native-instruments.com/hc/en-us/articles/4415601248657-How-to-Enable-Full-Disk-Access-on-macOS?_ga=2.216638486.1465358346.1683120322-829792636.1628180035

  • MTXBeats
    MTXBeats Member Posts: 6 Newcomer

    You took the words out of my mouth. Native Access is a big issue. We shouldn't have to jump through all these hoops just to download paid for products.

  • chk071
    chk071 Member Posts: 342 Pro
    edited May 2023

    Just FYI: I had quite a few issues with Arturia's Software Center as well. You probably just have been lucky not to run into those.

    That said, I also think that NI should make sure Native Access 2 works correctly. There have been too many issues lately. Such software has to work. It's the tool to install and activate NI's plugins.

  • Rich_NI
    Rich_NI Customer Care Posts: 173 mod

    Hi @MTXBeats

    I just replied in your other thread, requesting some information about the errors you receive.

    Once you have sent the requested screenshots, we can take a closer look into the issue you are having.

    You can also submit a support request via the following link: http://bit.ly/NIsupport_install

Back To Top