Issues: Dependency installation process is taking longer than normal



  • Philcl
    Philcl Member Posts: 3 Newcomer

    New to the DAW music technology but also have not been able to install NA due to runtime error richedit script line. I have a ticket in with NI so will reveal if a solution is found. Has anyone else suffered from this problem, comments would be much appreciated.


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod

    @musiclogic then you should get in touch with our specialists here:

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod

    @Philcl Maybe you could give this a try? Windows Error Message: "Runtime Error!"

  • Philcl
    Philcl Member Posts: 3 Newcomer

    Problem now solved, it was corrupt files in my windows system. I ran DIsm then a sfc scannow and this repaired the relevant corrupt files.

    Thanks for your help


  • DanRad
    DanRad Member Posts: 5 Member

    i too have been stuck with a spinning circle. I’ve followed the suggestions here as close as I can but my M1 MBP Montery will not open up Native Access. HELP!!!

  • Paja1959
    Paja1959 Member Posts: 1 Newcomer

    the same issue, I am really frustrated trying everything as advised for couple of days already and no success. Please help

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod

    @Paja1959 I see you're in contact with our specialists, they should be able to help.

  • whelmking
    whelmking Member Posts: 1 Member

    I am just returning to NI after a few years away from DJ'ing. I'm shocked that this is the state of NI that I cannot install the mandatory Native System program. If this is the best NI can do when someone wants to use their software with a brand new M1 Mac, then I'll be exploring other DJ programs. I submitted a ticket and hope to hear from NI very quickly if you want to keep my business.

  • Robert080
    Robert080 Member Posts: 10 Member
    edited January 2023

    Still waiting for a (really) installable version of NA2 for Windows. Same problem on two different W10 pc, no solution from technical support. I've never seen in my life something like this.

  • KlaFeBo
    KlaFeBo Member Posts: 1 Member

    Hello all,

    when is the Native access version coming that just runs smoothly??? I am a customer of Native Instruments from the beginning, but I have never been so dissatisfied as now!!!!

    It is also not the task of well-paying customers to get to the goal with countless work arounds at some point. Other companies can do that too!!!!

    So bring out something sensible and functional.

    Really annoying!!!!


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod

    @KlaFeBo We hear you loud and clear. The Native Access team is working hard on this. There should be an update in a couple of weeks that shoud improve things.

  • BKK
    BKK Member Posts: 8 Member

    I have tried every suggestion put out there by NI to get Native Access up and running, and nothing has worked.

    At this point I am seriously considering just dumping Native Instruments altogether.


    Just one example among many, your terminal script produces an error: "assertion failed [header->version <= kProjectSourceVersion]: runtime library is newer than runtime"

    I am running Monterey 12.6.1 on an M1 Mac mini.

    I can't even get Maschine working now because something is borked, and I can't reinstall or update.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod

    @BKK Maybe before using the big caps you could contact our support agents and see if they can help you out? I don't see any request from you regarding these issues.

  • BKK
    BKK Member Posts: 8 Member

    i see, it’s my fault for not contacting a support team that I didn’t know existed.

    I am sorry.

Back To Top