Issues: Native access 2: Dependency installation process is taking longer than normal (MAC)

Jeremy_NI
Jeremy_NI Customer Care Posts: 8,935 mod
edited April 2023 in Native Access

First of all, install Native Access 3.3.0:

Native Access 3.3.0

Solution 1:

  1. Open your Mac's System Preferences and click Security & Privacy.
  2. Under the Privacy tab, choose Full Disk Access from the side bar.
  3. Click the lock icon in the bottom left of the window and enter your Mac password.
  4. Ensure that Native Access appears in the list.

If it does not appear in this list, click the + icon and add the following apps:

Macintosh HD > Applications > Native Access

Macintosh HD > Library > Application Support > Native Instruments > NTK > NTKDaemon

Once completed, click the lock icon again 


If it still gets stuck: 

  1. Go to Macintosh HD > Applications > Utilities and open the Terminal app.
  2. Copy this command line:
  3. sudo /Library/Application\ Support/Native\ Instruments/NTK/NTKDaemon.app/Contents/MacOS/NTKDaemon
  4. Paste the command text into Terminal and press enter.
  5. Enter your macOS password when prompted.
  6. Start Native Access.

Some users also fixed it by following these steps

Right-click on the Native Access app in the Application folder and then show package contents. Navigate to Mac and the installer for the ntkdaemon, launch, install, reboot.


If none of the above worked out:

You can downgrade to Native Access 1, following these steps:

How to Downgrade Native Access 2 to Native Access 1

You can also get in touch with our specialists here: http://bit.ly/NIsupport_install

This discussion has been closed.
Back To Top