Roland DP-10 Sustain/Half Damper pedal with Komplete Kontrol S61 mk2 & various NI Komplete pianos

Molchanski
Molchanski Member Posts: 2 Noise
edited January 28 in Komplete Kontrol

Dear NI,

No problem with the controller/software recognising this pedal. I configured it according to instructions in the article about sustain and half-damper sustain pedals:

https://support.native-instruments.com/hc/en-us/articles/115005166305-How-to-Configure-Sustain-Expression-Pedals-on-a-KOMPLETE-KONTROL-MK2-Keyboard.

(I've used Pedal A in my case but otherwise settings are identical)

Something changed and now when I use it with any of the NI piano plugins (Komplete 13 Ultimate), it defaults to functions other than sustain pedal. I don't know if I have somehow accidentally reassigned this midi function, or if something changed in an update (the issue started last year). Whatever it is โ€“ I would be so grateful for a fix! I'm not midi savvy unfortunately, so me experimenting there is a bit like shooting in the dark.


Examples:

with The Grandeur & The Giant, the pedal defaults to adjust the tone knob of the piano (continuously)

with Alicia's Keys, it toggles the convolution reverb on and off

But with none of the pianos does it assign to work as a sustain pedal.

Thanks for reading!

Best wishes

Steve

p.s. Also should add I'm still running macos High Sierra 10.13.6 on an old but heavily upgraded iMac i7, and everything runs great.

Best Answer

  • Molchanski
    Molchanski Member Posts: 2 Noise
    Answer โœ“

    Dear Uwe and Jeremy,

    Thanks a lot for your suggestions. I triple checked through all these things, but the settings were exactly as they should be & the glitch was mysteriously still there.

    However! I realised I had forgotten to check for an update ๐Ÿ˜ and sure enough now with the latest update of Komplete Kontrol the issue has gone away :) without having changed any settings, the half-damper pedal now simply works as it should.

    So there you go - a cautionary tale about keeping things updated (even on an old workhorse iMac running High Sierra...)

    Cheers,

    Steve

    p.s. it's useful to know though about about how to troubleshoot the midi channels in case it happens again, so thanks for that Jeremy! ๐Ÿ™

Answers

  • Uwe303
    Uwe303 Moderator Posts: 516 mod

    Hello,

    have you double checked that youยดve set midi cc number 64?

    Uwe

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,094 mod

    Hey Steve,

    There is probably a wrong MIDI setting. Open the Komplete Kontrol standalone application, click on the MIDI logo, check that there are no other knob or button assigned to MIDI CC 64 or 65. Also check Buttons and Touchstrip.

    Only the pedal should have an assignment for CC64, since it's a half-damper, it should look like this:

    Now disconnect the keyboard and click on "MIDI", delete any MIDI assignment by clicking on the small x, also check the Buttons section.

    It should work now.

  • Molchanski
    Molchanski Member Posts: 2 Noise
    Answer โœ“

    Dear Uwe and Jeremy,

    Thanks a lot for your suggestions. I triple checked through all these things, but the settings were exactly as they should be & the glitch was mysteriously still there.

    However! I realised I had forgotten to check for an update ๐Ÿ˜ and sure enough now with the latest update of Komplete Kontrol the issue has gone away :) without having changed any settings, the half-damper pedal now simply works as it should.

    So there you go - a cautionary tale about keeping things updated (even on an old workhorse iMac running High Sierra...)

    Cheers,

    Steve

    p.s. it's useful to know though about about how to troubleshoot the midi channels in case it happens again, so thanks for that Jeremy! ๐Ÿ™

Back To Top