NTK Daemon ''Error Service' NTK Daemon Service' failed to start

Kornel
Kornel Member Posts: 4 Newcomer
edited April 7 in Native Access

I cannot install NTK Daemon which is needed to download Native Access. The same message appears every time: ''Error Service' NTK DaemonService' failed to start. Verify that you have sufficient privileges to start service. '' I've tried many things but nothing works. Please help.

Thanks,

Kornel

Answers

  • Kornel
    Kornel Member Posts: 4 Newcomer
    I did it as written in the manual and still nothing
    


  • PoorFellow
    PoorFellow Moderator Posts: 2,491 mod

    Profile says Windows 11

  • Kornel
    Kornel Member Posts: 4 Newcomer

    Im on Windows 11

  • Hardy Tilger
    Hardy Tilger Member Posts: 5 Newcomer

    I have the same problem. Win 11.

  • BIF
    BIF Member Posts: 553 Pro
    edited April 7

    Hey @Kornel and @Hardy Tilger

    Maybe your antivirus or firewall got in the way?

    What antivirus and firewall do each of you use?

    If that's possible, try deactivating one or both, then retry the installer as noted by Jester above. Be sure to run the installer "as administrator" as it says in the instructions.

    Just be sure to reactivate your security when done.

    If you're still having trouble after doing the above, then do this:

    Please open Windows 11 task manager, and go to the Processes tab. Click on "name" (so that the list sorts by name), then scroll down and see if NTKDaemonService appears in the list.

    If yes, then right click on it (not the higher level "NTKDAEMON" with the old NI logo...no, you must right click on the lower level one named "NTKDaemonService") and select "Services". This will open Windows services. Sort by name and scroll down to find NTKDaemonService.

    What does it say? Is it running? Failed to run? Please tell us the state reported by Windows 11 Services, and we'll come up with something else to try.

    For example, mine says "Running", "Automatic (Delayed Start)", and "Local System".

    I'm looking for something like "Disabled" or "Failed to Start", and maybe some clues as to why.

    Power User Tip:

    This is just general good advice. Whenever installing software, be alert for any popup messages from Windows. They most likely will appear in the lower right corner of your primary monitor, but if you're daydreaming or goofing around in your studio, you might miss them.

    I just installed something today (not NI, but still), and I got a popup. I clicked on it, and it gave me a yes/no choice to give authority for something or other. Which I did, and then the install went fine.

  • Hardy Tilger
    Hardy Tilger Member Posts: 5 Newcomer

    I´ve checked the NTKDaemonServis, it shows "empty" (so assume not running) and "Automatic (Delayed Start)". When i try to start this service it says system could not find the file.

    I´ve been going through all gpedit stuff already and i´ve been runing the gpedit enabler batch file already and tried to manually install NTKDaemon Service and nothing worked.

    All the tips and tricks which are already available on the NI Support Page didn´t work.

Back To Top