wagnersliszt Member Posts: 3 Newcomer

Good afternoon. Recently had issues with KontaKt not loading correctly inside VEP. Tried to load KontaKt 7 inside VEP which eventually worked when not connected to the DAW. Once I initiate my DAW to connect, many K7 load as K6 and some don’t load at all. Tried getting into my Native Access (thinking there should be a way to repair it) which would not load. Tried downloading a new version of Native Access after going through the Native wizard and deleting various files and folders then restarting my Mac. That didn’t work, it wouldn’t load. Checked all the privacies and securities on my Mac making sure everything is listed and be allowed that needs to be. Everything listed. Any tips gratefully received.

Running MBP M1 Ventura, VEP + DP.


  • Paule
    Paule Member Posts: 1,328 Expert

    Do you try to load VST 3?

  • wagnersliszt
    wagnersliszt Member Posts: 3 Newcomer

    No I use AU. Somethings wrong with my MBP. Having to erase and reload the whole machine. Good idea though. Will try VST once I’m back up. Made the mistake of going to Sonoma then realising my mistake went back to Ventura. Somewhere in between I think something got corrupted. Should have thought of VST 👍

  • PoorFellow
    PoorFellow Member Posts: 1,123 Guru

    NI Forum person and MAC expert Jeremy_NI is off until 6th of November , I do not have a MAC but can give you this collection of standard advice ! : But first and foremost make sure that your OS is supported. Else , if none of the advice works then you most likely need to contact support (see post bottom for link !)..

    Compatibility of Native Instruments Products on macOS :

    1) Check all folders in Download, Application and Content locations by doing Get Info in Finder for full Read and Write access permission. Click lock at bottom right to make changes.


    2). Be sure Full Disk Access is granted for NI applications under System Settings> Privacy and Security> Then under "Privacy Section" scroll down to "Full Disc Access" right arrow. Will open up the NI apps, and you slide them all to "on".


    If it fails immediately on download, it is probably disc write privileges, if it fails at last point in installation, probably Full Disc Access. When all is working you will see the temporary install folder for the app you are installing show up on your desktop. If you get that far, it should complete.

    Final Solution: For new MacBook Pro users or anyone using the M1 & M2 chips, Native Access will work as long as you have the permissions turned on under the privacy and security. So if you see Native Access and the other NTKDaemon on your list, make sure they are turned on and you see blue after you check them. If you don't see blue and if they don't appear in your drop down list under FULL DRIVE ACCESS then you will continue to have installation issues.

    Did everything explain above. Stil problem. Then formatting external disk to APFS. Everything works fine

    This works - change your designated File Management folders in Native Access Preferences to a drive that is Mac OS Extended (Journaled) format. If you, like me, are trying to install using ExFat Samsung T7 SSD it will not work.

    I had the same issue here, and there was one additional step that solved this: I had to change the permissions for the desktop. For some reason, "everyone" did not have read and write permissions for the desktop, and that somehow prevented the dmg to do its thing.


    (a) I gave full disk access for NI Access and NTK

    (b) changed the permissions to read/write for the destination folder

    (c) changed the permissions to read/write for the desktop

    and then it worked. Good luck guys!

    I've given full disk access to Native Access and the NTKDaemon, changed permissions on folders, and checked the APFS disk format, and the issues still happening. So I am not able to use or reinstall certain Kontakt libraries.

    Native Access's NTK Daemon: sometimes fails to install even with full disk access, also mutex issue

    Tips: Full Disk Access on Mac and why it matters

    Ref. : Native Access - Dependency Installation on Mac

    Native Access Freezes on “Installing Dependencies“ at Startup :

    If the issue persists even after the steps mentioned then please contact our support:

  • wagnersliszt
    wagnersliszt Member Posts: 3 Newcomer

    This is great. Thanks. Due to some none NI related problems that came up I decided to reformat. I’ll go through your points again carefully once back up and running. Very interesting point about the desktop permissions. Thank you.

Back To Top