[Solved!] Shouldn't the NKS standard be the same for all controllers?

ShelLuser
ShelLuser NetherlandsMember Posts: 135 Tri
edited March 31 in Komplete General

Hi gang!

So, I am confused. I always figured that the NKS standard is the same for all devices; so in specific for Komplete Kontrol as well as Maschine. After all, it's mentioned as such on the website and in both environments you'd end up with different banks containing 8 controls.

However...

So here I've loaded Komplete Kontrol and browsed to the section that lists my SoundIron instruments (these are all Kontakt instruments btw), and as you can see I have 10 in total.

But coming over to Maschine on the other hand:

Now I only have 6 left!

I then did some research on an instrument that is available in both: Voices of Wind - Adey, and when I look at the controls in KK:

... they fully matcht the controls as available within Maschine:


Which leaves me very much puzzled... why can't we have this:

... within Maschine as well?

Thanks in advance for any comments or insights you might have!

Best Answers

  • Kubrak
    Kubrak Member Posts: 852 Saw
    Answer ✓

    Hard to say, it should be the same. Try to do plugin scan in Maschine 2 SW. Also check if those missing are not placed in different folder, that is not scanned....

    I have older version of Olympus Elements, and I have the controls in Maschine 2 like you show in KK.

    So again, the controls should show up the same in the both Maschine and KK.

  • ShelLuser
    ShelLuser NetherlandsMember Posts: 135 Tri
    edited March 13 Answer ✓

    So... I dove deeper into this and as it turns out I am not as stupid as I thought I was. There is an issue somewhere.

    • I fire up Maschine stand alone, I hit rescan (as mentioned above), I now have 10 Iron Sound instruments.
    • I close Maschine, start it again, now I'm back to 6.
    • Now I disable Win10 ransomware folder protection.
    • Repeat; and rinse.

    I'm pretty confident this isn't about my hardware because Komplete Kontrol has no issues updating nor retaining its library. NOR has Maschine perse because my latest purchased expansions (Lunar Echos is, IMO, quite nice) ... they all show up and remain consistently present.

    See, it's only the 3rd party products which keep falling through the mazes.

    Bug report time.

  • ShelLuser
    ShelLuser NetherlandsMember Posts: 135 Tri
    Answer ✓

    I'm very happy to report that with the help of Alfredo from NI support this issue got resolved!

    It turned out that my Maschine database somehow got corrupted, after resetting the whole database Maschine did a full recan and this time it found and retained my missing instruments. Unfortunately we can't determine the exact cause for all this but it had to be something local on my end. Maybe an upgrade gone wrong, who knows...

    So yeah, if you're experiencing issues with the Maschine database yourself you may want to try this as well. The procedure is very simple:

    • Make sure Maschine isn't running (important detail!).
    • Open a file browser and go to: "%localappdata%\Native Instruments".
    • Find the "Maschine 2" folder in there and rename it to something else (like "Maschine 2.bck" for instance).
    • Start Maschine again and get ready to take a break when it rebuilds its entire library.
    • Now check if the previous problems are gone.

    Best part of this is since you're only resetting the database and not so much your personal settings your favorites list easily retains.

    So yeah, thanks again to Alfredo for all the help and his patience!

Answers

  • Kubrak
    Kubrak Member Posts: 852 Saw
    Answer ✓

    Hard to say, it should be the same. Try to do plugin scan in Maschine 2 SW. Also check if those missing are not placed in different folder, that is not scanned....

    I have older version of Olympus Elements, and I have the controls in Maschine 2 like you show in KK.

    So again, the controls should show up the same in the both Maschine and KK.

  • ShelLuser
    ShelLuser NetherlandsMember Posts: 135 Tri
    edited March 13

    I have older version of Olympus Elements, and I have the controls in Maschine 2 like you show in KK.


    So again, the controls should show up the same in the both Maschine and KK.

    Thanks for your comment, really appreciate it!

    Yeah, that's the thing where it gets somewhat bizarre... Olympus is actually listed in my Maschine library:

    Yet it refuses to show up in my browser no matter what I do.

    OK, it's official: IR stupid 🤐 Yah, I don't think so!!

    Wanting to rule out everything I followed up on your suggestion and fired up Maschine stand alone, clicked "Rescan" ("yah sure, Maschine scans everytime I start it up anyway, surely this isn't going to change stuff" (= biased thougths up front)) and lo & behold:

    Now.. while I do feel kinda stupid here this experience also does make me wonder: why the heck am I waiting for VST scan's during startup when Maschine doesn't even pick up anything new?! (yeah, I just discovered this issue 😶).

    Thanks for your help!!

  • Kubrak
    Kubrak Member Posts: 852 Saw

    Yes, there are things between heaven and earth..... Probably dwarfs' jokes.

  • JesterMgee
    JesterMgee Custom NKS Libraries: freelancesoundlabs.com/nksMember Posts: 493 Saw

    NKS is exactly the same in Maschine and KK, it uses the same reference files, same image/database resources and same paths to content.

    VST scan on start-up scans ONLY for your physical plugins, not library content. NKS files are considered the same as a sound file basically in the fact they need to be imported to your library. This is not done by the VST Scan thread as that is only looking for plugins.

    Official NKS libraries make a registry entry which is what appears in your factory list so when you launch the standalone software it should actually auto-detect the new entry and scan the location for files. If for whatever reason that has not happened you can manually trigger it also. User NKS files are scanned in either manually or an option can be set to auto scan on start-up.

  • ShelLuser
    ShelLuser NetherlandsMember Posts: 135 Tri
    edited March 13 Answer ✓

    So... I dove deeper into this and as it turns out I am not as stupid as I thought I was. There is an issue somewhere.

    • I fire up Maschine stand alone, I hit rescan (as mentioned above), I now have 10 Iron Sound instruments.
    • I close Maschine, start it again, now I'm back to 6.
    • Now I disable Win10 ransomware folder protection.
    • Repeat; and rinse.

    I'm pretty confident this isn't about my hardware because Komplete Kontrol has no issues updating nor retaining its library. NOR has Maschine perse because my latest purchased expansions (Lunar Echos is, IMO, quite nice) ... they all show up and remain consistently present.

    See, it's only the 3rd party products which keep falling through the mazes.

    Bug report time.

  • ShelLuser
    ShelLuser NetherlandsMember Posts: 135 Tri
    Answer ✓

    I'm very happy to report that with the help of Alfredo from NI support this issue got resolved!

    It turned out that my Maschine database somehow got corrupted, after resetting the whole database Maschine did a full recan and this time it found and retained my missing instruments. Unfortunately we can't determine the exact cause for all this but it had to be something local on my end. Maybe an upgrade gone wrong, who knows...

    So yeah, if you're experiencing issues with the Maschine database yourself you may want to try this as well. The procedure is very simple:

    • Make sure Maschine isn't running (important detail!).
    • Open a file browser and go to: "%localappdata%\Native Instruments".
    • Find the "Maschine 2" folder in there and rename it to something else (like "Maschine 2.bck" for instance).
    • Start Maschine again and get ready to take a break when it rebuilds its entire library.
    • Now check if the previous problems are gone.

    Best part of this is since you're only resetting the database and not so much your personal settings your favorites list easily retains.

    So yeah, thanks again to Alfredo for all the help and his patience!

Back To Top