Busy season in progress... Please note that due to a high volume of requests, the response time from our support is currently longer than usual. Chat is temporarily not available. We thank you for your understanding.

Komplete Kontrol showing duplicate presets in browser. HELP!

channelo
channelo Member Posts: 7 Sine

Hey all,

I am on a M1 Monterey 12.6 running Komplete Kontrol 2.7.2

It is showing duplicate (sometimes quadruple) presets in browser. When I click on either of the duplicate presets, they both will work and load the instrument successfully. When I right click on both the presets to do "Find in Folder", they both open to the same file/same location. So basically, the presets are for the same file and I don't have duplicates of the instruments/libraries installed. I know there have been instances where people have installed the "Selection" version of larger libraries and found duplicate instances of their presets, but that is not the case for me.

The same thing started happening in Maschine 2.15.1 for me after installing Komplete Kontrol 2.7.2, so I suspect that something went wrong during the installation that is causing both Komplete Kontrol and Maschine to show duplicates in the browser section. I've tried deleting the db3 files from both Maschine and Komplete and the Shared folders in the Library >Application Support >Native Instruments folder, and also deleting the plist files

I also had a look inside the actual plist files of Komplete Kontrol and Maschine but could not tell if there was anything unusual that would cause the duplicates. I also had a look inside of the plist files of the individual libraries but nothing in them suggested anything was unusual.

Is there another way to remove and rebuild the libraries so that the duplicates consolidate other than reinstalling EVERYTHING which would take me an eternity.

Thanks guys.

Best Answers

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,771 mod
    Answer ✓

    No need to delete the files in the NI Resources folder, what you need to reset Komplete Kontrol 's database is to delete this folder: Mac HD > Users > Username > Library > Application Support > Native Instruments > Komplete Kontrol

    If you already deleted that and the issue remains, we'll need to check your system so I'll contact you by email.

  • channelo
    channelo Member Posts: 7 Sine
    Answer ✓

    Thanks for that! I tried that and it didn't work. So I went and moved all my Local Pref plist files for Native Instruments into a folder on my desktop, then I added them one by one back into the Local Pref folder and rebuilt the db each time to see if any of them were causing the presets to duplicate. It literally took me hours!

    But I found the culprit files. Turns out they were the Massive X Factory Library plist file and a few Massive X expansions:

    com.native-instruments.Massive X factory library.plist

    com.native-instruments.Pulse.plist

    com.native-instruments.Rush.plist

    com.native-instruments.Scene.plist

    I don't know why they were causing problems, but removing them and reinstalling them doesn't seem to work so I will live without them for now.


    Hope this helps someone else with a similar problem. Thanks

Answers

  • channelo
    channelo Member Posts: 7 Sine

    Or could it be the new Native Access 2 causing this problem?

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,771 mod

    Is that doing it for all libraries and presets ? Or only for some ? Can you post screenshots ? Where are your libraries installed ?

  • channelo
    channelo Member Posts: 7 Sine

    Hi,

    It's doing it for all libraries and expansions! They are all installed in Users\Shared

    When I delete the db files and rebuild the databases, I keep getting duplicate presets. Also, I've tried deleting the _DatabaseResources and database folders from Users\Shared\NI Resources. When either Maschine or Komplete Kontrol rebuilds its databases, duplicates of the _DatabaseResources and database folders appear inside Users\Shared\NI Resources.

    I think this all started happening when I installed Native Access 2 or updating to Komplete Kontrol 2.7.2

    It is really driving me nuts. Do I need to reinstall everything? TIA!

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,771 mod
    Answer ✓

    No need to delete the files in the NI Resources folder, what you need to reset Komplete Kontrol 's database is to delete this folder: Mac HD > Users > Username > Library > Application Support > Native Instruments > Komplete Kontrol

    If you already deleted that and the issue remains, we'll need to check your system so I'll contact you by email.

  • channelo
    channelo Member Posts: 7 Sine
    Answer ✓

    Thanks for that! I tried that and it didn't work. So I went and moved all my Local Pref plist files for Native Instruments into a folder on my desktop, then I added them one by one back into the Local Pref folder and rebuilt the db each time to see if any of them were causing the presets to duplicate. It literally took me hours!

    But I found the culprit files. Turns out they were the Massive X Factory Library plist file and a few Massive X expansions:

    com.native-instruments.Massive X factory library.plist

    com.native-instruments.Pulse.plist

    com.native-instruments.Rush.plist

    com.native-instruments.Scene.plist

    I don't know why they were causing problems, but removing them and reinstalling them doesn't seem to work so I will live without them for now.


    Hope this helps someone else with a similar problem. Thanks

  • G15
    G15 Member Posts: 2 Noise

    Was there a solution for this? i have the EXACT same issue and tried the above steps (deleting recommended folders and .db3 files)

    It takes hours for it to 'komplete' the scan on my system and for it to only result with the same issue is EXTREMELY frustrating.

    at one point during the scan there were no duplicates, however after i did my victory dance and sat bac down at the computer i realized all the same duplicates were. somewhere during the scan it triggered the duplicated presets in the list.

    Please help. I'm obviously not the only one with the issue and if there was a solution found, it should be posted.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,771 mod

    @G15 I already answered in the other post where you submitted the same message.

Back To Top