Komplete Kontrol showing duplicate presets in browser. HELP!

channelo
channelo Member Posts: 7 Member

Hey all,

I am on a M1 Monterey 12.6 running Komplete Kontrol 2.7.2

It is showing duplicate (sometimes quadruple) presets in browser. When I click on either of the duplicate presets, they both will work and load the instrument successfully. When I right click on both the presets to do "Find in Folder", they both open to the same file/same location. So basically, the presets are for the same file and I don't have duplicates of the instruments/libraries installed. I know there have been instances where people have installed the "Selection" version of larger libraries and found duplicate instances of their presets, but that is not the case for me.

The same thing started happening in Maschine 2.15.1 for me after installing Komplete Kontrol 2.7.2, so I suspect that something went wrong during the installation that is causing both Komplete Kontrol and Maschine to show duplicates in the browser section. I've tried deleting the db3 files from both Maschine and Komplete and the Shared folders in the Library >Application Support >Native Instruments folder, and also deleting the plist files

I also had a look inside the actual plist files of Komplete Kontrol and Maschine but could not tell if there was anything unusual that would cause the duplicates. I also had a look inside of the plist files of the individual libraries but nothing in them suggested anything was unusual.

Is there another way to remove and rebuild the libraries so that the duplicates consolidate other than reinstalling EVERYTHING which would take me an eternity.

Thanks guys.

Best Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,948 mod
    Answer ✓

    No need to delete the files in the NI Resources folder, what you need to reset Komplete Kontrol 's database is to delete this folder: Mac HD > Users > Username > Library > Application Support > Native Instruments > Komplete Kontrol

    If you already deleted that and the issue remains, we'll need to check your system so I'll contact you by email.

  • channelo
    channelo Member Posts: 7 Member
    Answer ✓

    Thanks for that! I tried that and it didn't work. So I went and moved all my Local Pref plist files for Native Instruments into a folder on my desktop, then I added them one by one back into the Local Pref folder and rebuilt the db each time to see if any of them were causing the presets to duplicate. It literally took me hours!

    But I found the culprit files. Turns out they were the Massive X Factory Library plist file and a few Massive X expansions:

    com.native-instruments.Massive X factory library.plist

    com.native-instruments.Pulse.plist

    com.native-instruments.Rush.plist

    com.native-instruments.Scene.plist

    I don't know why they were causing problems, but removing them and reinstalling them doesn't seem to work so I will live without them for now.


    Hope this helps someone else with a similar problem. Thanks

Answers

  • channelo
    channelo Member Posts: 7 Member

    Or could it be the new Native Access 2 causing this problem?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,948 mod

    Is that doing it for all libraries and presets ? Or only for some ? Can you post screenshots ? Where are your libraries installed ?

  • channelo
    channelo Member Posts: 7 Member

    Hi,

    It's doing it for all libraries and expansions! They are all installed in Users\Shared

    When I delete the db files and rebuild the databases, I keep getting duplicate presets. Also, I've tried deleting the _DatabaseResources and database folders from Users\Shared\NI Resources. When either Maschine or Komplete Kontrol rebuilds its databases, duplicates of the _DatabaseResources and database folders appear inside Users\Shared\NI Resources.

    I think this all started happening when I installed Native Access 2 or updating to Komplete Kontrol 2.7.2

    It is really driving me nuts. Do I need to reinstall everything? TIA!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,948 mod
    Answer ✓

    No need to delete the files in the NI Resources folder, what you need to reset Komplete Kontrol 's database is to delete this folder: Mac HD > Users > Username > Library > Application Support > Native Instruments > Komplete Kontrol

    If you already deleted that and the issue remains, we'll need to check your system so I'll contact you by email.

  • channelo
    channelo Member Posts: 7 Member
    Answer ✓

    Thanks for that! I tried that and it didn't work. So I went and moved all my Local Pref plist files for Native Instruments into a folder on my desktop, then I added them one by one back into the Local Pref folder and rebuilt the db each time to see if any of them were causing the presets to duplicate. It literally took me hours!

    But I found the culprit files. Turns out they were the Massive X Factory Library plist file and a few Massive X expansions:

    com.native-instruments.Massive X factory library.plist

    com.native-instruments.Pulse.plist

    com.native-instruments.Rush.plist

    com.native-instruments.Scene.plist

    I don't know why they were causing problems, but removing them and reinstalling them doesn't seem to work so I will live without them for now.


    Hope this helps someone else with a similar problem. Thanks

  • G15
    G15 Member Posts: 2 Member

    Was there a solution for this? i have the EXACT same issue and tried the above steps (deleting recommended folders and .db3 files)

    It takes hours for it to 'komplete' the scan on my system and for it to only result with the same issue is EXTREMELY frustrating.

    at one point during the scan there were no duplicates, however after i did my victory dance and sat bac down at the computer i realized all the same duplicates were. somewhere during the scan it triggered the duplicated presets in the list.

    Please help. I'm obviously not the only one with the issue and if there was a solution found, it should be posted.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,948 mod

    @G15 I already answered in the other post where you submitted the same message.

  • Niko Craft
    Niko Craft Member Posts: 9 Newcomer
    edited December 2023

    Hi @Jeremy_NI I just run into the same issue after moving my library from one to another location. My assets doubled from 22k+ to 43k+, I restarted the Komplete Kontrol and now assets are showing 9670 Presets, and its not being updated.

    I'm on Komplete Collectors Edition, and I got 80% of stuff installed, so this number is too small now.

    I wanted to reset the database as you suggested BUT and I am on windows 11 pro, I can't find this path: "Users -> Username -> Library -> Application Support..." and as I wrote this I realized that path is for Mac OS.

    Do you have same path for us windows 11 users? So I can reset the database and get back to 23k+ presets I remember having just before I reallocated my 450GB NI library.



    Edit: Ok this is really weird, restarted Komplete Kontrol again and now files are doubled again and at 43k+. How can I nuke the database? Could you help me with the path?


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,948 mod

    @Niko Craft On WIndows, this is how to reset the database:

    Reinitialize the KOMPLETE KONTROL Database

    1. In the Windows File Explorer, go to the following location on your computer:
    2. C: > Users > *Your Username* > AppData > Local > Native Instruments
    3. Note: The "AppData" folder is hidden. See this article for instructions to access hidden Windows folders.
    4. Search through the Native Instruments folder at this location to find the KOMPLETE KONTROL folder.
    5. Delete only the KOMPLETE KONTROL folder found here.
    6. Note: Deleting other NI product folders could result in unexpected behavior with other applications.
    7. Reopen the KOMPLETE KONTROL software to check that the issue has been resolved.


  • bhayes
    bhayes Member Posts: 1 Member

    Hey everyone, just wanted to chime in and see if I could help anyone else who says this method doesn't work for them.

    1. Open your NI software and navigate to a Library that is affected with duplicate presets.
    2. Right-click the duplicated presets and hit Find in Explorer
    3. Compare the file paths side by side and look closely! They may look very similar but for me this is where I noticed the issue.

    For example my Analog Dreams folder had another folder inside it called Analog Dreams Library which were all of the same files but with a newer date on them. I ended up keeping the new files only and then followed the instructions above to Reinitialize the KOMPLETE KONTROL Database.

    No more duplicates after yay!

    Hope this helps somebody :)

  • Niko Craft
    Niko Craft Member Posts: 9 Newcomer

    Thank you, my Komplete Kontrol managed to sort it out by it self after a restart or two and letting it scan everything for few minutes. After third or fourth restart it was back to correct number of samples :)

Back To Top