Beatport Link issue with track waveform

misura
misura Member Posts: 1 Noise

For some reason, when I load a track from beatport link, a tiny little slice of waveform gets cut at the very beginning of the track, and I assume that sends the bpm and cue calculation forward of a bar, as the distance from the first kick and the second is not as the same as in the remaining bars of the track. That missing bit makes launching the record by hand with DVS or TT Jog wheel an actual challenge.

I opened a case with beatport link support, but they say I should contact NI cause they can't replicate the issue, but funny enough I am on the beatport link user group and others are experiencing the same issue.

See that tiny yellow bit at the attack of the first kick is missing in the beatport link track, and that seems to be pushing the cue to the next 4 bars, where the distance among kicks is consistent.

I am on latest version of trackor (3.53 303) - Win 11


Tagged:

Best Answers

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,406 admin
    Answer ✓

    Indeed Traktor seems to have a hard time analyzing the track because of its contents. A solution provided by support is to manually correct the beat grid of a track: 

    How to Set Beatgrids in TRAKTOR

  • zephry
    zephry SeattleMember Posts: 128 Tri
    Answer ✓

    I tested moving it back to the beginning. It causes the grid to be incorrect.

    It is best to leave it the 4 or 8bars in so that the grid starts on the one. As I said above most the time a person is probably not mixing from the absolute beginning of the track anyway.

    You can always quickly check if the grid is correct by jumping ahead to a drop. The grid should have the thicker line on the first beat of the drop. (Using the dim setting for the grid and assuming you are mixing dance type music)

  • Mat_Lock_DJ
    Mat_Lock_DJ Member Posts: 5 Sine
    Answer ✓

    Okay, looks like I have solved the issue by downgrading from Windows 11 to 10 and installing Traktor Pro 3.5.3 from new. On the W11 I had original Traktor Pro 2.x and then upgraded to 3.x this could have been a deciding factor too. But so far on the new setup its working perfectly again

Answers

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,406 admin

    Hi! Not sure I've seen similar reports from other users here. But I see that you contacted our supported team already. Pls keep us updated if you find a fix.

  • zephry
    zephry SeattleMember Posts: 128 Tri

    I tested putting the Beat marker at the beginning when this happens and the result is a bad grid. Definitely leave it alone unless for some reason it isn't on the downbeat (the one).

    The good thing is Traktor does usually put this on the downbeat when it is moved forward, typically 4 or 8 bars in. So you don't get offset drums.

    This doesn't bother me because I usually am looking for a different place in the track to use anyway.

    Maybe has something to do with a compromise that had to be made so that the track can be analyzed and downloaded faster?

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,406 admin
    Answer ✓

    Indeed Traktor seems to have a hard time analyzing the track because of its contents. A solution provided by support is to manually correct the beat grid of a track: 

    How to Set Beatgrids in TRAKTOR

  • zephry
    zephry SeattleMember Posts: 128 Tri
    Answer ✓

    I tested moving it back to the beginning. It causes the grid to be incorrect.

    It is best to leave it the 4 or 8bars in so that the grid starts on the one. As I said above most the time a person is probably not mixing from the absolute beginning of the track anyway.

    You can always quickly check if the grid is correct by jumping ahead to a drop. The grid should have the thicker line on the first beat of the drop. (Using the dim setting for the grid and assuming you are mixing dance type music)

  • zephry
    zephry SeattleMember Posts: 128 Tri

    To backtrack just a bit.

    My answer is 80% correct! Lol

    Sometimes, especially depending on the genre.

    The grid might be offset with this anomaly.

    I have had some tracks be the wrong bpm and not match up when using sync.

    Traktor uses sync! For effects and in general for finding a grid and bpm. But I have found some tracks that are not 4 to the floor or long intros to be way off.

    My suggestion is that if you are expecting dance and typical House style tracks to work.

    You should get used to understanding the grids and structure of tracks.

    If you want to force a track to work, you probably can. You just have to find the drop section and know where you want to mix.

    But be aware! Mixing from a streaming and unplanned tracks can sometimes need a quick adjustment of the grid. Practice this and you will know what to do.

  • Mat_Lock_DJ
    Mat_Lock_DJ Member Posts: 5 Sine

    Hi,

    I have been using Beatport Link for 3 months and have this issue constantly. I play mainly trance, melodic/progressive house and so a lot of tracks I will start transitions from the very forst beat so the phrases work better in the mix.

    If NI and BP Link can't provide the track in exactly the same way a purchased track is being analysed at then surely that means there is a bug. A pretty big bug that prevents someone from quickly mixing a track on the fly rather than having to fix the beatgrid.

    I've regularly had to fix the beatgrid, and then in the middle of transition realise it's out by a beat so i get double claps etc.

    Please NI investigate this issue properly and try to get BP Link on board. It is very frustrating as the workaround just shoudn't need to exist.

  • Mat_Lock_DJ
    Mat_Lock_DJ Member Posts: 5 Sine
    edited July 1

    So I have just reanalysed this situation and in fact sometimes it's not just missing a small amount off the 1st beat, it's actually dropping a whole beat and the bit inbetween.

    I just counted the beats back from a 32 beat phrase and when I get to the start of the track I have only counted 30, then 31 is the 3/4 of a beat showing in the grid which means it's missing another whole beat.

  • Mat_Lock_DJ
    Mat_Lock_DJ Member Posts: 5 Sine
    Answer ✓

    Okay, looks like I have solved the issue by downgrading from Windows 11 to 10 and installing Traktor Pro 3.5.3 from new. On the W11 I had original Traktor Pro 2.x and then upgraded to 3.x this could have been a deciding factor too. But so far on the new setup its working perfectly again

Back To Top