Komplete Kontrol Categories randomly change and put many products into "other"

anthony-1979
anthony-1979 Member Posts: 23 Sine
edited March 21 in Komplete Kontrol

Recently my KK has been showing libraries all under "other" instead of 'sampled instruments" and "synthesizers" etc. Sometimes KK loads with only a few under "other" and the rest properly categorized but it's never how it used to be with correct placements of products in the correct categories. Any idea how to remedy this? I've rescanned and deleted prefs and got Komplete Kontrol to re-init and it doesn't fix the problem.

Best Answer

  • anthony-1979
    anthony-1979 Member Posts: 23 Sine
    Answer ✓

    I deleted all things NI and reinstalled all NI products and deleted the waves NKS preference files. That About solved all my loading time issues and also solved the wrong categories.

Answers

  • Matt_NI
    Matt_NI BerlinAdministrator Posts: 748 admin

    Tagging @Jeremy_NI, he might know what's happening here.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 987 mod

    Hey @anthony-1979 it looks like you are already in contact with one of our support agents, it might be good to let them know about this new issue. Usually, deleting these folders and files would fix this:

    Mac HD/Users/User Name/Library/Application Support/Native Instruments/Komplete Kontrol (folder)

    Mac HD/Users/User Name/Library/Application Support/Native Instruments/Shared/favorites.db3

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:


  • anthony-1979
    anthony-1979 Member Posts: 23 Sine
    edited March 22

    Thanks for this info, I kinda did this when removing everything NI to start from scratch again. You may be interested to know that the original problem I was having was NI synths like Absynth, FM8, reaktor taking forever to load. I narrowed it down to having Waves NKS files installed. Removing the Waves stuff made everything super snappy again. Just wanting to point this out so that It can be perhaps investigated and fixed.

    Tiny side note: Session Bass - Prime Bass "always" eventually puts itself into "other" category. Was the only item in "other" before everything got screwed up for me and now after a fresh install is again under "other".

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 987 mod

    Hey @anthony-1979 Ok, this definitely requires more information on your system. Please inform my colleague of this new problem, and also please send the missing files.

  • anthony-1979
    anthony-1979 Member Posts: 23 Sine

    Can I just clarify what’s happened for a second.

    Ok so I had 2 issues to begin with. The first was slow loading NI synths. The second was all categories being lost and everything appearing under ‘other’. I deleted everything NI related from my computer and started from scratch. With native access started to install everything from scratch. Got everything back to normal running super fast and everything appearing under the correct categories again. Except for prime bass which likes to go to ‘other’. As soon as I installed waves NKS again everything was back to sluggish load times for about 5 synths. Removed waves.native.instruments prefs and everything super fast again. I’m happy now without the waves NKS and it’s a little annoying but prime bass is parked at ‘other’. Hope this clarifies the situation.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 923 admin

    @anthony Looks like your issue has now been resolved with the help of the support team. Do you mind sharing a solution with us? 🙂

  • Kubrak
    Kubrak Member Posts: 852 Saw

    It has happened to me also that I have all plugins under Others. On Win. I thought it is some kind of intended change.

    Trully said, I prefer it as it is now, and do not want to get it repaired to correct state.

    Different people, different preferences. Hard to please all.

  • anthony-1979
    anthony-1979 Member Posts: 23 Sine
    Answer ✓

    I deleted all things NI and reinstalled all NI products and deleted the waves NKS preference files. That About solved all my loading time issues and also solved the wrong categories.

Back To Top