Inconsistencies with Komplete Kontrol M32 and Ableton

Andreas Ericsson
Andreas Ericsson Member Posts: 9 Member
edited November 2022 in Komplete Kontrol

I bought the Komplete Kontrol M32 yesterday and initially I was very happy with my purchase. My goal is to use it as an Ableton controller. Browse sounds in komplete kontrol, record a melody, jump to the next track and repeat the process. That worked really well at the start of a session but eventually everything got messed up and there was no way to solve it. I could not jump between tracks anymore and the transport controls stopped working. Instead of starting and stopping the track they played a note on the selected track 🤨

If I started a new session everything worked again. But if I loaded the first sessions the problems were still there.

Is there anyone here that has experienced this and has a solution?

Tagged:
«1

Comments

  • Nico_NI
    Nico_NI Administrator Posts: 1,125 admin

    Do you have more details on your OS/setup/Ableton version?

  • Andreas Ericsson
    Andreas Ericsson Member Posts: 9 Member

    Hi Nico!

    Yes ofc,

    MacBook Pro M1pro

    Mac os Monterey

    Ableton 11 Standard

    Komplete Kontrol 2.8.0+25

    Just tried to run Komplete kontrol in rosetta mode but no difference.

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    Post a screenshot of your midi preferences

  • Andreas Ericsson
    Andreas Ericsson Member Posts: 9 Member

    Tried a bunch of different settings but nothing seems to solve it.

  • Andreas Ericsson
    Andreas Ericsson Member Posts: 9 Member
    edited November 2022

    Update:

    So everything works fine until I save and when I open the session again it's corrupted. I cannot get back to "Track Instance" And almost every button seems to generate a note on the keyboard instead of doing what it should.

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    Clear everything I have highlighted as a start

    In control surface you should have ONLY 1 listed antry for the keyboard with BOTH IN/Out set to the keyboard DAW port

    In the MIDI ports section below the MIDI port used in the control surface section should NOT have ANY options checked (since it is acting as a control;; surface, it has a script doing the work so no need for signals in the midi section.

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    Also, I would suggest placing the keyboard control script as device 1 in the above screenshot followed by Push then nothing in any other slots, set all to "none".

  • Andreas Ericsson
    Andreas Ericsson Member Posts: 9 Member

    Hi JesterMgee!

    Thanks for all the tips.

    I tried your suggested settings:

    But I get the same problem as before. Everything works fine until I save and open the session again.

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    Well, keep the MIDI settings as they are because that is now how it should be, No idea then for your issue, i'd be tempted to simply say it's a mac issue then simply because it usually is, especially if you have an M1 (no helpful specs in your profile...)

    Windows 10 and 11 systems here with an A series and MK2, both are fine and dandy with Ableton 11

  • Andreas Ericsson
    Andreas Ericsson Member Posts: 9 Member

    Yep, M1pro. I actually bought this Macbook because I was so sick of how bad windows and pc's handle audio and music production. The Macbook has been a complete joy to use with Maschine MK3 ever since.

    I think the issue is the new update to komplete kontrol software 2.8.0. If l load up a bunch of other vst-synths everything works fine. It only happens when I have KK on a track.

  • Andreas Ericsson
    Andreas Ericsson Member Posts: 9 Member

    Update:

    Ok, so this is weird but I've found a way to solve this. The controller does not like when the selected track is a KK track when I save the session. If I reopen all my corrupted sessions and then select the master track, save and reopen everything is fine again 🤔

  • Andreas Ericsson
    Andreas Ericsson Member Posts: 9 Member

    I actually have one more question regarding the komplete kontrol software. When I load a new project in Ableton I can jump between tracks by nudging the pushencoder left and right and the selected track gets armed for recording. But when I put KK on a track and then try to switch between track, the arming does not follow. Anyone experienced this?

    And here is also a strange behavior, if i turn on Ableton Push 2 everything works again. Track arm follows the selected track on M32.

    Can't figure out a way to solve this. I don't want to be forced to have Push switched on to be able to use M32.

  • D-One
    D-One Moderator Posts: 2,689 mod
    edited November 2022

    It could be a M1 Pro specific issue. Arming when using KK to change tracks and reloading sessions both work fine for me on the regular M1.

    Have you checked if your firmware is up to date? Download the update tool here in case you haven't:

    https://www.native-instruments.com/en/support/downloads/drivers-other-files/#kompletekontrol

    If all fails then contact tech support.

  • Andreas Ericsson
    Andreas Ericsson Member Posts: 9 Member

    Hi D-One and thanks for your response!

    Yep, checked firmware and it's up to date.

  • Juan Salazar
    Juan Salazar Member Posts: 4 Member

    Same problem, 3 instances of KK, but this worked for me M1 Macbook Pro 13" Ableton 10.1.43, thanks!

Back To Top