Busy season in progress... Please note that due to a high volume of requests, the response time from our support is currently longer than usual. Chat is temporarily not available. We thank you for your understanding.

Massive X and/or Super 8. CPU max out on both instuments and no controls to tweak?

Donkey Oaty
Donkey Oaty Member Posts: 18 Sine

I am having a problem with two synths that I acquired with Komplete 13.


‘Massive X’


‘Studio 8’


THE PROBLEM

The problems are identical on both. Running presets on some fairly simple MIDI tracks they both max out the processor. That’s individually or together. My DAW’s (Studio One 5) performance manager reports that they are each using up to 30% of my CPU in background and 100% of it when playing the previously scored recorded MIDI. When this happens everything else keeps running and playing but the two instruments concerned (either individually or together) completely distort and – it’s more than drop out. It’s like they’re grabbing one processor core. Most VSTs and instruments have some means of limiting the resources they use. I can’t find this (I even RTFM’d) for either of these.

HARDWARE & SOFTWARE

I’m running a Windows 11 laptop with an I5 7300 CPU, 32 GB of RAM and an internal 1TB M2 SSD. The NI programmes & libraries, the DAW, the songs – are all on this internal drive. My Windows 11 is up to date as are the machine manufacturer and component provider drivers.

THE SOLUTION

Is there a solution to this? It’s as if it’s grabbing a CPU Core and that when both used in the same song that they are both trying to latch in to the same one. My machine runs fine when they glitch as do other instruments – hence my speculation on the core issue.


Does anyone have any solutions please?

Comments

  • EvilDragon
    EvilDragon CroatiaModerator Posts: 791 mod

    Plugins have no control over which core they are assigned, this is all up to the host to handle.

  • arachnaut
    arachnaut Sunnyvale, CA USAMember Posts: 62 Tri

    It may be that, even though you have multiple cores, the DAW is not assigning VST processes well.

    If both heavy users were set to run on the same physical, but separate logical core, they will cause that core to thrash sometimes.

    Try temporarily disabling hyperthreading in BIOS and see if that helps.

  • Donkey Oaty
    Donkey Oaty Member Posts: 18 Sine

    These two plug ins don't seem to be releasing the core. Everyhting else I use from NI seems to do that.

  • Kubrak
    Kubrak Member Posts: 1,341 Pulse

    Massive X may be pretty CPU intensive. Do not look at overall CPU load, instead have a look at individual cores.

    Also, at which speed runs your notebook? And beside disabling hyperthreading for a test, you might also experiment with audio buffer size.... Also you may try, how many tones you may play in MX together without problems.

    As far as I remember, I had problems to run Massive X on very old i7 notebook....

  • Donkey Oaty
    Donkey Oaty Member Posts: 18 Sine

    I've tried disabling the hyperthreading option - with no real effect. Thanks for that suggestion. I can't find any way of reducing voice count in Massive X or Super 8 - but they're both synths. I'll try adding more audio buffer. Log files are showng that total memory load with Studio One ramped right up is less than 40%. so there's certainly capacity for a bigger audio buffer. I'll let you know the result on that. Thanks again.

  • Donkey Oaty
    Donkey Oaty Member Posts: 18 Sine

    I delved into the BIOS and its pretty simpe - the hyperthreading is either on or off. It was already on. However, being able to 'check that box' lead me to make a few tweaks to both Windows and my Studio One set up and ... things are better. Super 8 is not 'maxing out processor use any more - it's peaking at about 46%. which is still ludicrously high. So it won't become my synth of choice. Thanks again.

Back To Top