In Studio One Komplete Kontrol keeps saying Update Required

Options
2

Comments

  • PoorFellow
    PoorFellow Moderator Posts: 3,460 mod
    Options

    Thank you Matthew_NI and thank you for your time ! 🙂

  • Ongey
    Ongey Member Posts: 20 Member
    Options

    Thanks Matthew, that's good to hear, and am happy to help with any user-based tests / diagnostics / info etc.

    Neil.

  • Megatim
    Megatim Member Posts: 12 Member
    Options

    Thank you very much Matthew. Same as Ongey, I am happy to help in any way to resolve this issue. So if there is anything I can do, please just ask.

  • Megatim
    Megatim Member Posts: 12 Member
    edited March 14
    Options

    Hi all, any news on this topic? Updating to the current versions did not fix the issue for me yet.

  • Jonas Denolf
    Jonas Denolf Member Posts: 16 Member
    Options

    Haven't heard anything from Matthew or NI so far @Megatim i'm hoping for an update

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,871 mod
    Options

    I guess this is a Windows bug? Not seeing it in Studio One on my Mac

  • Ojustaboo
    Ojustaboo Member Posts: 216 Advisor
    edited March 15
    Options

    Also not getting it on Windows 10 pro, the latest Studio one pro and the latest Komplete Kontrol v3.

    I know it can feel annoying when other users say it works fine for them, not trying to annoy, just wanting NI to know it’s not a bug every windows user is having.

    You watch, now I’ve said this, tomorrow, I’ll go into Studio one, and I’ll get the same problem.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,871 mod
    edited March 15
    Options

    People should not get annoyed at that, it is an essential part of any bug fixing process to be able to identify the exact circumstances that trigger the bug, which means knowing which systems are affected and which are not is extremely helpful. Negative reports are just as important as positives. Most bugs are based on a combination of factors and it's not at all unusual for there to be some very system specific factors at work.

  • Ongey
    Ongey Member Posts: 20 Member
    Options

    I've not heard anything, but I'm satisfied with the last update that they had escalated to a bug. Just have to be patient and in the meantime, I can work with Kontakt 7 at least (hopefully that's ok for others experiencing the bug).

    People (including me) have reached out and offered support with diagnostics etc to NI, always happy to help investigate and fix bugs - it's part of my job, so I have every empathy with the NI developers.

    It's good to see NI are actively developing features for KK (as we see from the recent Roadmap post), so I remain optimistic.

  • Wispirer
    Wispirer Member Posts: 2 Member
    Options

    Just received my S61 Mk3 Friday. Having the same issue posted here. One thing I can contribute is that a new clean project with nothing in it except a KK instrument will have this issue when loaded. But if you delete that track and instrument, and drag a fresh copy of Komplete Kontrol over and drop it in as a new instrument, it loads perfectly and works without issue.

    So at least in my case, the issue seems to be when the S1 project is loaded. KK doesn't want to initialize if its already instanced. But when creating a new one, it seems fine and my S61 picks up the KK instance.

    What's also interesting in my case is sometimes I get the update error, sometimes the S1 project will load, but my S61 has no awareness of the instrument. I see the generic midi screen on the S61. The KK instrument reacts to the midi, but there is no awareness between the s61 and KK.

    Deleting that instrument, and dropping in a new one causes the S61 to wake up and start working with KK. NI, I hope you are continuing to read these posts and are incorporating the information into your development bug fixes.

  • FelixP
    FelixP Member Posts: 9 Member
    Options

    We were finally able to reproduce and identify the issue and are working on a fix.

  • Ongey
    Ongey Member Posts: 20 Member
    Options

    That's great Felix, thanks for letting us know! Just proves that the community forums work, and NI support / developers are listening 👏

  • Jonas Denolf
    Jonas Denolf Member Posts: 16 Member
    Options

    Great to hear! that is a relief to the heart thank you so much Felix!!!

  • Wispirer
    Wispirer Member Posts: 2 Member
    Options

    Thanks Felix & NI Support / Dev teams!! Goes to show NI supports its Pros using NI studio tools.

  • Megatim
    Megatim Member Posts: 12 Member
    Options

    Thank you Felix, that is great to hear! Looking forward to the fix!

Back To Top