Ableton LINK won’t stay connected

Dbdecker
Dbdecker Member Posts: 4 Newcomer
Hi there

I’ve been testing out a few products that support Ableton link, for example Maschine+ to control traktor tempo in a sync mode (working in external devices etc)

What I am finding is approx every 5 mins or so, the LINK disconnects.

I’m not sure if this is just “how it works” or if anyone has experienced and perhaps resolved this issue?

Also trying out the happy curcuit junior and ml2 from my euro rack setup, they also disconnect.

When reconnecting, the sync tempo has moved out of phase and I need to readjust everything.

(It’s pretty much, useless)

Answers

  • leesinthemix
    leesinthemix Member Posts: 245 Guru
    edited February 8

    Ableton Link in Traktor has been buggy for quite a while now... @Stevan may be able to help you.

    I always forget which sync mode that Link has trouble keeping in time...

    I really hope the Traktor team are able to spend some time on it this year after the mooted overhaul of other big features on the horizon. I've gone back to using MIDI clock in the past year or so, especially when it comes to DMX lighting or syncing my Maschine.

    Let's hope changes are on the way.

    How has the new Missing Link Junior been so far? Really want to get one soon.

  • Dbdecker
    Dbdecker Member Posts: 4 Newcomer
    Thanks @leesinthemix I expect i'll be using clock sync too (i have a Hapax that does a decent job on that) means I have some hardwware that is redudant, perhaps I can just sell...but I would also, really like to see this work with a consistent connection.

    When it does work, its really been quite good.
Back To Top