Waveform Stutter After Metadata Modification

Chaser720
Chaser720 Member Posts: 9 Sine

Moving this from over at the old forum to here. Original post below along with NI's response to my service ticket of "that's jut how it is".

Original Post:

Just bought a new macbook (14" M1 Pro), installed Traktor Pro 3.5.2 299 and transferred my settings over from my old macbook pro. Having a weird issue where every time I edit metadata (adding cue points mainly but adjusting grid, adding comments or just scrubbing around the track does it too) the wave form has two distinct skips. One right after I make the change and one 1 second after. No audio skips. Submitted a ticket yesterday but no response yet. Anyone else with similar issues?

https://imgur.com/a/wzpO61e

NI's unacceptable response:

thanks for sending the video! The degree of skipping depicted is nothing too unusual on Mac computers. It refers to a kind of well-matured technology under the hood and is expected to be subject to improvement in future Traktor generations. As you have observed correctly, it affects only the visual part of Traktor and does not at all endanger Traktor's audio output.

You might be able to slightly improve the behavior by taking the steps in the following article:

Mac Tuning Tips for Audio Processing

Comments

  • Guy Raz
    Guy Raz Member Posts: 1 Noise
    edited January 20

    @Chaser720  i have the same problem since i updated to 3.5.2 (running on catalina)

    luckily its just graphic issue. But still its a shame!!! very annoying and everytime it happens i hold my breath🥵

  • daveb124
    daveb124 Member Posts: 32 Sine

    i can am having the same issue on 3.5.2 on latest windows 10.


    i noticed its not just the waveforms but also the levels. Sound output unaffected. It doesnt happen when you first open traktor but after a few minutes,


    strangely when you click the close X button and the "are you sure" dialogue box appears all the waveforms and levels in the background revert to normal smooth behaviour. Close the dialogue box without closing traktor and its all stuttery again.

  • Chaser720
    Chaser720 Member Posts: 9 Sine

    Yeah. My old MBP (2012 low end model) would occasionally do it after 30min to an hour of playing but after installing Fan Control and ramping the fans early to keep the CPU cool, it cut out 95% of it.

    With this brand new MBP it's every time from the start. Sucks because I can't crank the settings high enough to make the load bar get over 15% but it can't handle a metadata change of the track. Sometimes getting the same issue while scrubbing.

    NI did get back to me and made sure to first address the negative feedback I gave for "Its normal on Mac" before I told them again that it's a visual waveform skip and not audio.

    Quote/

    a quick remark to begin with: I saw your bad rating referring to the 'solved' status. Please note that it wasn't me who set that status. When you checked the Knowledge Base article, a little dialogue popped up in the lower right-hand corner asking you whether the article answered your question:......

    /Quote

    Note to NI: Work on the problem and not the negative feedback you get on non-solutions.

  • Matt_NI
    Matt_NI BerlinAdministrator Posts: 765 admin

    Hey Chase, I'd like to clarify a few things here.

    Our support team isn't responsible for the development of the product and what you are being told isn't "that's just how it is". There is obviously some confusing on where the issue might come from but we also know that there can be issues. Issues that are "expected to be subject to improvement in future Traktor generations". Sharing with us that this specifically come from editing metadata will help our engineers.

    And yes, they are addressing the bad rating and take the time to detail why your ticket was marked as solved. That's what support teams do and obviously we want you to understand why there was no response to begin with.

  • daveb124
    daveb124 Member Posts: 32 Sine
    edited January 23

    Hey I have a bit of an update. And it's a curious one. I am using Lenovo yoga core i7 6th gen. 8gb of ram. Latest windows 10 with patches. It's full optimised Audio use only laptop. Works fine with load in traktor always low on correct latency settings for the sound card and CPU load is always low. I alternate between denon mc6000 z1, z2 and Roland mx1 mixer ( with x1 MK2). Running traktor 3.5.2.

    The issue I described above only appears to happen with the roland mx1. It was working ok but last time I used mx1 was about 6 months ago iirc. I dont think Roland have updated the mx1 driver in ages so it's either a Windows update or traktor update causing the issue.

    It's curious that using a specific soundcard would cause a visual defect. Especially when the load is still low and sound quality unaffected

    Also strange that it stops happening when a dialogue box is open.


    Anyone got any ideas what I could do to try to fix it ?

  • Chaser720
    Chaser720 Member Posts: 9 Sine

    Let's focus on the problem and not the feedback I left... again...

    Dude literally said and I quote, "The degree of skipping depicted is nothing too unusual on Mac computers.". That is exactly the same as saying "that's just how it is".

    So who do I email if the support team is not responsible for the development of the product?

  • Matt_NI
    Matt_NI BerlinAdministrator Posts: 765 admin

    Our Traktor team is already looking into it and they will be in touch with you via email as soon as they have some feedback to share. We need to do some testing and it can take some time to confirm if there is a bug or not. I'll share the outcome in this thread for anyone else interested.

  • daveb124
    daveb124 Member Posts: 32 Sine

    @Matt_NI thanks, does that investigation also cover the feedback I gave or should i raise that separately?


    thanks


    dave

  • Chaser720
    Chaser720 Member Posts: 9 Sine
    edited January 26

    Looks like they confirmed it's a bug and raised a defect ticket.

    Hello Chase, 

    My colleagues in QA have checked the behavior, were able to reproduce it, and created the following entry in our internal error documentation: 

    TP-16789 - Waveform stutters when setting cue points & editing metadata (playback/ audio unaffected)

    Our developers now have this on their agenda and will address the issue. I hope to see the issue tackled soon! 

  • daveb124
    daveb124 Member Posts: 32 Sine

    @Matt_NI do the development team think that this bug fix will also be the cause of the issues I am seeing?

  • daveb124
    daveb124 Member Posts: 32 Sine

    Hi can someone from NI comment please ?

  • Nico_NI
    Nico_NI BerlinAdministrator Posts: 654 admin

    Hey Dave, we would advise to proceed like @Chaser720 and raise a ticket. You can maybe mention the reference TP-16789 - Waveform stutters when setting cue points & editing metadata (playback/ audio unaffected) so they can make the connection.

  • daveb124
    daveb124 Member Posts: 32 Sine

    case raised :-)

  • kashada
    kashada Member Posts: 1 Noise

    Hi,

    I'm having similar issue since the 3.5.2 299 update, the waveform have a strange behaviour like stutter when the song is playing. I have tried with the option "enable multicore processor support" disabled and it has improved a lot, however not enought compared to my previous version 3.4.0 237 where even with the multicore processor enabled everything runs fine.

    Sound output unaffected on both, but the stutter is anoying.

    I'm using:

    MacOS Mojave 10.14.6 / 13-inch, 2017, Four Thunderbolt 3 Ports / 3.1 Ghz Intel Core I5 / 8 GB 2133 MHz LPDDR3 / Intel Iris Plus Graphics 650 1536 MB

    David

Back To Top