Reinstalling all my stuff after a HD crash - NI Access does NOT like this scenario

wayfinder Member Posts: 221 Pro

I recently lost the drive on which my NI Library was stored. That sucked. Now I am trying to reinstall/repair all the stuff that vanished, and I am running into troubles:

  • some older products (like Berlin Concert Grand and Abbey Road 60s Drums) cannot be installed or repaired via NA at all.
  • they can also not be uninstalled via NA! the option is there, it says it worked, but the broken product remains.
  • I found instructions and a sketchy-seeming Google Drive with installers for the legacy pianos in the NI support pages. these installers work at varying levels of annoyance - New York and Upright will not install unless the directory into which they are supposed to go already exists (but will happily announce that the installation successfully finished, even when it didn't!)
  • the instructions page in the support portal has different instructions for "NA 1 (light)" and "NA2 (dark)". my NA2 is light though (it follows the OS theme so it can be either). i did not realize at first and followed the instructions for NA 1 because my NA wasn't dark. it still worked, somehow, and the products finally appeared as "installed" in NA. it would be good if this info and the link to the instructions came up in NA when dealing with the respective products
  • I was not able to find an installer for the 60s drums in the support pages. I realize that the (newer, successfully installed) Abbey Road 60s Drummer exists, but that is not helpful when I am trying to open project files that were created using the older product. a google search turned up a post from @Jeremy_NI that linked to another Google Drive with the correct installer:
  • some products will complain that the directory in which they were installed before the crash does not exist, and will not install - others will install, even though their directories do not exist either.
  • I think the difference may be that the ones that were up to date before the crash can be repaired, and that the ones that needed an update will not repair the installation but try to update the non-existing files (even though everything in the app, including the button I clicked, says "reinstall" and not "update", the task in the queue is called "[product] Update"). i think that's a bug. the apparent workaround is to first uninstall, then reinstall.
  • When trying to uninstall, I get another error message about the missing directory, then the button will let me install the product again
  • NA at one point went completely white - it seemed to still be working, but it wouldn't display any UI. i had to close and restart it.
  • NA does not remember the task queue across sessions, which is great when you're trying to reinstall 60+ products
  • NA at some point stopped showing what was left in the queue - it still said "23 items" and would continue working through them, it just stopped showing the queue items that weren't currently active (downloading or installing)
  • NA gets a little optimistic with the remaining download time calculations for items that started downloading while the previous product was still installing. at the point where that installation finishes, the estimate jumps from an accurate value to one that is unrealistically small, displaying "About 1 minute remaining" until it drops below one minute, which in some cases means that it stays at "about 1 minute" for 10-20 minutes. here's a video capturing the last two bugs in action:

to summarize: bugs, widely-scattered information and intransparent, inconsistent behavior create stress, doubt & uncertainty. it's a bad experience.



  • Milos
    Milos Member Posts: 775 Advisor


    Maybe you need to update your device first.

    Then, make a custom desktop folder for plugins, and then go to the File Management to change the location of the libraries (VST or VST3, free to choose)

    Hope it solves the issue.

  • wayfinder
    wayfinder Member Posts: 221 Pro

    I don't understand your post, sorry, can you explain?

  • Milos
    Milos Member Posts: 775 Advisor

    1.Update your OS.

    2.Make a desktop folder.

    3.Open NA

    4.Open Preferences

    5.Open File Management

    6.Click on VST or VST3 location and change the location to the desktop folder you created.

  • wayfinder
    wayfinder Member Posts: 221 Pro

    sorry, I still don't understand - which of the points is this supposed to address? how would it help? what problem would it solve? are you sure you were replying to the right thread?

  • Milos
    Milos Member Posts: 775 Advisor

    This is step by step comment.

    I had very similar issue and i did these steps and it worked.

    Maybe it can help you too.

    If it does not, ask PoorFellow or Kymeia, maybe they can help.

  • wayfinder
    wayfinder Member Posts: 221 Pro
    edited November 28

    help with WHAT specifically? which part of my post is it addressing? what problem of yours did it solve?

Back To Top