Unable to set up Kontrol S61 MK3

Options
2»

Answers

  • Ravedavid
    Ravedavid Member Posts: 6 Member
    Options

    Hi,

    has anyone sorted this yet? Picked up my keyboard yesterday but getting the message ‘Download the update at ni.de/kontrol-update’ but this takes me to a blank page. So frustrating!

    Cheers

    Dave

  • jori
    jori Member Posts: 6 Newcomer
    Options

    Has anyone had this problem and found a way to fix it? When trying to register the hardware I get "An error occurred while processing your serial" error message

  • Chris Cologne
    Chris Cologne Member Posts: 6 Newcomer
    Options

    I have installed the Hardware Connection Service and add the serial key of the new S61 MK3 in Native Access. But the display shows allways the "Welcome Screen" with the serial number. I tried to use the Firmware Updater but he does not find the S61.

    • Windows 11
    • AMD
    • Connected by USB-C


  • remo
    remo Member Posts: 12 Member
    edited October 2023
    Options

    Hi there,

    I have the same issue on AMD Ryzen 7th generation. Really frustrating, I tried everything from here:



    https://support.native-instruments.com/hc/en-us/articles/14229160390045-Kontrol-S-Series-MK3-Troubleshooting-Firmware-Update-Issues

    Both guides did not help. The keyboard keeps saying it is updating the firmwar but the update wizard on the computer, shows that it could not boot into firmware update mode. I wait for over 30 minutes and the keyboard is still showing it does the update, although the it already failed. It does not work, even after 5 times reastarting etc.


    I hope somone can help here. Thanks!

  • beanradio
    beanradio Member Posts: 6 Member
    edited October 2023
    Options

    any help from support? I'm having the same issue on S49 MK3. using the included cable connected to my hub. I was able to update the firmware, but hardware connection service doesn't even show in Applications (using a mac). Per the instructions we need to run this program to update the hardware then run the firmware updater. Please help, it's frustrating that we're not seeing support in these forums on a brand new product!!!


    Macbook Air M1 2020, 16GB, 2TB, MacOS Sonoma 14.0

    Kontrol S49 MK3 connected via the included cable to a hub.

    Native Access is installed with most recent update and was able to successfully register the hardware product, all the included software shows up under New in Native Access. I installed Hardware Connection Service (and reinstalled), and rebooted my computer. Still doesn't show up in applications. I tried searching for the app in Finder and using Spotlight and it doesn't come up. I'm at a loss...

    UPDATE: After updating the firmware I reinstalled Hardware Connection Service and the screen of the S49 MK3 changed to Default MIDI Template. In case any other users are experiencing this issue. It's probably better to update the firmware before installing Hardware Connection Service.

  • Mike Mass
    Mike Mass Member Posts: 9 Member
    Options

    error message when trying to load Kontrol "One of the files this plugin needs cannot be found, please reinstall or contact technical support for assistance". I've reinstalled and am having the same issues.


    Thanks

  • rjb
    rjb Member Posts: 1 Newcomer
    Options

    Well I received mine a few days ago, opened the box today, and still cannot update the firmware, macOS Ventura, Windows 10 it doesn't matter constant failure trying to update firmware. And it's not showing bricked per the Knowledge base article.

    I don't have a USBC hub and don't see why purchasing one would be required to make a firmware update function. I've used external USB-C power, no power, USB c to USB-A different ports different computers. Intel MB Pro I7 with Monterey none work.

  • Syngularity
    Syngularity Member Posts: 16 Member
    Options

    Same Problem here !!!!

    Very angry Native Instruments! 899Euro for NOTHING!!!!

  • Beatback
    Beatback Member Posts: 15 Member
    Options

    Same problem here S61 mk3 not recognized by software .

    Even the firmware upgrade can not see the s61.

  • Bridgenorth
    Bridgenorth Member Posts: 1 Newcomer
    Options

    This is absolute nonsense - display still showing the welcome screen with the serial number. Come on NI.

  • DDuncs
    DDuncs Member Posts: 1 Newcomer
    Options

    i just got my S61 MK3 on Friday (3 days ago) . It works to scroll and choose plug ins and instruments. However, the keys on the keyboard don’t work with Komplete Kontrol stand alone. I can use the s61 with all my other seifteare like Arturo’s, roli and EZ Keys and superior drummer. But not with anything NI. Hilarious that it works for everything but it’s own brand. The lack of information available is astonishing. I’ll just leave this here and start a ticket. I am super disappointed in NI.

  • WonderCPH
    WonderCPH Member Posts: 1 Newcomer
    Options

    Stuck at first page with serial number, submit request for help. Waiting for several days then, get it registered. Then installed the Hardware Connection Service. But it still stucks at the initial page with the serial number. The updater cannot recognize the MK3 keyboard! Very bad start!

  • jbgarren
    jbgarren Member Posts: 1 Newcomer
    edited January 12
    Options

    Similar issue here. I followed the setup instructions. Registered my serial, installed all the software from Native Access, including Hardware Connection Service and Komplete Kontrol.

    When I get to the Firmware Updater step, it just says "Please connect your KONTROL S MK3 and click RESCAN." I initially tried different USB ports, different cables, made sure it had the additional power USB, etc. None of that worked.

    Looking at the device in the Device Manager, it doesn't appear to have a driver installed for my S61. I've uninstalled & reinstalled the Hardware Connection Service, rebooted the system multiple times, but no change.

    From looking in C:\Windows\System32\DriverStore\FileRepository, I don't see a folder that looks like the a driver for the S61 MK3, based on what I've seen from other ppl who fixed their driver issues with the S88.

    From what I've read, I'm lead to believe that the driver might should be labeled something like "nikksm3usb.inf". But it doesn't appear Native Access installs that.

    It should be noted, my machine is managed by my work IT dept, and they control which Windows Updates are allowed to be installed. This could be relevant as I've seen NI rep posts that state they've pushed out new drivers via Windows Updates... but I may not be able to obtain the drivers via that method.

    I find it extremely annoying that I've spent hours and hours troubleshooting this issue for such an expensive keyboard, and there doesn't even seem to be anywhere I can manually locate and install drivers for the S61. And that Native Access doesn't appear to install them either, leaving the keyboard unrecognizable.

Back To Top