Komplete Audio Mk2 Driver Issue (Bug: KH1097-254)

Options
dor.re
dor.re Member Posts: 5 Newcomer
edited March 2022 in Other Software & Hardware

** This is a continuation of a thread from the old NI forum **

Hey all, this is to move the old thread from the old forum here, to keep track of the bug and monitor other users responses.

Since this bug I pretty much didnt end up using my Komplete Audio 6 MK2 interface, and had to buy another one (from another company) to be able to work on Windows, but I will come back to it and test now in the next few days to see if there is any difference/progress, I will report back in the comments

_______________________________________________________

# BITCRUSH BUG

after a few hours of using the laptop, and i think especially after waking up from sleep that it starts to randomly happen, the audio from the interface starts to bitcrush / drop sample rate: (beware its loud and horrible lol)


the issue can be temporarily solved by changing the buffer size, or by restarting the 'audiosrv' and 'AudioEndpointBuilder' services - but it will come back until i restart the laptop.

- - -

# DEADLOCK THINGY BUG (Solved atleast on my end)

So i just got my Komplete Audio 6 mk2 and i have this issue where when i load a project in my DAW while i listen to music or play audio from anywhere else out side my DAW - i get tons of dropouts and stutters, seems like the driver is getting overloaded or some sort of a temporary deadlock.

this seem to be fixed after playing around with changing the buffer size or just giving it a minute till it goes back to normal, note that i also have the older komplete audio 6 and this never happened there.

anyway heres a video of me playin music -> opening a project -> dropouts starts -> driver completely 100% overloaded until i change buffer sizes a few times:

notes:

1) the CPU percentage in this specific project normally lays around 80% since its a mastering session - therefore the generally high CPU usage becuase plugins like ozone etc..., but it is not an issue, the issue is only when the CPU is at 100%+ in the beginning, this also happens at normal projects where my cpu usage is lower, it starts at a 100%+ and then goes back to normal

2) once the project is finished loading and cpu goes back to normal - i can normally play audio outside the DAW again, so its a temporary issue happening only when loading a project (btw this also happens for a short period of time when opening a plugin in a session)

  • - - - - -

information on my system:

- Dell XPS 15 7590, Windows 10 Pro 64bit 21H2

- FL Studio 20.9.1

- Updated Komplete Audio 6 Mk2 Firmware from 0.2.2 to 0.2.4 and now to 0.3.6

- Komplete Audio 6 Mk2 Driver Version 4.59.0 and now to 5.22

- OS Sample Rate (every output and input available in Windows settings): 24bit 48Khz

- DAW Sample Rate: 24bit 48Khz

Tagged:

Best Answer

«1

Answers

  • dor.re
    dor.re Member Posts: 5 Newcomer
    Options

    Happy to report that it seems that the 2nd bug mention in my original post (in the 2nd video - Deadlock when loading projects) seem to be gone! good work.

    I hope the 1st bitcrushing is gone as well, will report back on that in a few days if it doesnt happen till then

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,335 mod
    Options

    Hey @dor.re Thanks for bringing it in the new forum. We had fewer and fewer reports on this one. It seems that the latest versions of the driver helped a lot, as well as you and other users :)

  • dor.re
    dor.re Member Posts: 5 Newcomer
    Options

    came back to report the bitcrushing bug is still present :/

    just happened to me after waking the laptop up from sleep mode

  • dor.re
    dor.re Member Posts: 5 Newcomer
    Options

    its coming back and goes away within minutes... and repeats. (running the latest drivers and firmware)

    only a restart solves this (until the next time the computer goes to sleep)

    ⚠ and once again - this is very dangerous and can damage hearing. ⚠

    ⚠ we are musicians for Christ sake and this is nothing to play around with. ⚠

    Quoting users from the previous thread on the old forums:

    1) "Yep, I am sick of waiting....stop playing around and get something done, nearly 2yrs

    of my unit sitting in it's box unusable." -Rocky_Racoon

    2) "I'm returning my unit and getting something from a different company" -Yedya

    3) "I'm having the exact same issue as OP dor.re is. In all cases, this has been happening to me outside of any DAW, during normal computer use like watching a stream or something" -River of Graves

    4) "I have the same Issue!!! it's driving me crazy. [...] it's been months and still don't have the solution???? I want my money back I cant affort a new audio device" -Emmanuel Lopez

    5) "CRACKLING / DISTORTION / BITCRUSHING with Audio 6 MK2(Same issue here)same problem!!!! why???????:(Please Help Me" -sadegh

    6) "I also have Komplete 6 MK I and no issues at all with the same HP laptop... I regret I decided to upgrade to MK II." -Arthur_j1

    7) "I have the exact same issue and it is incredibly frustrating, support please help us with this, I cant do audio production if the audio gets messed up and distorted every few minutes!!!!" -Jahbadger

    8) "I purchased my Komplete Audio 6 mkII two weeks ago. The exact same crackling issue started appearing a few days ago and happens several times a day now. I am thinking of sending it back to my supplier for refund. I cannot afford a to work with an unstable audio interface !" -Syd0w

    These (and more..) are real people who spent real money with Native Instruments and have just been screwed over because Native Instruments, well... simply don't care.

    It's been around 3+ years. there is no excuse for not fixing this.

  • dor.re
    dor.re Member Posts: 5 Newcomer
    Options

    While were on this thread - I do want to point out Ive been reached out by the kind Jeremy from support and was offered a compensation a while ago.

    The guys from support have been great to talk to - but whoever is behind developing the driver did not solved the issue yet

  • Kubrak
    Kubrak Member Posts: 2,841 Expert
    Options

    And what about to set the computer so that it does not go to sleep?

    Also, it never has happened to me on Win7 using ASIO driver and with KA2 MK2 audiointerface.

  • DannyPMusic
    DannyPMusic Member Posts: 1 Newcomer
    edited September 2022
    Options

    I'm having this exact same issue, I have to keep the NI Komplete Audio Control Panel open all the time and when I get the audio issues, I change the buffer settings and it clears for a while and then comes back. This happens even when watching films on netflix through the laptop or listening to music via spotify.


    I did a clean install, setup the hardware first and then tested and nothing changed even with the latest drivers installed.


    Has there been any more news about the issue and if NI will be trying to update the drivers or replicate the issue.


    My current setup is as follows.


    OS: Windows 11 Pro 64bit

    CPU: Intel Core i9-11900H

    RAM: 32GB

    NI Hardware: Komplete 6 Audio MK2.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,335 mod
    Options

    @DannyPMusic This issue is being less common and our support agents managed to fix the issue for most of the affected users. It seems you submitted a request last month but you stopped replying after a while. I'd suggest to contact my colleagues again about it.

  • BartCloni
    BartCloni Member Posts: 4 Member
    Options

    Periodic ear destroying bitcrush sound issue still exists for me on Windows 11 with Komplete Audio 6 MKII. Nothing helps permanently and I've been trying to fix it for a week. Time to buy another interface and never look back.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,335 mod
    Options

    @BartCloni Have you checked all the steps in this article? KOMPLETE AUDIO 1 / 2 / 6 MK2 Audio Issues (Windows)

    If that didn't work out let us know and we'll forward your case to our specialists, in the vast majority of cases they were able to fix it.

  • Slack
    Slack Member Posts: 1 Member
    edited February 2023
    Options

    Still happening to me too, my KA6 mk2 is doing the bitcrushing sound all the time. I got this one for live use and it's never going near a stage (or being used for that matter - it's a paper weight now) Pretty pissed to have wasted that money.


    I don't think I'll be trusting NI stuff again after it blew my ears out.


    Yes, I've tried the steps in the article.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,335 mod
    Options

    Hey @Slack I see you have contacted our support, one of our specialists will take care of you shortly.

  • Sebastiaan
    Sebastiaan Member Posts: 1 Newcomer
    Options

    I have exactly this problem, it's driving me nuts. Pretty sure I will return it if this keeps happening.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,335 mod
    Options

    @Sebastiaan THese issues were fixed by firmware updates, please check this article: KOMPLETE AUDIO 1 / 2 / 6 MK2 Audio Issues (Windows)

    In case that does not help, please get in touch here: http://bit.ly/NIsupport_audio

  • rikyedo
    rikyedo Member Posts: 1 Newcomer
    Options

    i have the same problem

    i have a bitcrush sound every 5/10 minutes and i tried every problem solving are you guys giving but i still can't resolve it (windows 11 16GB RAM intelcore i5 11th gen)

Back To Top