Komplete Audio Mk2 Driver Issue (Bug: KH1097-254)

Options
2»

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,705 mod
    Options

    @rikyedo Then please contact my colleagues with the link I provided up there.

  • DaveBell
    DaveBell Member Posts: 2 Newcomer
    Options

    Komplete Audio 6 Mk 2

    Got the same issue. Got a new computer Windows 11 and now get terrible distortion on all applications - Reason, Teams, Spotify etc.

    Have uploaded and installed latest drivers I think.

    So frustrating.

    Hope you can help or it's in the bin and bad marks for NI

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,705 mod
    Answer ✓
    Options

    @DaveBell This bug was fixed a while back. Have you tried the steps proposed several times in this thread?

    KOMPLETE AUDIO 1 / 2 / 6 MK2 Audio Issues (Windows)

    If you have and still have this issue you'll also find a link to our support: https://bit.ly/NI_support_other

  • DaveBell
    DaveBell Member Posts: 2 Newcomer
    Options

    Unfortunately I've been through the steps in both of those articles with no success on Windows programs such as Teams, Zoom and Spotify or my DAW. I'm using Reason 7 as my DAW.

    My DAW settings are;

    Sample rate 44100

    Buffer 512 - I've tried it with all of the other buffer sizes.

    Asio Komplete Audio Asio Driver. I'm assuming this is the latest Asio driver which I downloaded from the NI site. Date on it was September 21 for Windows 10! I'm on Windows 11

    Haven't got much hair but I'm pulling out what's left :)

    Dave

  • BartCloni
    BartCloni Member Posts: 4 Member
    edited February 5
    Options

    I've been struggling with this issue for a year now, and I've come back to report something:

    I decided to do a full clean Windows 11 reinstall. The interface then started worked perfectly fine for game and Youtube audio. This was a very blissful experience, having my audio go through the interface and not distort hard every 3 minutes. It didn't work for DAWs or Spotify yet though, so I installed ASIO4ALL so I could use the interface just fine in DAWs (as far as I could tell). Now, an important thing to note is, when I looked at the interface's driver/device in Device Manager under "Sound, video and game controllers", it showed that its version was 10.0.-something. Seems like it was the first driver that came with the interface, maybe?

    So, today, because Spotify still refused to play anything (which is the fault of spotify itself, but I know that downloading the full NI interface drivers fixes this), I installed the latest NI Komplete Audio 6 MK2 v5.22.0 drivers. And behold, The bitcrushing bug is back. Spotify works, but now the interface returned to all that was wrong before. That tells me that there's something wrong with how the driver works with my computer. What is the update adjusting to suddenly make the interface not work right with my computer? Why do other drivers work completely fine, minus the spotify stuff?

    The main question I have now though, because it seems an older driver of the KA6 MK2 did work partly, is there maybe a way that we can download old drivers of the KA6 MK2? If one or multiple of the old drivers works and they were made accessible to us, I'd be very happy as customer 😀

  • BartCloni
    BartCloni Member Posts: 4 Member
    edited February 5
    Options

    Update: Messing around more, I managed to get the old driver back. I deleted all the programs and files in the folder where the v5.22.0 driver setup .exe installed its files, and more importantly I uninstalled everything I could find of the Komplete Audio 6 MK2 in Device Manager, with "Show hidden devices" ON in the View menu, then plugged it back in, repeating this with minor variations until it automatically reinstalls "Komplete Audio 6 MK2 Audio" under "Sound, video and game controllers".

    Now the interface works perfectly fine, though I'm back to the minor spotify issue thing.

    This old driver version BTW that's working for me right now is actually 10.0.22621.1 in case anyone wants to know.

    For my spotify issue I'm now just resorting to the spotify web player, and am using ASIO4ALL to be able to access the in and outputs of the device in the DAW.

    I finally fixed it after a year. And the fix was to avoid the latest interface drivers. I hope this helps people.

  • John Curry
    John Curry Member Posts: 9 Member
    Options

    audio interface driver on the MK3 controller has a bug that causes BSOD for SOME windows users when turning the device OFF.

    not only can NI products potentially damage your ears, but also break your computer!

    Good old NI.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,705 mod
    Options

    @John Curry Do you mean Maschine MK3? What bug do you mean, do you have a bug number or did you do a bug report?

  • BartCloni
    BartCloni Member Posts: 4 Member
    Options

    Update 2 to my previous posts: So.. my "fix" that I posted about here on the 5th of February unfortunately was just a band aid solution. The crackling/bitcrush issue was solved, but in turn, a lot of applications using audio just didn't work correctly or at all, like Spotify, games and more. my DAW also still seemed to have problems, using the NI interface with ASIO4ALL, like latency and extreme crackles when projects get bigger even though my CPU could easily handle it before. So I just got the Scarlett Solo 4th gen and it seems to be doing perfectly well.

  • LEE DS
    LEE DS Member Posts: 1 Newcomer
    Options

    I had same problem. But I fixed it.
    Just delete KA6 driver with ashampoo uninstaller.
    No more bit crushing sounds

Back To Top