Traktor wont open at all on new laptop

I have the Z2 with traktor 2 installed on my old laptop but upgraded to a new laptop put in for a licence transfer so i can download and install on my new laptop.

Everything i had on my old laptop has been downloaded via the access app but when i try to open traktor nothing happens.

no pop up windows indicating an issue, I even ran as administrator the same i have no clue what's went wrong can anyone help?

Best Answers

  • Markovicz
    Markovicz Customer Care Posts: 381 mod
    Answer ✓

    Hi there,

    the error descriptions suggest that you are running quite recent Windows computers with intel Ice Lake, Tiger lake or Alder lake CPUs.

    These CPUs prevent Traktor Pro 2 versions between 2.7 and 2.11.3 to start.

    It's not clear what exactly is causing this problem - specification-wise it should work as these processors easily fulfill Traktor 2´s requirements.

    There are two ways to fix this problem: either to downgrade your Traktor Pro 2 to the version 2.6.6 or purchase an update to Traktor Pro 3.

    You can download an installer for Traktor Pro 2.6.8 HERE (which is the latest Pro 2 version that is not affected by the phenomenon). There is no need to remove your current Pro 2 installation beforehand.

     Alternatively, you can upgrade to Traktor Pro 3 via the following link

    https://www.native-instruments.com/en/products/traktor/dj-software/traktor-pro-3/pricing/

  • Markovicz
    Markovicz Customer Care Posts: 381 mod
    Answer ✓

    Thanks for the extensive reply! Please check your email inbox :)

  • Markovicz
    Markovicz Customer Care Posts: 381 mod
    Answer ✓

    @Tigermafia1210

    Have you tried running 2.6.8?

    BTW the license agreement (EULA) a user has to accept before installing Traktor allows the use on two separate machines.

  • lord-carlos
    lord-carlos Member Posts: 2,016 Expert
    Answer ✓

    If you can't start Traktor 2 on a modern intel CPU (listed above) try installing Traktor Pro 2.6.8.

    You could also upgrade to 3. I think it's only 25 EUR currently. Will probably end tomorrow. Then it's back up to 50 EUR for the upgrade.

«1

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 3,972 Expert
    edited May 2023

    Same exact thing is happening to me on my Surface

    When I will figure it out, I’ll tell you.

    In the meanwhile, a couple of things about your case: you didn’t have to ask for a license transfer: Native Access on your new laptop would know your registered softwares (when it works…)

    You can install your softwares on more than one device

  • LostInFoundation
    LostInFoundation Member Posts: 3,972 Expert

    First test: I tried to uninstall it and reinstall it. No luck, nothing changed.

    (just to know if you have my same version: are you on Traktor Scratch pro 2 2.11.3?)

  • LostInFoundation
    LostInFoundation Member Posts: 3,972 Expert

    Another clue: trying to open it a first time with double click on the icon (without success) and then a second time with right click - open as administrator gave me this message: Culd not initialize Traktor. another instance is probably running

    But no instance was running (the icon on the bottom bar just appeared and disappeared with the message)

  • Markovicz
    Markovicz Customer Care Posts: 381 mod
    Answer ✓

    Hi there,

    the error descriptions suggest that you are running quite recent Windows computers with intel Ice Lake, Tiger lake or Alder lake CPUs.

    These CPUs prevent Traktor Pro 2 versions between 2.7 and 2.11.3 to start.

    It's not clear what exactly is causing this problem - specification-wise it should work as these processors easily fulfill Traktor 2´s requirements.

    There are two ways to fix this problem: either to downgrade your Traktor Pro 2 to the version 2.6.6 or purchase an update to Traktor Pro 3.

    You can download an installer for Traktor Pro 2.6.8 HERE (which is the latest Pro 2 version that is not affected by the phenomenon). There is no need to remove your current Pro 2 installation beforehand.

     Alternatively, you can upgrade to Traktor Pro 3 via the following link

    https://www.native-instruments.com/en/products/traktor/dj-software/traktor-pro-3/pricing/

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,465 Expert

    @Tigermafia1210

    Just a side note: Traktor 2.6.8 (mentioned above) doesn't support dual core nor stems format and includes a backward graphic glitch on the waveforms. But it has been the most stable and fastest version of Traktor that i ever used!

    If it has all the tools you need and supports all the hardware you have, it's a beauty.

  • LostInFoundation
    LostInFoundation Member Posts: 3,972 Expert
    edited May 2023

    I’m not so sure in my case this is the problem. I’m using a Surface pro 8 which is exactly the same computer on which Traktor was working before. I checked and effectively it mounts a Tiger lake processor, but it seems to me to remember that when Traktor was working on the Surface, it was already a version with stems. Unless I’m really wrong and I mix up what I remember with my studio computer (which is even older than the surface but makes newer Traktor versions work…).

    I will try to install also the first version that contained Stems (can you confirm that it was 2.9?) which I can find here https://www.native-instruments.com/en/support/downloads/update-manager/?q=Traktor&t=updates

    Going back to 2.6.8 will also remove things like Freeze/Slicer mode, Ableton Link, step sequencer for Remix Decks,… And the aforementioned Stems. Quite not ideal to lose all these functionalities. Specially for someone like me who bought 2 D2 controllers to use these functionalities (NI already discontinued them little after introducing them and taking the (not small) amount of money people like me spent to buy them…)

    Question: since NI seems conscious of the problematic with these processors (that are mounted on official MS computers, therefore not so rare) from so long (you said it affects all version from 2.7 to 2.11.3… Ever thought of fixing the problem? It is not like a small problem for very rare and not used processors. It prevents Traktor to being able to start AT ALL. And therefore to use it.

    This is something I don’t understand about NI. Such a serious problem and instead of fixing it they continue to build on top of it, moving from 2.7 to 2.11.3. I checked and there has been 14 updates from 2.7 (which was released 27.10.2014. 9 years ago…not enough developer time (as someone in NI call it) to fix it?). And they are not interested in fixing this issue? Just moving on for 14 updates and 9 years ignoring it and all these users? That’s not a very professional (nor honest) behavior.

    And not even mentioning it in the release infos is the icing on top of the cake.

    Yes…I know now it’s 9 years later and someone could say “in the software world you can’t pretend a software version from 9 years ago still works”. But they knew this problem when it appeared and the version was brand new as the computers it affected…they just chose to ignore it…

    Sorry…but sometimes NI just seems to not care about users. And, even worst than this, willing to show them they don’t care. Like “We do what we want and we throw it at your face, in any case you can’t do annything about it”. This is exactly why I didn’t buy the update to Traktor 3: if you cripple the products I already bought from you and you don’t even care, difficult for me to trust you and buy a new one.

    Waiting for an official statement about the intention to fix this problem (or not)

  • Markovicz
    Markovicz Customer Care Posts: 381 mod

    The issue first appeared when Pro 2 had already been replaced and taken off the market - and as a company policy, there are no updates for discontinued products.

    BTW I have checked your NI User Account and haven't found the D2s you are referring to. Is it possible they were registered under another email address? If so, PM please.

  • LostInFoundation
    LostInFoundation Member Posts: 3,972 Expert
    edited May 2023

    No…they simply are not registered. Since they didn’t give me any software I didn’t already own, I didn’t register them.

    But since you need to confirm that I was saying the truth, here is a proof I own them:

    And if in future you’ll need it, here is another one about some other NI gears I own:

    Do you need a photo also for the hardwares from other companies?

    Sorry, but since eight years have passed, I don’t have my receipt anymore to prove you also that I bought them on release

    BTW…out of curiosity: is it normal procedure for Customer CARE to go in users accounts when it’s not needed?

  • Markovicz
    Markovicz Customer Care Posts: 381 mod
    Answer ✓

    Thanks for the extensive reply! Please check your email inbox :)

  • LostInFoundation
    LostInFoundation Member Posts: 3,972 Expert

    😶

    Thank you for the alternative solution you provided me (even if I wasn’t asking for it).

    The problem is this isn’t solving the issue for the other users

  • Markovicz
    Markovicz Customer Care Posts: 381 mod

    It's a specific approach for a certain group of users, I presume you get the point.

  • Tigermafia1210
    Tigermafia1210 Member Posts: 2 Newcomer

    Been told to do various different things ill try each one till i get something moving forward thank for the replies everyone i will let everyone know if i get it running on my new laptop.

    seen a comment also stating i can install on more than one machine never know that, i would think that would flag up some where.

  • Markovicz
    Markovicz Customer Care Posts: 381 mod
    Answer ✓

    @Tigermafia1210

    Have you tried running 2.6.8?

    BTW the license agreement (EULA) a user has to accept before installing Traktor allows the use on two separate machines.

  • Tesno
    Tesno Member Posts: 2 Newcomer

    can you maybe tell more about this alternative? also feel a bit suspicious of this problem and been trying just to get same setup working on new computer as on my old laptop, but just don't have the visibility what's a bug and what's a known issue.

  • lord-carlos
    lord-carlos Member Posts: 2,016 Expert
    Answer ✓

    If you can't start Traktor 2 on a modern intel CPU (listed above) try installing Traktor Pro 2.6.8.

    You could also upgrade to 3. I think it's only 25 EUR currently. Will probably end tomorrow. Then it's back up to 50 EUR for the upgrade.

Back To Top