Is there any way to disable light guide on KK S88 MK2?

IvoryKeys88
IvoryKeys88 Member Posts: 21 Sine
edited August 28 in Komplete Kontrol

Hi folks,

I've read numerous threads on the old forums about this very question. Those discussions were from 2 or more years ago.

So came very close to programatically turning the light guides on and off. The closest I came to finding a working solution (also from over 2 years ago) was an app called qKontrol (https://github.com/GoaSkin/qKontrol) created by NI user @GoaSkin. Unfortunately I wasn't able to get it to detect my keyboard.

Another couple of years has gone by since the earlier discussions on this topic. Does anyone know of options for disabling the guide lights, on a an S88 MK2, via a macOS (M1 / Silicon) computer?

I'm astounded N.I. haven't bothered to release an update that allows for this. Surely it would be a relatively minor task to enable this feature on the MK2? If someone at N.I. reads this, can you chime in and indicate whether there's any plans to? Like many other users of the S88 MK2, I find the lights overkill when simply playing piano, especially late at night.

Thanks very much ...

Jonathan

Tagged:

Best Answer

  • JesterMgee
    JesterMgee AustraliaMember Posts: 838 Saw
    Answer ✓

    On the macOS version of Komplete Control (SW) there is no Hardware tab in the preferences. It's kompletely absent.

    It only shows when you have an MK1 keyboard attached (or no keyboard). For whatever insane reason, as you mentioned the devs decided it's not something people want or need so it is removed on all MK2 versions. Some may say it's so it eventually burns out an LED forcing you to have to buy a new keyboard but that's probably being a little cynical.

    Here is one option for those windows users looking for a workaround.

    Neat, tho that solution only works when using a Kontat instrument and not when using any other VST instrument, will always show whatever the instrument has been set to display or just that endless sea blue we love so much.

    Still puzzled why this much requested option is STILL not even in consideration.

Answers

  • Brad Yost
    Brad Yost Anacortes, WA, USA Member Posts: 218 Saw
    edited August 28

    The best you can do at this point is to disable the light guide in Komplete Kontrol SAL <Preferences><Hardware>, which only seems to work when in SAL mode. Even with that disabled, the LG is still active in a DAW.

    If the screens on the keyboard are also a bother, set <Navigate><Browse Mode> to "On-Screen Overlay", go into Setup, and reduce brightness of the on-board displays.

    Along with the Fatar keybed, the light guide was one of the premium features of the S-Series.

    There is always the "long piece of black electrical tape" option.

  • IvoryKeys88
    IvoryKeys88 Member Posts: 21 Sine

    Thanks Brad,

    I appreciate your input. I read other folk resorting to taping over the light guide. It's not an option for me, as I actually like it a fair amount of the time (when I am actually making use of it), and taking tape on and off would be more of a nuisance than the lights. When buying the keyboard I just assumed there would be a way to turn the lights on and off ... It never occurred to me that something so basic would be over-looked by the developers (and since they had that feature in MK1, it seems it was intentionally removed or at least consciously omitted, as opposed to overlooked). So much for our Kontrol being Komplete!

    That's enough ranting though.

    On the macOS version of Komplete Control (SW) there is no Hardware tab in the preferences. It's kompletely absent.

    I shall continue praying for a macOS compatible script for disabling it.

    Cheers ... J

  • MyStudioOne
    MyStudioOne Member Posts: 47 Tri
    edited October 13

    Here is one option for those windows users looking for a workaround.

  • JesterMgee
    JesterMgee AustraliaMember Posts: 838 Saw
    Answer ✓

    On the macOS version of Komplete Control (SW) there is no Hardware tab in the preferences. It's kompletely absent.

    It only shows when you have an MK1 keyboard attached (or no keyboard). For whatever insane reason, as you mentioned the devs decided it's not something people want or need so it is removed on all MK2 versions. Some may say it's so it eventually burns out an LED forcing you to have to buy a new keyboard but that's probably being a little cynical.

    Here is one option for those windows users looking for a workaround.

    Neat, tho that solution only works when using a Kontat instrument and not when using any other VST instrument, will always show whatever the instrument has been set to display or just that endless sea blue we love so much.

    Still puzzled why this much requested option is STILL not even in consideration.

  • Fread
    Fread Member Posts: 8 Sine

    We need this.

Back To Top