Is there any way to disable light guide on KK S88 MK2?

Options
IvoryKeys88
IvoryKeys88 Member Posts: 26 Member
edited August 2022 in Komplete Kontrol

Hi folks,

I've read numerous threads on the old forums about this very question. Those discussions were from 2 or more years ago.

So came very close to programatically turning the light guides on and off. The closest I came to finding a working solution (also from over 2 years ago) was an app called qKontrol (https://github.com/GoaSkin/qKontrol) created by NI user @GoaSkin. Unfortunately I wasn't able to get it to detect my keyboard.

Another couple of years has gone by since the earlier discussions on this topic. Does anyone know of options for disabling the guide lights, on a an S88 MK2, via a macOS (M1 / Silicon) computer?

I'm astounded N.I. haven't bothered to release an update that allows for this. Surely it would be a relatively minor task to enable this feature on the MK2? If someone at N.I. reads this, can you chime in and indicate whether there's any plans to? Like many other users of the S88 MK2, I find the lights overkill when simply playing piano, especially late at night.

Thanks very much ...

Jonathan

Tagged:

Best Answers

  • Brad Yost
    Brad Yost Member Posts: 351 Pro
    edited August 2022 Answer ✓
    Options

    The best you can do at this point is to disable the light guide in Komplete Kontrol SAL <Preferences><Hardware>, which only seems to work when in SAL mode. Even with that disabled, the LG is still active in a DAW.

    If the screens on the keyboard are also a bother, set <Navigate><Browse Mode> to "On-Screen Overlay", go into Setup, and reduce brightness of the on-board displays.

    Along with the Fatar keybed, the light guide was one of the premium features of the S-Series.

    There is always the "long piece of black electrical tape" option.

  • JesterMgee
    JesterMgee Member Posts: 2,678 Expert
    Answer ✓
    Options

    On the macOS version of Komplete Control (SW) there is no Hardware tab in the preferences. It's kompletely absent.

    It only shows when you have an MK1 keyboard attached (or no keyboard). For whatever insane reason, as you mentioned the devs decided it's not something people want or need so it is removed on all MK2 versions. Some may say it's so it eventually burns out an LED forcing you to have to buy a new keyboard but that's probably being a little cynical.

    Here is one option for those windows users looking for a workaround.

    Neat, tho that solution only works when using a Kontat instrument and not when using any other VST instrument, will always show whatever the instrument has been set to display or just that endless sea blue we love so much.

    Still puzzled why this much requested option is STILL not even in consideration.

Answers

  • Brad Yost
    Brad Yost Member Posts: 351 Pro
    edited August 2022 Answer ✓
    Options

    The best you can do at this point is to disable the light guide in Komplete Kontrol SAL <Preferences><Hardware>, which only seems to work when in SAL mode. Even with that disabled, the LG is still active in a DAW.

    If the screens on the keyboard are also a bother, set <Navigate><Browse Mode> to "On-Screen Overlay", go into Setup, and reduce brightness of the on-board displays.

    Along with the Fatar keybed, the light guide was one of the premium features of the S-Series.

    There is always the "long piece of black electrical tape" option.

  • IvoryKeys88
    IvoryKeys88 Member Posts: 26 Member
    Options

    Thanks Brad,

    I appreciate your input. I read other folk resorting to taping over the light guide. It's not an option for me, as I actually like it a fair amount of the time (when I am actually making use of it), and taking tape on and off would be more of a nuisance than the lights. When buying the keyboard I just assumed there would be a way to turn the lights on and off ... It never occurred to me that something so basic would be over-looked by the developers (and since they had that feature in MK1, it seems it was intentionally removed or at least consciously omitted, as opposed to overlooked). So much for our Kontrol being Komplete!

    That's enough ranting though.

    On the macOS version of Komplete Control (SW) there is no Hardware tab in the preferences. It's kompletely absent.

    I shall continue praying for a macOS compatible script for disabling it.

    Cheers ... J

  • MyStudioOne
    MyStudioOne Member Posts: 263 Pro
    edited October 2022
    Options

    Here is one option for those windows users looking for a workaround.

  • JesterMgee
    JesterMgee Member Posts: 2,678 Expert
    Answer ✓
    Options

    On the macOS version of Komplete Control (SW) there is no Hardware tab in the preferences. It's kompletely absent.

    It only shows when you have an MK1 keyboard attached (or no keyboard). For whatever insane reason, as you mentioned the devs decided it's not something people want or need so it is removed on all MK2 versions. Some may say it's so it eventually burns out an LED forcing you to have to buy a new keyboard but that's probably being a little cynical.

    Here is one option for those windows users looking for a workaround.

    Neat, tho that solution only works when using a Kontat instrument and not when using any other VST instrument, will always show whatever the instrument has been set to display or just that endless sea blue we love so much.

    Still puzzled why this much requested option is STILL not even in consideration.

  • Fread
    Fread Member Posts: 9 Member
    Options

    We need this.

  • etudes
    etudes Member Posts: 25 Member
    Options

    +1 here. It's absolutely infuriating and distracting to have 88 gaudy LED's shining in your face 24/7.

    The NI dev team kind of seem like ****** to me, given the fact that 4+ years have now gone by with people asking for this extremely simple option, with not so much as an acknowledgement.

  • etudes
    etudes Member Posts: 25 Member
    Options

    +1 here. It's absolutely infuriating and distracting to have 88 gaudy LED's shining in your face 24/7.

    4+ years have now gone by with people asking for this extremely simple option, with not so much as an acknowledgement. That is Native Instruments for you.

  • Simchris
    Simchris Member Posts: 294 Pro
    Options

    Yep. They advertise and sell a product which does exactly what is was designed for.

  • IvoryKeys88
    IvoryKeys88 Member Posts: 26 Member
    edited March 2023
    Options

    I'm curious... Did making a facetious remark fulfill a particular need of yours? I can say for certain it didn't help answer my original post, and I am pretty sure it didn't help 'etudes' in his/her frustration on that matter.

    I assume (perhaps wrongly?) that you frequent these forums in order to be helpful and or to receive help. It's unclear to me how your remark achieves either outcome. Hence my curiosity.

  • nelligan tetrault
    nelligan tetrault Member Posts: 31 Member
    Options
  • MartinK64
    MartinK64 Member Posts: 3 Newcomer
    Options

    Hi,

    I found a solution which works for me, when using my favorite vst - Pianoteq. Since piano has use of all the keys and light guide would be just a distraction, I created a totally empty instrument in Kontakt. There is not a single character or line in the script. That just does not initialize the light guide at all. I load up Pianoteq in Gig Performer 3 with my favorite preset and connect midi to VST and than to output (komplete audio 2) through the interface. Alongside, I also open Kontakt with my empty instrument (name it what you want) and do not bother with any connections.

    And there you have it. LEDs on s88 stay off.

    But as others mentioned, I also bought s88 for the light guide, for vsts with limited range and key switches. It would be really nice if there was a simple button to be able to turn LEDs off though. On the other hand, when playing just a piano, Roland FP-10 has - in my opinion of amateur - nicer key action and sound is amazing….

    Hope this helps a bit…

    🙂

  • MartinK64
    MartinK64 Member Posts: 3 Newcomer
    Options

    Correction, you need to open the empty instrument in komplete kontrol, not kontakt, for lights off to function…

Back To Top