Komplete Kontrol Scan hangs up

echopark Member Posts: 1 Newcomer
edited December 2022 in Komplete Kontrol

Hello, after the last update of Komplete Kontrol nothing works for me. When I start Komplete Kontrol, the scan hangs on various plugins like Halion Symphonic Orchestra, SpectraLayers, True Iron, etc.

Is it possible to skip these plugins with a command ?

Since I couldn't do a full scan yet, I can't use the Komplete Kontrol plugin at the moment.


  • JesterMgee
    JesterMgee Member Posts: 2,474 Expert

    Try press ESC

    If you are on Windows you can open task manager then kill the scanapp process if its stuck. On mac I think you can do the same.

  • Harpya
    Harpya Member Posts: 1 Member
    edited December 2022

    I have the same problem, mostly, but not exclusively, with iZotope plugins. Killing the task and restarting will eventually get you trough. But it can take ages, depending on the number of your plugins.

    It seems to be mostly the VST2 variations of plugins, so you should try excluding that folder from the scan. However, I also have it hang with VST3 plugins at times, like Wave's Waveshell for example. I have no idea why.

    Since this has been a frequent problem for years, could we expect a fix for that any time soon, please, NI?


    With the latest KK version, I can also no longer overcome it getting stuck. When I kill the task, it gets stuck with something else, rinse and repeat. It is mostly the same 4-5 plugins that take turns in going through and getting stuck, depending who's turn it is.

    Only workaround: in Windows task manager there are two tasks. One is the scanning task. You can kill that seperately, and then KK will open so you can review paths. Good luck!

    And, PLEASE fix it, NI!

  • scarsnyc
    scarsnyc Member Posts: 1 Member

    Same thing here - since upgrade to Komplete 14 Collector - When using KK as a plugin, the scan stopped all the time and freeze the DAW and tghe scan process at Replika (NI Effect).

    Mac M1 Max Processor

  • Gordon
    Gordon Member Posts: 1 Newcomer

    Please can we get some support for this problem.

  • JesterMgee
    JesterMgee Member Posts: 2,474 Expert

    People need to post their OS and what it gets hung up on for a start.

    I have over 400 plugins and have had the scanner get stuck 1 time in guitar rig 6 but killing the scan process in task manager forces it to the next and it’s fine.

    if it’s an issue on every plug-in it’s likely some other issue, not sure you will get the required help here, would need to open a ticket

  • Lalo
    Lalo Member Posts: 3 Newcomer

    Im completely stuck guys, I cant get Maschine or Komplete Kontrol to finish scanning my plugins. Mainly it seems to get stuck with the Arturia plugins.

  • JesterMgee
    JesterMgee Member Posts: 2,474 Expert

    And since you set your profile private (so we cannot see what your system specs are... if you filled them in to begin with) would you be helpful and post at least if you are using a mac or PC?

  • Lonely Player
    Lonely Player Member Posts: 1 Newcomer
    edited October 2023

    it´s the same for me. Komplete Kontrol freezes while scanning "Halion Sonic SE".

    i have a Intel Core i9-9820X CPU @ 3.30GHz, whith 128MB RAM, running Windows 10 and Cubase 12

  • BIF
    BIF Member Posts: 443 Pro

    Heads' up, folks. Sometimes a "stuck scan" is being paused by a hidden modal window, possibly with a prompt that you need to answer...by pressing a button such as "ok", "skip", or "continue" or something similar.

    If you're getting snagged by a lot of stuck scans, try poking around and see if you can find the hidden dialog window.

    Power Tip: If your environment has high-resolution monitors, the dialog boxes are going to be absolutely teensy-tiny and you might miss them off in a corner or slightly overlapping the KK Software dialog box, or possibly overlaid by that dialog box.

    It's rare that I actually need to get into task manager and kill a scan. Find the root cause first. Hunt that little squirrel down!

  • keefycal
    keefycal Member Posts: 22 Member

    Hi NI Forum

    Regretfully, I have the same issue. Using a Windows 11 & Cubase Pro set up, the scanning process has always worked OK until now - and although I haven't moved any of my sample sets. since installing the updated Komplete Kontrol, the system now hangs on Halion Sonic SE.

    Using Task Manager to 'end' the process simply does that - rendering the KK unavailable to use. I tried rolling KK back to V.1, but the scanning still hangs as before. Also, there are no partially hidden screens that require a click to proceed. That would be too easy?

    How do professional film composers have time to hunt little squirrels?

    Any ideas gratefully received.


  • keefycal
    keefycal Member Posts: 22 Member

    As a follow up to my initial submission, I note that the screen that hangs as it scans (in standalone mode) through the sample sets, shows 'HALion Sonic SE' as 'Halion Sonic SE'. I wonder if this is why it stops scanning at this point. At no time is this programme spelt without the capital HAL at the start - maybe it just doesn't recognise the name?

    I am no expert, but after another 5 hours wasted trying to resolve this particular issue (and failing once again), I'm clinging at straws.


    See att screen shot.

  • niCKed
    niCKed Member Posts: 5 Member
    edited November 2023

    Solved this by killing the Scanning in task manager which eventually opens up Komplete Kontrol in standalone mode. Went to preferences and removed any folders on the X86 drive. Seems to work ok after this!

    OK. I take it back. It doesn't work. I'll try reinstalling. So annoying!

  • keefycal
    keefycal Member Posts: 22 Member

    Many thanks for your response. I eventually solved it my uninstalling the latest KK and reinstalling the last one again (V.2.9.6). I think it had something to do with the latest version not being compatible with VST2.

    Cheers Keith

  • GRVE
    GRVE Member Posts: 1 Newcomer

    I know im late to the game. The only progress I made was by ending the task "WavesLocalServer" over and over until it finally completed the scan. It is now scanning the library to add my instruments to the library. Fingers crossed.

Back To Top