Maschine 2:14:7 (R1) Software knob value unusable glitched

sparra Member Posts: 5 Newcomer
edited December 2022 in Maschine

I use a Mikro & a 2 macs, I use a posh Kensington Slimblade Trackball instead of a mouse for space & better health for my wrist. I am still using Mojave 10:14:6 on the editing setup & the studio runs on similar for compatibility & hardware reasons. Both are still fine with most software updates so no issues there.

The main issue i experience has absolutely nothing to do with Waves plug-ins or any plug-ins. It is to do with the basic fundamental need of changing values of knobs, If i use the trackball its unusable, jumps all over the place & i don't have the option to type the value required. For tune this is unbearable, Same with ADSR, Jumps all over the place again, Aux values, indeed no control or ability to type a value. I know holding shift goes into it in the smallest increments but you can even be doing that & it will suddenly jump to maximum value.

Waited for updates to see if it resolved, Nope.

It makes the software unusable for me, I see no preference to change knob to mouse movement ratio there is no special driver for the trackball on the mac, The mouse prefs run it just like a mouse, Everything else integrates with the trackball with no issues so i can only assume the NI programmers overlooked something here or it's a hardware thing with the NI Mikro controller lacking dedicated knobs to access true functionality. The fact that it's the same response on 2 different Apple setups that have never shown any similar issues with numerous pieces of software from numerous companies makes me think that it's all about the hardware controller, I have the Mikro as i don't need anything bigger than pads & maybe the odd button like repeat or erase, It has no assignable knobs. I think the larger Maschines have dedicated knobs for Tune, Aux & ADSR hence i can only assume the software works OK for them??

Why can't i just click on these knobs & enter a value from the keyboard?

Can somebody tell me a solution to this other than buy the bigger controller with dedicated knobs?

Thanks in advance!



  • D-One
    D-One Moderator Posts: 1,814 mod
    edited December 2022

    That's very odd, a trackball mouse is the same as any other, it just uses a laser pointed at a ball instead of a desk/mousepad, surely there's more users with that type of mouse but yours is the 1st report of this I've seen.

    Do you have another mouse around just to check it works? Do you have any window management app like Magnet or something? Those can interfere with the mouse in Maschine for some reason.

    Mouse & keyboard improvements in Maschine are something that simply does not happen, at the top of my head I can think of:

    • Shortening adjacent notes have been broken for 3 years or so... unusable.
    • Trackpad side-scrolling moves 4 pixels at a time when zoomed out, unusable.
    • The mouse wheel moves some knobs up and others down, confusing.
    • The mouse wheel also takes 4 clicks to move by a factor of 1, annoying.

    Why can't i just click on these knobs & enter a value from the keyboard?

    I'd say it's because this kind of thing is a super low priority for them if it's even on the to-do list at all. Lots of users scream: "Do not focus on mouse features, the good thing about MAS is the tactile control and HW, bla, bla" but those people forget that there are Mikro users out there and the SW has a ton of keyboard/mouse issues... 🤷‍♂️

    Go fill in the survey and prioritize mouse workflow, but ultimately you will be one of the few prioritizing such a thing, unfortunately.

    or it's a hardware thing with the NI Mikro controller lacking dedicated knobs to access true functionality.

    No, knobs should work fine even if no controller is attached to the computer.

    I think the larger Maschines have dedicated knobs for Tune, Aux & ADSR hence i can only assume the software works OK for them??

    Yes, the 8 parameter Knobs automatically control whatever is in focus on Maschine.

    You can also control those things with the Mikro's single knob, it just requires a bit of navigation (at least you can on a Mikro MK3, pretty sure the MK2 can also). Personally, the navigation throws me off and I'd prefer a mouse too.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod

    @sparra If you use a regular mouse, is the behaviour the same or not ?

    You mention Waves, yes, it is a known issue. Do you have Waves plugins installed on your computer or not ? Did you ever have Waves plug-ins version 12 or less installed on your systems?

  • sparra
    sparra Member Posts: 5 Newcomer

    Hello, No Waves plugins, Not that that should effect the movement of a knob, I use UA, Soundtoys & Plugin Alliance with no issues, I also use the Akai MPC software & hardware with no issue. I know about the Waves issue after searching a solution.

    The mouse is the same, The trackball is just a mouse upside down so shouldn't effect anything & iy doesn't, These knobs do not increment correctly, They don't go up in increments of 1 each movement but skip 2 or 3 or more increments or stick & don't move then jump to max or minimum value, If you are making slight adjustments it's horrific Your original value is gone while trying to tweat slightly.

    As i say these knobs don't allow you to type in the value either, The knobs have dedicated controllers on the more expensive hardware units, I wonder if they have any issues with that scenario, I am just using the Mikro controller & wondering if there is any foul play going on to make me buy the more expensive & desktop hogging, Wouldn't be the 1st time a corporate took the p*ss with a bit of shady code, Not allowing a value to be typed in is suspect, Especially as other knobs have this ability. Call me paranoid but this is basic stuff to be able to turn a knob on the software with a mouse or similar & it to equate to the value required in normal increments...Thanks, Appreciate the feedback

  • sparra
    sparra Member Posts: 5 Newcomer

    Smooth integrated parameter control is one of the most important features of any DAW or instrument, It defines workflow & creativity...

    After much research i have found the reason for the issue....The Maschine software is really buggy, When you google the problem there's a post saying "SOLVED" when it isn't, In the forum people are still saying tried the waves solution without any joy...Waves plug-ins were being used as a scapegoat for the poor coding but numerous users testified that it wasn't a solution in this "SOLVED" forum post.

    I don't really have any similar issues with any plug-in knob movement, VST 3, VST, Audio Unit, All the manufacturers Plugin Alliance, Soundtoys, UAD, I even tried installing a Waves plug in & it's Waveshell, No problems & If i did have issues, I can type a value below the knobs, Easy 😎

    Unfortunately, Maschine since the version 2 update has been really unusable with serious workflow restrictions due to the software being really buggy, Everybody wants to run a track & tweak envelopes, Pitch. Start points etc as we listen, Just like you do running an MPC or similar hardware device, Maschine can't handle that & it gets worse when strain on CPU gets bigger. I'd love to try the dedicated hardware device to see how that performs but thats unattractive with 2 outputs even if it did perform well.

    Maschine is not alone, Akai's MPC software isn't as buggy with control but lacks a lot of workflow related features which make it unattractive to creative people. Their standalone hardware MPC's have individual outputs but can be a bit buggy in use, They overcomplicated the software, The new machines are plasticy & fall apart quickly unlike MPC's of old.

    I have come to the conclusion this software & midi controller thing is a huge deception, You are really buying a sample library & some plug in instruments to play the sounds thru. The sequencer part is a really poor Ableton knock off as an afterthought hence issues like this which are really fundamental requirements that should never be overlooked go unsolved.

    By the time they iron out the bugs they introduce a new version that costs you $99 🤣

    Why can't you type a value into one of Maschine's controller knobs? Surely thats easy we have the knob so why not be able to click & add a value?

    Thanks for the feedback & attempts at a solution but i can't see it coming, I think i'm going to move back to the DAW exclusively & use it as i did before someone recommended this.

    Good luck!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod
    edited December 2022

    @sparra Not scapegoating anyone...this issue has been confirmed by Waves. Anyway, if these similar symptoms appear on your system, even without any Waves plugin installed, my colleagues will be happy to look into the issue, let me know and will create a ticket for you.

  • sparra
    sparra Member Posts: 5 Newcomer

    Jeremy lets not focus on the Waves issue, I have no experience about it, Whether it was the plug-in knobs or the host knobs people where refering to, I don't know so i won't pretend i do. All i know is this Waves issue was given to numerous users as an explanation for the behaviour & once they had completed various procedures it made no difference to them.

    My issue is with the host knobs i.e Maschines control knobs not plug-ins. I can use plug-ins no problem & even type in numerical values below the knobs.

    My Kensington trackball is pro stuff & has an extensive editing app called trackball works, It lets you define virtually every feature, Button click & config, When you turn the ball clockwise or anticlockwise it clicks for every increment like the knob on an expensive piece of analogue studio mastering hardware that requires recall. When i click it once clockwise i expect the knob on Maschine to go to +1.00 another click +2.00 etc etc It doesn't, Even slowing the ball down to it's most basic setting doesn't correct the behaviour, It goes from click 1 +1.00 to click 2 +3.00 then click 3 +7.00 same with anti clockwise except it's -1.00, Then -3.00 2nd click & -7.00 3rd. The higher settings for the trackball make it worse, I had it open in a window with Maschine to check how the setting effected its performance & integration.

    I can hold down shift to increase the .00 in small increments but this is risky as you can get to nearly the value you want & it will jump around.

    The settings jump around more when there is CPU load & the sequence is running which equates to something more than plug in compatibility

    The mouse is the same except no clicks when you increase or decrease, It actually performs poorer than the trackball & gets worse the more CPU strain & when the sequencer runs.

    Both my macs are setup exclusively for audio, The macbook has been running for 10 years & still handles CPU intensive demands with full ram & lightning quick SSDs, I have the 12 core Mac Pro with D700 & full ram in the other room. I am running the last version of Mojave on the Macbook & last version of Catalina on the Mac Pro. Apogee interfaces on both, Duet 2 USB & Symphony Mk1 via 64 Thunderbridge. Cubase Pro 10 on both. Plugins all legit, Most are VST 3 now Soundtoys has been updated.

    Maybe the development & testing by NI is purely Apple silicon & the latest hardware. There's no details.

    I can say it definitely worked no issues before the big update last year?

    I sincerely would like to thank guys like Jeremy for their help 🤩

    [email protected] Member Posts: 1 Newcomer

    I don't know if this is still an issue but the same is happening to me in the maschine micro software and in the Komplete kontrol software with all the various library plugins. It hasn't been too much of an issue until recently when I tried it. Then it became like an itch that you cannot scratch.

    Anyway I thought I would throw my hat in the complaint ring. BTW the Maschine stand alone software works perfectly, so there's that. It's only when I use it as a plug in with Logic that the knob problems show up.

    Looking forward to any solutions you come up with.

  • Remm TWO4KAY
    Remm TWO4KAY Member Posts: 1 Newcomer

    Im late to this convo but I've been having this for a whole year! If I don't have my hardware plugged in changing values on the knobs is a MYTH! it bounces around like crazy I'm trying to tune 808s for a major song that I need finishing today and I'm having to drag it crazy and hope it lands on -5 tuning. My does this in standalone and a sa plug in with Logic Pro its so frustrating. Its a shame because maschine fits my brain lol but this bug is a joke I wish I could show a video I'm here fighting with it right now the drive ill have to take to get my MK3 is 45 mins on way and the same back something this simple shouldn't be happening at all. My computer is running super fast 32GB ram 2TB on the drive quite shocked to see there no solution I have been searching for this issue to be recognised for ages and I've only JUST come across this

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod

    @Remm TWO4KAY Do you use Waves plug-ins? What version?

  • sparra
    sparra Member Posts: 5 Newcomer

    Just to finish the converstaion 8 months later, I bought the Mk3 with all the knobs, Software buggy as always, No improvement when interfacing with it via the computer, Latest version too. MK3 definitely interfaces with the software better than the Mikro ever will & makes changing parameters a lot easier, It's quicker & workflow improves but certain pages don't function as good as they do on the Mikro. It doesn't operate exactly the same as the Mikro so if you have a workflow you are going to re-learn, A bit frustrating but at least you can follow the tutorials as they were not Mikro friendly.

    Overall the Maschine software & controllers are great tools for sound design but are not a replacement for a hardware MPC or DAW like Cubase or Pro tools, You're better bouncing stuff in audio format rather than attempt to run everything 'live' either standalone or as a VST within a DAW.

    Pet hate is all the demo soundbanks & libraries remaining in the browser that you can't get rid of even using the longwinded deleting pref files procedure. Native Access is useless for refining & organizing your library & soundbank content.

    It would be nice just to install only full versions you own exclusively & pick & choose what you have available instead of all the extra junk & sounds you can see, hear & not load.

    Waves plug-ins do not alter the performance in my experience, I have waves & non waves setups i use with the controller & software, Soundtoys, Plugin Alliance, UAD2 all work faultless also, VST, VST3 & AU.

    Thanks, Hope that clears everything up for users suffering similar issues, Get the MK3 over the Mikro for workflow & improved control of the software esp the knob parameters which simply do not work without the MK3 standalone controller.


Back To Top