Bug, or Feature??? Un-numbered Cuepoints (but, not midi-mappable)

Patch
Patch Member Posts: 223 Pro
edited September 2022 in Traktor Software & Hardware

Stumbled upon something odd recently…

When you set a hotcue, then change the cue type to Grid (using your mouse/touchpad and the cue type drop down) you get an un-numbered grid marker (EDIT: Store Grid Marker as Hotcue needs to be UN-CHECKED in preferences). This is useful. Because, if you then change the type back to Cue, you get an un-numbered blue cue point. So, we can use Traktors excellent beats-to-cue feature, WITHOUT using up one of our valuable numbered Hotcues.

BUT - when you try to replicate the same thing (switch cue type to Grid, then back to cue) by mapping a midi button, the grid marker retains the hotcue number… Infuriating.

Anyone have any idea why this happens, and, how to stop it happening? I want to retain the un-numbered (blue) cuepoint, while being able to switch that cuepoint to a grid marker, then back to cue marker via a midi mapping.

Someone help me. It's driving me mad. I need to set the hotcue first, so that the cue point snaps to the grid (I've already set the grid on my tacks), then switch that cue type to grid, then back to cue type marker.

Tagged:

Comments

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,513 mod
    edited September 2022

    I do it like this (mostly for additional gridmarkers):

    1. Set the Hotcue.
    2. Turn the Hotcue into a Grid Marker.
    3. Set a second Hotcue.
    4. Remap ('Add In --> Track Deck --> Cue --> Remap Hotcue') the second Hotcue to the number of the Grid Marker. The Grid Marker becomes unnumbered. The second one needs to be active for this. Press remap once, then press the new number.
    5. Delete the second Hotcue.

    If you do this to Hotcues that are not of the type Grid Marker and you don't use all 8 numbers for different hotcues, the unnumbered Hotcues at times (sadly) automatically get assigned one of the free numbers.


    Edit: Second variation is this.

    Go to where you want the unmarked Grid Marker to be. Have SNAP active. Use the standard CUE button to snap the needle to the grid. To place the Grid Marker in this (exact) position use the assignment 'Add In --> Track Deck --> Grid --> Set Grid Marker'.

    You can also bind this to a single button. Bind the command 'Add In --> Deck Common --> Cue' to a button to snap the needle to the grid. Bind the command 'Add In --> Track Deck --> Grid --> Set Grid Marker' + Inverted to the same button to set the marker on release of the button.

  • wayfinder
    wayfinder Member Posts: 328 Guru

    Correct me if I'm wrong, but wouldn't it be easier to uncheck the "Store Grid Marker as a Hotcue" option under Preferences -> Analyze Options? Then No Grid Markers that you add will eat up any Cue Slots

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,513 mod

    That will still leave the number on the Grid Marker if you change a Hotcue to a Grid Marker manually. The setting you mentioned only applies to the auto-grid Grid Marker that is set when the beat grid is established after analyzing the track or using beat tap to create your own.

  • Patch
    Patch Member Posts: 223 Pro

    Yes - I've edited my original post to highlight this (thanks!). And it works fine when you use a mouse to change cue type to Grid, then back to Cue (you'll get an un-numbered Cue Marker! 😁 ). BUT, when you try to midi or key map Cue Type Selector, the number stays on the Grid Marker regardless of whether or not you have "Store Grid Marker as a Hotcue" checked or not.


    The functionality I need is there in Traktor. (Yay!) Unfortunately, it just cannot be midi-mapped. (Booo!)

  • wayfinder
    wayfinder Member Posts: 328 Guru

    Set a grid marker directly, and it will work!


  • Patch
    Patch Member Posts: 223 Pro

    Already thought of that - there's a problem. Obviously, Grid Markers don't snap to the existing Grid. The only tracks I want to do this on are ones where the Grid is already locked...

  • wayfinder
    wayfinder Member Posts: 328 Guru
    edited September 2022

    Check out the second variation in this post for that: https://community.native-instruments.com/discussion/comment/31010/#Comment_31010

    I think eventually it will be easier to just use regular cues for beats-to-cue (especially since it is my sincere hope that Traktor will at some point stop counting grid markers in those calculations!). If they are on numbered pads and you don't need those for anything else, you're fine. If you want to create new cues later on and the numbered cue slots are already full of beats-to-cue targets, you can always map the newly created numberless cue to one of the slots.

  • Patch
    Patch Member Posts: 223 Pro

    Unfortunately, the whole point of this is to keep my Hotcues available for Hotcue'ing. 😉


    Like I said - Traktor does exactly what I want it to, when I use the mouse/trackpad to do it. Unfortunately, when we try to midi map it, the behaviour changes...

  • wayfinder
    wayfinder Member Posts: 328 Guru

    I'm very sorry to hear that. Remapping hotcues is easy and a viable solution to the underlying problem, but if that's not good enough, you will probably have to continue to suffer for the time being 💁‍♂️

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,538 mod

    This is definitelly a bug. I can duplicate it with mapping.

    Use bome midi mouse click magic instead.

Back To Top