Komplete Kontrol m32's cc16 & cc20 are constantly moving

Options
john.cuba
john.cuba Member Posts: 5 Member
edited June 2022 in Komplete Kontrol

Hi guys, i recently have problems with my keyboard. The screen shows cc16 & cc20 are constanlty moving when midi mode, even when im not working on my daw (ableton live 10). So the problem worsens when Im producing, this glitch messes with my volumen faders. Currently im working on windows 10 & power hub. Have someone deal with similar situation? Is there some email i can ask for support.

thanks in advance!

Best Answer

  • JesterMgee
    JesterMgee Member Posts: 2,659 Expert
    Answer ✓
    Options

    Do you have a foot pedal connected?

    If so try disconnect that.

    The movement is typically due to some kind of interference issue and I have noted some users have discovered that disconnecting their foot pedal stops the issue. Since a foot pedal is nothing more than a simple switch on a wire (usually in an open state going closed) the cable itself could be acting as an antenna and picking up some kind of radio noise which affects the circuit in the keyboard. Not uncommon.

    If you do not have a foot pedal or that does not solve the issue, the same issue can also be caused through the USB cable so just make sure you use the original supplied cable, it is not coiled up in a circle and it is not running close to anything electrically noisy like a power board full of transformers, a large monitor or even parallel with electrical cables. May have to experiment a bit.

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,659 Expert
    Answer ✓
    Options

    Do you have a foot pedal connected?

    If so try disconnect that.

    The movement is typically due to some kind of interference issue and I have noted some users have discovered that disconnecting their foot pedal stops the issue. Since a foot pedal is nothing more than a simple switch on a wire (usually in an open state going closed) the cable itself could be acting as an antenna and picking up some kind of radio noise which affects the circuit in the keyboard. Not uncommon.

    If you do not have a foot pedal or that does not solve the issue, the same issue can also be caused through the USB cable so just make sure you use the original supplied cable, it is not coiled up in a circle and it is not running close to anything electrically noisy like a power board full of transformers, a large monitor or even parallel with electrical cables. May have to experiment a bit.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,015 mod
    Options

    Hey @john.cuba Do you have any other MIDI devices connected in your setup ? Please check in your Komplete Kontrol standalone application to which buttons or CC16 and CC20 are affected. The real assignment is here:

    Doublecheck Keys and Pedal for these CCs as well.

    Disconnect your keyboard and delete any MIDI assignment in the Komplete Kontrol plug-in:

    Make sure to do the same for the buttons.

  • john.cuba
    john.cuba Member Posts: 5 Member
    Options

    Guys thanks for take your time to answer. Suddenly it stops, but it may ramdonly glitch eventually. Buttons seem to be ok i dont use any other usb midi device. I do use the footswitch as a loop pedal, i will notice if problems solve by disconecting. By the way im using a surge suppressor to prevent any electric issued. Anyway I ll keep you informed. Thanks again!

  • JesterMgee
    JesterMgee Member Posts: 2,659 Expert
    Options

    By the way im using a surge suppressor to prevent any electric issued

    A surge suppressor (most of the cheap ones) won't do a thing to protect against electrical noise, brownouts, voltage drops and most "surges". Most of the simple inline suppressors you get simply have a voltage gas arrestor which is triggered under extreme high voltage conditions such as from lightning.

    A power conditioner (much more expensive) or "Active UPS" (which I run) will actually filter and condition power protecting against rise/fall in power and also noise induced BUT it will not help solve the problem if the interference is being picked up by the actual foot pedal cable itself. What you would need there if that is the case is a shielded (or better shielded) cable to the foot pedal.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,015 mod
    Options

    Interesting, so what are your settings for this loop pedal ? Can you post a screenshot ?

  • john.cuba
    john.cuba Member Posts: 5 Member
    Options

    Well i use the sustain pedal as a midi button. Just midi map the sustain on/off to session record button on ableton session view only.

    Works on any midi keyboard with sustain/fs option. For me its the perfet way to start producing a new song.

    Check this vid in case u need more details

    https://www.youtube.com/watch?v=ALmUTPoQfFk

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,015 mod
    edited June 2022
    Options

    You mention it's also happening outside of Ableton, in what context ? If you unplug the pedal, do you still have this issue with MIDI CCs moving ?

    Can you post screenshots of your MIDI assignments in the Komplete Kontrol standalone application, for knobs and pedal when keyboard connected ? and for Knobs and buttons when the keyboard is not connected ?

  • john.cuba
    john.cuba Member Posts: 5 Member
    Options

    Suddenly it start glitching again, so this time i unplugged the foot pedal and it was solved.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,015 mod
    Options

    Yes, I suspect there might be wrong assignment for the pedal, Can you post screenshots of your MIDI assignments in the Komplete Kontrol standalone application, for knobs and pedal when keyboard connected ? and for Knobs and buttons when the keyboard is not connected ?

Back To Top