No plug-in interface showing in GarageBand, only controls.

NoahK
NoahK Member Posts: 3 Newcomer
edited June 2022 in Komplete General

For the past few months I have been trying to access to the sounds from my komplete 13 package. However, I have been unable to do so. I used to be able to access the sounds, but I can't anymore. Instead, when I click on kontact, or any of the sound packages within komplete 13, I get this box that doesn't give me an option to select any sounds. I'm not sure if it's because of an update, because I'm using the M1 chip, or because I did something. I've tried everything from deleting and reinstalling, to deleting specific GarageBand parts, to checking access. If anyone else has experienced this or knows how to fix it, I'd greatly appreciate it.


Tagged:

Comments

  • Brad Yost
    Brad Yost Member Posts: 350 Pro

    The general consensus is that you have to launch in Rosetta mode on the M1 chipset until the Dev's have full compatibility built in (most likely in the fall, as it is a monumental task to port to the new architecture).

  • NoahK
    NoahK Member Posts: 3 Newcomer

    Does it matter if I use Rosetta or Rosetta 2? I'm unfamiliar with both and Not quite sure how to launch them.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @Brad Yost is correct, if you want to use NI plug-ins in Logic, you'll need to run it in Rosetta mode: How to Open Your DAW Using Rosetta

    Now for Kontakt, Kontakt is actually the only NI plug-in that doesn't need Rosetta. It should load normally in Logic. It seems that in your case, it's just the plug-in window that is not in the right view, you should be able to expand the window and let this appear, then choose Kontakt View.


  • NoahK
    NoahK Member Posts: 3 Newcomer

    @Jeremy_NI I'm using GarageBand, not Logic. Is it the same process for that as well, or is it something different?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod
    edited June 2022

    Hey @NoahK It is the same process. Please also check in your preferences that this tick is unchecked:


Back To Top