Traktor kind of crashes silently and destroys the collection within seconds

DJWildSide
DJWildSide Member Posts: 4 Sine

Hey everybody,

with the latest Traktor version installed, i played around with different font settings for the browser. When selecting a font, it is immediately reflected in the browser and you can see how the font looks and if you want to keep it or maybe change its size.

When selecting the font "Ubunto mono", the change of the font was not reflected on the UI, instead it immediately shows the default Traktor font. When trying to pick another font, nothing changed. Only the Traktors default font was displayed. Something seems to went wrong when selecting that "Ubunto mono" font. After restarting Traktor, it tells me, that my collection was corrupted and it needs to instantiate a new collection.

I think that definitely should not happen when simply picking a font for the browser. The behaviour is reproducable.

Attached to this post are the 4 font files of the font family "Ubuntu mono" that are installed on my system.

Tagged:

Comments

  • Sûlherokhh
    Sûlherokhh GermanyMember Posts: 239 Saw

    I can confirm the problems with selecting a different font, not just the one mentioned. But it hasn't destroyed my collection so far.

  • DJWildSide
    DJWildSide Member Posts: 4 Sine

    That's interesting. I had zero problems with other fonts but with the Ubuntu one. Therefore it crashed my whole collection somehow. But it's good to know that I am not the only one having this problem! :)

  • Ryan_NI
    Ryan_NI BerlinCustomer Care Posts: 157 mod

    hey all - tried to reproduce the issue on my end with UbuntuMono - Regular, and was unable to do so. this particular typeface is also, for some reason, the only version of Ubuntu that Traktor was able to pick up on from the Font Book in my macOS. What are your operating systems/setups?

  • Sûlherokhh
    Sûlherokhh GermanyMember Posts: 239 Saw

    Win10, TP 3.4.3 to short of beta. I wanted to see how every single font would look in the browser. After the first few selections (which worked) every other selection done sequentially had no effect. Before reaching the last font (can't remember how far), Traktor crashed. Only a restart makes the most recent selection show in the browser.

    I'm not sure if it was a specific font that was troublesome. I basically started from the top.

  • Dj pako
    Dj pako GreeceMember Posts: 6 Sine
    edited May 30

    The same thing happens with my two different computers running windows 10 and older versions of the traktor. After some tests of different fonts and not only with this one my collection was corrupted.In the latest beta after some tests the change of the font was not reflected on the UI, but after restart the most recent selection show in the browser and collection was not corrupted. I should add that in my collection there are many files with non-Latin characters which do not appear correctly with the default font.

  • DJWildSide
    DJWildSide Member Posts: 4 Sine

    Also a Win10 machine where this initially happened. I tested with MacOS a few days ago and had no problems whatsoever. The saddest thing was, that it corrupted my entire collection when crashing.

Back To Top