Traktor BUG: sudden loud hum in front of 400 people

creal
creal Member Posts: 19 Sine

Hello,

Yesterday night, I had a big gig in Monaco. An event that could not be failed.

The party began. I played some songs with my Kontrol S4 MK3 plugged into a Windows 11 laptop. But suddenly, when I was searching the next song to play, the current song stopped and a big hum took place instead! My audience (and I) was very disappointed and I had to launch a backup song with an Android tab.

It was very frustrating and now I am stressed that this unacceptable behaviour reappears someday.

To be precise: no action triggered the hum (it happened randomly), no song could be played during the hum, and I was forced to close Traktor to stop the hum. Then I re-opened it to resume the party but it was very stressful til' the end.

How are your feelings about it? Is that something already happened to you? How can I prevent this bug?

Maybe it's a problem of drivers/converters?

I precise that all my programs are up to date and my gear is clean. I am very careful about these things.

Thanks for your help,

This is urgent because I have another gig a the end of the week.

Cyril.

Tagged:
«1

Comments

  • Ryan_NI
    Ryan_NI BerlinCustomer Care Posts: 157 mod

    hey @creal - sorry to hear this happened to you!

    could you download the S4 MK3 ASIO driver and see if the issue persists? additionally, please download the firmware updater and update the firmware:

    If the issue is still happening, I highly recommend going through the steps in the link below:

    Windows Tuning Tips for Audio Processing

  • olafmol
    olafmol Member Posts: 89 Tri
    edited May 23

    Sounds like an audio driver issue. This is why I work on a MacBook, although you can also have a stable windows setup if you know how to setup your ASIO drivers correctly. Also disable everything that’s not needed: WiFi, network card, no usb hubs, virusscanners, firewalls, background processes etc etc

    tbh, I always carry 2 rekordbox usb sticks to be used with the pioneer CDJs and mixer that most professional venues have. If the gig is so important make sure you’re well prepared and make sure there is a backup system.

  • creal
    creal Member Posts: 19 Sine

    Hello Ryan,

    Thanks for your help but both the driver and the firmware were up to date. By superstition, I uninstalled then installed the driver (but not the firmware, should I have ?).

    I always worked with 48kHz and 256 samples. Maybe I have to work with 44.1kHz and 512 samples? But the laptop is brand new, so there is no worries regarding potential performance issues.

    Thanks for your link. I already optimized Windows and my audio apps, but I am sure there is interesting information I am not aware of.

    Cyril.

  • creal
    creal Member Posts: 19 Sine

    Thanks for your advices olafmol.

    I always run the PC in airplane mode. This time, I admit that my phone was plugged into the second USB-c port because I forgot to unplug it just before the gig. I hope it was only that that caused the problem. The Windows Defender firewall is always active but not effective since I am running Windows in airplane mode when I am deejaying.

    I have a backup with an Android tab (but I must buy a second laptop for great gigs).

    One thing that disappointed me a lot is that Kontrol S4 MK3 works in Standalone mode only if you unplug it from the laptop. Thus it is not optimal as a backup mixer. I think for the next season I will end up with a Mac and Pioneer system to be safer.

    I took my day off today to test all the gear and be prepared for saturday night. I hope it will be fine.

    Have a nice day,

    Cyril.

  • Knivshult
    Knivshult Member Posts: 12 Sine
    It sounds to me more like a possible cable error
    


  • creal
    creal Member Posts: 19 Sine
    edited May 26

    Really? It's the Native Instrument USB cable. But I have another one. Maybe should I change for the next gig? What is weird is that the hum appeared suddenly/randomly, without touching the cable at all.

    How to test the potential guilty cable?

  • olafmol
    olafmol Member Posts: 89 Tri

    Was this the first time you are using this new laptop? Sometimes certain drivers/hardware components can cause havoc with audio or USB. F.e. check which USB port for your specific laptop might be the most stable to use. 48Khz and 256 samples should be good, just make sure your CPU doesn't spike, if it's low and stable your laptop is able to run this. I always change the sample-size up/down and back in Traktor settings before a gig, i believe it resets a buffer somewhere which make it more stable for longer multi-hour sets.

    The only way to test is to setup exactly like you had on your gig and test for a few hours to see if all runs stable.

  • creal
    creal Member Posts: 19 Sine

    Thanks olafmol,

    It was the second time I use this laptop for a gig.

    There is only one USB type A port.

    The CPU never goes beyond 5% when using Traktor in a live situation.

    Okay for the sample buffer size trick. I will do it.

    I am testing now since a few hours and everything goes well.

    I cross the fingers for saturday night. To be safer, I will set a real mixer between the Kontrol S4 and the loudspeakers system. And bring another laptop with Traktor and updated tracks.

    I will give another 4-hours test on saturday morning.

  • Aleix Jiménez
    Aleix Jiménez Barcelona (Spain)Member Posts: 55 Expert
    edited May 27

    Have you verified with LatencyMon if your laptop is working properly prepared for live audio situations?

    A few years ago I bought an HP Spectre for university + work (which I still own) with an i7 processor more than ready (in theory) to run Traktor.

    However, there were (and still are) huge issues with the Audio Latency that made my laptop WITH Windows 10 (and also tested with 11) unsuitable for live peformances. Blame it on Microsoft and their ACPI controllers.

    EDIT: If anyones wonders, yes, I did clean installs of the OS, without bloatware, updated all drivers with official packages, etc.

    I also tested NI’s and Ableton audio optimization guides, checked the issue with HP, and reported it to Microsoft after realizing that it was something related to the ACPI controller and Power Management…

    The saddest thing, though, is that my father has a 1 year older HP Elitebook that runs everything ultrasmoothly.

    And to make matters worse, I installed macOS for testing purposes only (what is known as Hackintoshing), and my HP runned Traktor Pro very smoothly, in the exact same hardware.

    I do not mean that Windows isn’t suited for audio performances, and macs also have their stuff, but I would always recommend macOS over Windows for DJing, based on my experience…

    I still rock an old 2012 MBP for DJing 👀

  • Stevan
    Stevan MIDIMember Posts: 237 Saw

    With Windows, there is a 50:50 chance that something can go wrong because of ***** drivers. I'd say stress test it well before the gig and disable everything you can - I even debloated one of my old laptops (i7, 8GB RAM) so it can work without latency issues.. Even most powerful Alienware laptops cannot run Traktor smoothly.

    Regarding PS/windows I'd only consider using something like XMG DJ 15.

  • creal
    creal Member Posts: 19 Sine
    edited May 30

    I haven't tested yet with LatencyMon but I will do during the week.

    In fact, if I have other trouble (only one) with my PC/controller before the end of the year, I will consider buying a Mac for the next summer season.

    EDIT: by the way, no issue at all during the previous gig two days ago (and I had 2 backups, just in case...). Next gig in two weeks (for a private wedding).

  • Knivshult
    Knivshult Member Posts: 12 Sine
    Noise can sometimes be due to a fault in the grounding of one of the cables connected to equipment. Have you tried to replace all cables. Also from possible mixers and / or controllers? Have you connected directly to the Pa system or did you connect via cable to another mixer?
    If you turn on the sound at home, do you have the same problem as when you last played elsewhere?
    


  • creal
    creal Member Posts: 19 Sine

    Hi Knivshult,

    When the problem appeared (once out of 15 years of deejaying), the controller was directly connected to the mixer.

    In the meantime, I did another gig with exactly the same config (and cables) but everything ran smoothly.

    I have another gig in the same place next week, but I will put a mixer between the controller and the PA system, just in case.

  • Kubrak
    Kubrak Member Posts: 1,036 Pulse

    DI box between S4 audio output and PA might be also solution. It may completely resolve ground loops, if that was problem. But I guess, ground loop was not the cause of your problem. If it had been, the hum would be there all the time, not suddenly occuring....

    What about cooling of your laptop? Is it good? Did you play at night, or day. Inside or outside? High temperature of notebook might result in instability and something like you describe.... If you played outside and sun shined to notebook/S4, temperature might go very high...

Back To Top