I have a problem with updating my Kontrol S88 mk3

I have a problem with updating my Kontrol S88 mk3


Answers

  • mykejb
    mykejb Moderator Posts: 809 mod

    What exactly is the problem? Are you trying to do the update on a PC or a Mac ?

    -- Mike

  • dutty
    dutty Member Posts: 2 Newcomer

    Me too...I have a feeling this was one of the things wrong with the Controller and caused the delays. NI dropped the ball. I smell a class action lawsuit coming.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Piotr Matuszkiewicz Have you tried these steps? S88 MK3 - How to fix Windows Driver and Firmware updater issues.

    @dutty Have you tried that as well? What controller do you mean? What would be wrong with it?

  • Bossynth
    Bossynth Member Posts: 8 Newcomer
    I am trying to update firmware on a Mac OS 14.3.

    I've tried everything I can see here, I want it to work....

    Is there some secret I am missing? It just should not be this difficult.
  • PoorFellow
    PoorFellow Moderator Posts: 1,538 mod
    edited February 17

    As I wrote over here then using an USB-C to A adapter apparently has been a solution for more Mac users , though I can not guarantee that it will help in your specific case , especially not with the existing problems also with some adapters themselves :

    https://community.native-instruments.com/discussion/comment/133877/#Comment_133877

  • BIF
    BIF Member Posts: 423 Pro
    edited February 17

    What adapter are we talking about? A power adapter? Or a USB Hub?

    For the power adapter, I use an old Apple AC adapter with a 20 Watt rating and a USB-C female connector on it. I think it's from an old iPhone purchase. Plugged into that is an 8-foot USBC to USBC cable plugged into the PD port on the back of the KK MK3 unit. This only provides power.

    On the data side, I use a long USB-C extension cable (male plugged into the computer motherboard and famale plugged into a passive J5 hub. Coming out of the hub is the MK3's included USBC cable, which is then plugged into the MK3's USB-C port (not the one labeled "PD").

    This has worked for me.

    The only reason I use the hub is because once I set up my home office/studio, I'm going to want to plug some other USB-C devices in near the MK3, and the hub gives me capacity to support 2 USB-C devices (one being the MK3) and 2 USB devices, such as a Push or Maschine, etc.

    I hope that helps. Links follow. This is just what worked for my Windows 11 machine.

    J5 Hub: JCH342EW <-- you can find this on Amazon

    Cables: USB-C extension cable <-- Amazon

    ...and USB-C Charging Cable <-- Best Buy (yep, bought in a store)

  • Bossynth
    Bossynth Member Posts: 8 Newcomer
    I was able to update with a generic USB C to USB A cable. There was not enough power to complete update so I plugged in an apple power usb c cable with apple wall power. Finally it was able to do the update. I am now using the original NI cable but I am experiencing crashes in LOGIC. Maybe the cable is bad or not sheilded well (I bet that is likely).
  • PoorFellow
    PoorFellow Moderator Posts: 1,538 mod

    My bad , I was referring to the USB-C to A adapter that I were referring to in the other thread. I added that in the above port before yours , thank you !

Back To Top