Problem with Maschine export of audio drag and hold not working

DiMuTech
DiMuTech Member Posts: 8 Member

Is anyone else having a problem with this not working. I click the icon and nothing happens. I have tried in Live and Bitwig


Tagged:

Best Answer

  • D-One
    D-One Moderator Posts: 2,733 mod
    edited December 2023 Answer ✓

    Drag and drop works both as plug or standalone but….

    Judging by your screenshot having tons of Ableton tracks I reckon you have the outputs going from MAS-plug to the DAW tracks… In such a scenario export/drag-and-drop does not work because all Audio is not being used in MAS, so there’s “nothing” to export, as it’s effectively being bypassed and just sent to the DAW.

    You can, however, arm the DAW tracks and record normally as it plays.

    To confirm make a new Ableton project, load any random Group in MAS-Plug with pattern data (without outputs setup up to DAW), and try drag-and-drop, just to make sure it's working.

Answers

  • Sunborn
    Sunborn Member Posts: 2,178 Expert
    edited December 2023

    The way you described is how we usually export audio from Maschine as stand alone.

    If you use the Mascine as a plugin in a DAW, you should use the export options of the DAW (Live or Bitwig), not Maschine

  • DiMuTech
    DiMuTech Member Posts: 8 Member
    edited December 2023

    Thank you for response even though you are wrong in the information you provided.

    By clicking the icon and holding down the mouse button when using Maschine as a VST plugin inside a DAW, it exports an audio clip of the group.

    However here is another piece of information i have just found out whilst investigating the issue.

    It turns out this feature is disabled or doesn't work due to a bug, when routing each individual sound to it's own channel within the DAW. Example Pad 1 to EXT 1, Pad 2 to EXT 2 etc etc etc. I loaded up another Maschine project inside my DAW and routed group A1 to the separate EXT channels and you see B1 is routed to the group output, A1 doesn't work to export audio but B1 does work.

    So is this a bug to be reported or is this something that just is as pat of the program?

  • Sunborn
    Sunborn Member Posts: 2,178 Expert

    Yep i know that. It was not at all a "wrong" information however. I didn't wrote that you "can not", i wrote that "you should".

    Because usually we do it that way, mostly because we have more flexibility and more options when we export through DAW, for example we can include all the effects we used. ...or maybe just because its an old studio habit... :-)

    For the rest you are correct, though i can't say for sure if its a bug, because i can not remember a similar case in the past. However, even if you are the only one with that problem, you should report it, but before you do, lets ask a Maschine expert first. @D-One ?

  • D-One
    D-One Moderator Posts: 2,733 mod
    edited December 2023 Answer ✓

    Drag and drop works both as plug or standalone but….

    Judging by your screenshot having tons of Ableton tracks I reckon you have the outputs going from MAS-plug to the DAW tracks… In such a scenario export/drag-and-drop does not work because all Audio is not being used in MAS, so there’s “nothing” to export, as it’s effectively being bypassed and just sent to the DAW.

    You can, however, arm the DAW tracks and record normally as it plays.

    To confirm make a new Ableton project, load any random Group in MAS-Plug with pattern data (without outputs setup up to DAW), and try drag-and-drop, just to make sure it's working.

Back To Top