Issue with Kontrol S88 MK3

gcorcella Member Posts: 52 Member

Hi there,

I am experiencing an issue setting up my S88 MK3. I have registered it via NA and installed the Hardware Connection Service. When I try to update the firmware, it keeps saying to connect the keyboard and press Rescan even if it's connected already. And if I press rescan nothing happens.

I tried different USB-C cables on different ports and even to connect another USB-C to get additional power.

Any idea on how to fix it?



  • nightjar
    nightjar Member Posts: 1,080 Guru

    Trying a usb-c hub or a different usb-c port on your computer is a first step to try

  • gcorcella
    gcorcella Member Posts: 52 Member

    i tried different cables and also to connect it to a USB3.0 port. On my laptop the updater finds the keyboard but it says the keyboard failed to boot into firmware update mode.

  • Tim_NI
    Tim_NI Product Team Posts: 42 mod

    Sorry to hear that you are experiencing these issues. Can you provide more information regarding your setup (computer, OS, etc)?

    If you are using a non-MagSafe Mac, try using the USB-C power cable (you shouldn't need to do this, but it helps to narrow down the issue).

  • AGK
    AGK Member Posts: 4 Newcomer

    hi same problem and the first wheel do a noise when the second wheel is placed at bottom.

  • Jonas Denolf
    Jonas Denolf Member Posts: 4 Newcomer

    I hate the same issue, tried another data cable bought a fresh Type C Power Supply and still no luck if anyone has a fix for the firmware please post it i can't use the features of the S88 MK3 until i update the firmware :(

  • Jonas Denolf
    Jonas Denolf Member Posts: 4 Newcomer
  • Yarda
    Yarda Member Posts: 4 Newcomer

    Hello. I downloaded the Kontrol S MK3 Updater and it shows me the new firmware, but even though I've tried to update several times, it always says an error.


    Device name LAPTOP-DHEEC4FA

    Processor Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz 2.59 GHz

    Installed RAM 80.0 GB (Usable: 79.8 GB)

    System type 64-bit operating system, processor for the x64 platform

    Windows 11 Home 22H2


  • Jonas Denolf
    Jonas Denolf Member Posts: 4 Newcomer

    As many above i also have the same issue, Downloaded Kontrol S MK3 Updater i have been recommended to try a new c power supply i tried that but no luck the power supply was 65 W and contains 12V/24V


    OS Name Microsoft Windows 11 Pro

    Version 10.0.22621 Build 22621

    Other OS Description Not Available

    OS Manufacturer Microsoft Corporation

    System Name JONASPC

    System Manufacturer System manufacturer

    System Model System Product Name

    System Type x64-based PC


    Processor Intel(R) Core(TM) i9-9940X CPU @ 3.30GHz, 3312 Mhz, 14 Core(s), 28 Logical Processor(s)

    BIOS Version/Date American Megatrends Inc. 3403, 19/03/2021

    SMBIOS Version 3.2

    Embedded Controller Version 255.255

    BIOS Mode UEFI

    BaseBoard Manufacturer ASUSTeK COMPUTER INC.


    BaseBoard Version Rev 1.xx

    Platform Role Desktop

    Secure Boot State Off

    PCR7 Configuration Elevation Required to View

    Windows Directory C:\Windows

    System Directory C:\Windows\system32

    Boot Device \Device\HarddiskVolume4

    Locale United Kingdom

    Hardware Abstraction Layer Version = "10.0.22621.1413"

    Username JonasPC\JonasLOCAL

    Time Zone Romance Summer Time

    Installed Physical Memory (RAM) 128 GB

    Total Physical Memory 128 GB

    Available Physical Memory 107 GB

    Total Virtual Memory 136 GB

    Available Virtual Memory 109 GB

    Page File Space 8.00 GB

    Page File C:\pagefile.sys

    Kernel DMA Protection Off

    Virtualisation-based security Not enabled

    Windows Defender Application Control policy Enforced

    Windows Defender Application Control user mode policy Audit

    Device Encryption Support Elevation Required to View

    Hyper-V - VM Monitor Mode Extensions Yes

    Hyper-V - Second Level Address Translation Extensions Yes

    Hyper-V - Virtualisation Enabled in Firmware Yes

    Hyper-V - Data Execution Protection Yes

  • Jonas Denolf
    Jonas Denolf Member Posts: 4 Newcomer

    Started having this message after trying to update with a power supply still not able to update

  • Chris_NI
    Chris_NI Product Team Posts: 47 mod
    edited October 19

    Hi all,

    I'm really sorry you are all experiencing issues updating the Firmware.

    If you have already tried the following:

    • Plugging the HOST USB-C cable into different ports on the computer (especially for Windows)
    • Use a USB-C hub for HOST USB-C cable (Between the keyboard and your computer)
    • Using the USB-C PSU plugged into the power only port (while the other HOST is connected to your computer)

    Then you can try to put it in recovery mode.

    Recovery mode; this is taken from our Knowledge base page which is updated daily with any new troubleshooting tips we identify

    Power cycle the keyboard 5 times. At the 5th time, the recovery screen should appear and you can re-update the controller. In order to power cycle, turn on the device, wait 2-3 seconds and then turn it off again. Please repeat this 5 times. If you receive a prompt during this process to allow the connection, please allow.

    When to contact support?

    Please let customer support know if you see this screen below after the FW update failed (please notice the - in the installed FW and Serial number fields). This indicates that we need to replace the keyboard as the failed Firmware is corrupted to the point where we need to fix it in our repair centres. If you see the standard 'Failed to boot into Firmware update mode screen, then your keyboard should be able to update the Firmware, and replacing the keyboard will likely not fix the issue.

  • Torsten 2023
    Torsten 2023 Member Posts: 10 Newcomer

    I bought the S88 MK3 yesterday and I have the same problem with this firmware update. I have tried all suggestions from the Support site of NI, but the error is still the same. I have absolutely zero sympathy for the fact that a device in this price range is shipped to customers with outdated firmware and that, on top of that, there are such problems installing new firmware on the customer side.

  • Chris_NI
    Chris_NI Product Team Posts: 47 mod

    Hi @Torsten 2023

    Which computer OS are you on? Windows / Mac, and version number?

    In-market firmware updates are a completely standard process. The keyboards are manufactured many months before they reach the customers and advancements in firmware are made, much like standard in-market software releases.

    This process will continue in the future as well, as it evolves over time with the software, for example with the Kontrol S-Series MK3, very soon we will unlock on-device functionality like standalone Play Assist (which is currently in development), and will likely require another Firmware update, along with software.

    Its more important that we find out the root cause of the issues you are all experiencing (eg: with Windows 11, or various hardware configurations that PC computers are built with, processors involved, so far its predominately Windows being problematic).

    I thank you for your understanding, and please do let us know the specs of your computer you are having issues with.

  • Torsten 2023
    Torsten 2023 Member Posts: 10 Newcomer

    Hello Chris,

    I am working with an AMD Ryzen machine based on Windows 10, all updates and drivers are up to date. I have also tried the update via another computer with Windows 11 installation, here the same problem appears.

    There is nothing against firmware updates, but they must also work and be applicable for the customer. I also just don't have the time to spend hours on a firmware update. The expectation was that I would buy a high-quality, technically mature and functional device that would make my work more pleasant. Exactly the opposite happened.

  • FlipBit
    FlipBit Member Posts: 15 Newcomer

    Just got mine and I have the same issue:

  • GhostriderGlenn
    GhostriderGlenn Member Posts: 17 Newcomer

    I am waiting on my New S88 to arrive. This thread is worrisome. Quick question to the users with the software failure. Did you all load any software or was this a mandatory update when you first connected to your computers? When you first connected did it recognize any new hardware? I am a noob, with NI products, but untired/retired Systems Analyst.

Back To Top