"please grant permission to native access to install dependencies"

Alfaedu
Alfaedu Member Posts: 4 Newcomer

After having everything working fine for two weeks (downloading and installation of all files, Native Access, Maschine 2 and Maschine Mk3), this morning I downloaded an update and got stuck on this error message. I have tried for several hours all the answers I saw on this topic but no luck. Sideline question: if it was working before why it is asking for permission now?

Anybody got any information on how resolve this problem?

Thanks


Answers

  • Alfaedu
    Alfaedu Member Posts: 4 Newcomer
    edited September 2023

    Thank you for your response. After more hours trying to fix the update following all the steps detailed in the link, unfortunately none worked.

    At the end I went into chrome's history and I downloaded the previous version that I used to install everything in August, and miraculously worked instantly (even after alllll the things I touched and changed up and down the Registry, Folders, Permissions, etc.!! --- I will remember next time to do a Restoration Point before any update).

    Ok, now, I have to stop the new update to install again, because when this version started, the automatic updates setting (I didn't see any ON-OFF settings for this) asked me the usual: "when do you want to install the update now or at restart?"

    Do you know how to stop installing the new update, other than never shut off the program and computer again (ha)?

    Thanks so much


    1st Edit

    After I pinned the program to the taskbar I closed it and with that new shortcut I tried to open it and it would not open, it goes directly to the error message that I posted on the first message. Native access only works when installed from the 3.5.1 August version, but it wouldn't keep its settings.

  • Retro5
    Retro5 Member Posts: 1 Newcomer

    This is exactly why people pirate software. The official software is clunky AF never works. updated for no reson and then breaks. I have this same issue. and also an issue with WAVES CENTRAL. not loading powershell. driving me equally insane. THESE COMPANIES SUCK. ABSOLUTLEY SUCK.

Back To Top