KSP, mad issue with snapshots and GUI, all knobs stopped working also in backup copies!

rattala
rattala Member Posts: 5 Member
edited September 2023 in Scripting Workshop

I have an issue with a script that is driving me crazy, literally ! tried to be methodic so any time I have reached a point where a function was complete I have saved a copy of the script and start working to the new function.

The script basically shows some FX buttons that can trigger the opening of a different section of the GUI with different background, that shows the advanced knobs to play with that FX controls, so you click the knob and you can show\hide the GUI controls.

Every FX has its own bypass button, too. All of these buttons were 100% working and have been tested every time I have started working to the new version of the script.

The problem started when I was trying to understand how to use snapshots and I have probably removed a couple of them I have previously created and (not sure if this is the cause), from that point on, every button in the GUI stopped triggering the GUI show\hide and the bypass functions, no errors are shown after applying the script.

The issue is present also with previous version of my scripts that I haven't touched and that I have saved when they were 100% working! Tried to create a new instrument from scratch and copy only relevant pictures, created a new resource container, tried different copies of the istrument saved during the process, tried to apply to each version of the instrument a different version of the script saved over time. All these combinations have show the same issue !!!

This is crazy and probably due to my misunderstanding of something, but I can't figure out what is, it seems totally mad.

Ttried to read the manual again and again, now I'm out of ideas.

Thanks in advance for your kind help.

Comments

  • noY_T
    noY_T Member Posts: 37 Member

    Can you post the lines of code where you hide whatever you're hiding? And also the bypass functions

  • rattala
    rattala Member Posts: 5 Member
    edited September 2023

    hI, found the way to repeat the issue, somehow. It seems (incredible but true) related to some kind of crash of my audio driver. it happened again a couple of times, I have disconnected the Komplete audio 6 usb cable then re-connect it and checked Asio driver audio was working fine, closed and re-opened my DAW (Reaper), dragged and dropped my NKI instrument again and the magik happened (no more issues).

    It's absolutely mad and counter-intuitive for me (I was thinking to an issue related to the code but could not explain why all previous tested version of the code were affected to the issue, too, seemed "impossible" to me), I hope to be able to double check this in the next days, i have more than 1 asio driver on my pc, maybe a conflict ? not sure but it seems to have solved here a couple of times already, so let's see in the next days how it goes.

    I hope this maybe of help to someoneelse, I've lost a lot of time trying to figure out this tricky situation.

    PS: my NKI is developed on Kontakt 7, Reaper is updated to last version, OS is Win 10.

  • EvilDragon
    EvilDragon Moderator Posts: 1,021 mod

    Since Kontakt scripting runs in the realtime audio thread, if the audio engine is not running, the scripts won't run either.

Back To Top