my komplete kontrol mk2 is sending out midi cc18 ..need help

djwaxxy
djwaxxy Member Posts: 10 Sine
edited March 13 in Komplete Kontrol

im using cubase and when i goto record its already sending out midi cc messages before i begin to play so it creates a bar off midi cc .

when i start recording yet more cc messages are getting sent out as well as velocity/modulation so then i start getting weird stuff going on in cubase.

ive only got a sustain pedal in my rear port 1 but its sending cc messages wether i stamp on it or not.

can anyone help ?

im on windows 10 if that helps..

thanks

Tagged:

Comments

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 834 Saw

    Sounds like one of the knobs is not working properly. Are you using Komplete Kontrol as a plugin or are you just using the KB in "Midi Mode" (the default if KK not loaded)? If not using KK, close Cubase, open KK standalone and open the midi assignment editor. (midi din icon top right) it should show which knob is controlling CC18. By default if you have not made any Midi Assignment modifications, it is probably Knob 5.

    At that point, try setting the "Assign Type" of the knob set to CC18 to "None". close the assignment editor, then close KK, and try a recording in Cubase to see if CC18 is being sent out... if not, then the knob is the culprit... try turning it a bunch of times, as it might be dirty... then turn it back on again and try recording...rinse and repeat a couple of times just to be sure... if the behavior continues, the unit may need repair... get in touch with support about that!

    The sustain pedal is CC64, are you seeing any of those Recorded? if not then that is not the issue.

    report back your findings...

  • djwaxxy
    djwaxxy Member Posts: 10 Sine

    thanks ill give it a try

  • djwaxxy
    djwaxxy Member Posts: 10 Sine

    hi ive done what you said but im still getting a cc18 message getting sent half a bar in once i record..the ghost bar recording which was happening at the begging of each record has now gone but im getting this weird cc18 (gen purpose) note from somewere.

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 834 Saw

    Just curious as to what VSTi you are using when this happens? Or does it happen with ALL instruments. If happening on all instruments I am wondering that due to a hardware issue, that the movement of the KB during playing is causing the CC18. (cause some sort of short circuit???)

  • djwaxxy
    djwaxxy Member Posts: 10 Sine

    ive found the problem i think..

    my record button on komplete kontrol is the one sending cc18 messages.and the cc18 switches on or off parameters in whatever is assigned to it in a vst and other parameters in cubase.

    how do i fix this?

  • JesterMgee
    JesterMgee Custom NKS Libraries: freelancesoundlabs.com/nksMember Posts: 391 Saw

    Do you have the DAW midi port selected as a midi control port in your Cubase preferences, it should not be set for MIDI control so deselect it.

  • djwaxxy
    djwaxxy Member Posts: 10 Sine

    thanks ill give it a try..

    just noticed in my midi input option on my vst tracks it shows 4 komplete kontrol midi out..1 komplete kontrol daw..1 komplete kontrol ext ..and 1 komplete kontrol midi1..that seems like a lot of komplete kontrol instances.

  • JesterMgee
    JesterMgee Custom NKS Libraries: freelancesoundlabs.com/nksMember Posts: 391 Saw

    Prob should read up on what the ports are, they each have a different function. I’m on my phone so too lazy to explain them but it’s covered in the manual somewhere.

Back To Top